summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonathan Smith <smithj@gentoo.org>2005-07-09 08:01:44 +0000
committerJonathan Smith <smithj@gentoo.org>2005-07-09 08:01:44 +0000
commit9248b76a430ff533267a456a5e1e00e168966d21 (patch)
tree9bf0b08137623e3d2dd666202467f1dab0f822b3 /x11-misc/openclipart
parentstable amd64 (diff)
downloadgentoo-2-9248b76a430ff533267a456a5e1e00e168966d21.tar.gz
gentoo-2-9248b76a430ff533267a456a5e1e00e168966d21.tar.bz2
gentoo-2-9248b76a430ff533267a456a5e1e00e168966d21.zip
version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-misc/openclipart')
-rw-r--r--x11-misc/openclipart/ChangeLog7
-rw-r--r--x11-misc/openclipart/Manifest16
-rw-r--r--x11-misc/openclipart/files/digest-openclipart-0.151
-rw-r--r--x11-misc/openclipart/openclipart-0.15.ebuild78
4 files changed, 87 insertions, 15 deletions
diff --git a/x11-misc/openclipart/ChangeLog b/x11-misc/openclipart/ChangeLog
index 5c437bde08b3..dacb90f04437 100644
--- a/x11-misc/openclipart/ChangeLog
+++ b/x11-misc/openclipart/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/openclipart
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/openclipart/ChangeLog,v 1.3 2005/07/09 07:34:31 smithj Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/openclipart/ChangeLog,v 1.4 2005/07/09 08:01:44 smithj Exp $
+
+*openclipart-0.15 (09 Jul 2005)
+
+ 09 Jul 2005; Jonathan Smith <smithj@gentoo.org> +openclipart-0.15.ebuild:
+ version bump
09 Jul 2005; Jonathan Smith <smithj@gentoo.org> openclipart-0.12.ebuild:
added ~amd64
diff --git a/x11-misc/openclipart/Manifest b/x11-misc/openclipart/Manifest
index 51495f5ae413..9bda5e1be558 100644
--- a/x11-misc/openclipart/Manifest
+++ b/x11-misc/openclipart/Manifest
@@ -1,14 +1,2 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 8dad4c602e8fc48cf21cf32d762b9af0 metadata.xml 231
-MD5 4390d1aa737c30bb147c2afdc2b573e3 ChangeLog 615
-MD5 9dacf2861d12592877acc8a5d56e909a openclipart-0.12.ebuild 1981
-MD5 9ae01cef1127f8736b4ad6c8f1cb15bb files/digest-openclipart-0.12 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCz34cl5AvwDPiUowRAsz1AKDZd4pvpU8Z+S5LTG1ZAvz18k6UaACgzVIW
-xHrxpzjd6RlbHS7/cjj2HV0=
-=pOut
------END PGP SIGNATURE-----
+MD5 33da4be4426f80cf3e2b817516690c1a openclipart-0.15.ebuild 1980
+MD5 8cea0f6a7884b60e03f7459fab352510 files/digest-openclipart-0.15 71
diff --git a/x11-misc/openclipart/files/digest-openclipart-0.15 b/x11-misc/openclipart/files/digest-openclipart-0.15
new file mode 100644
index 000000000000..92659e620862
--- /dev/null
+++ b/x11-misc/openclipart/files/digest-openclipart-0.15
@@ -0,0 +1 @@
+MD5 813f22e41f883fe23dc42a075c4bb120 openclipart-0.15.tar.bz2 78831798
diff --git a/x11-misc/openclipart/openclipart-0.15.ebuild b/x11-misc/openclipart/openclipart-0.15.ebuild
new file mode 100644
index 000000000000..49d29c949c66
--- /dev/null
+++ b/x11-misc/openclipart/openclipart-0.15.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/openclipart/openclipart-0.15.ebuild,v 1.1 2005/07/09 08:01:44 smithj Exp $
+
+inherit eutils
+
+DESCRIPTION="Open Clip Art Library (openclipart.org)"
+HOMEPAGE="http://www.openclipart.org/"
+SRC_URI="http://www.openclipart.org/downloads/${PV}/${P}.tar.bz2"
+
+LICENSE="public-domain" # creative commons
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc svg png pdf wmf gzip"
+
+# we don't really need anything to run
+DEPEND=""
+RDEPEND=""
+
+# suggested basedir for cliparts
+CLIPART="/usr/share/clipart/${PN}"
+
+select_files() {
+ # select wanted formats, optionally compress them
+
+ local FILE SVG="" PNG="" PDF="" DOC="" COMPRESS=""
+ use svg && SVG="svg"
+ use png && PNG="png"
+ use pdf && PDF="pdf"
+ use wmf && WMF="wmf"
+ use doc && DOC="doc"
+ use gzip && COMPRESS="yes"
+
+ find "$1" -type f -mindepth 1 -maxdepth 1 | while read FILE
+ do
+ local NAME="${FILE%.*}" EXT="${FILE//*.}" YES=0
+ if [ -n "$EXT" ]
+ then
+ if [ "$SVG" = "$EXT" -o "$PNG" = "$EXT" -o "$PDF" = "$EXT" -o "$WMF" = "$EXT" ]
+ then
+ if [ "$SVG" = "$EXT" -a -n "$COMPRESS" ] # compress SVG
+ then
+ gzip -9 < "${FILE}" > "${FILE}z" && echo "${FILE}z"
+ else
+ echo "${FILE}"
+ fi
+ if [ -n "$DOC" -a -f "${NAME}.txt" ] # if clipart has a description ...
+ then
+ gzip -9 "${NAME}.txt" && echo "${NAME}.txt.gz" # ... then compress it always
+ fi
+ YES=1
+ fi
+ fi
+ if [ $YES -eq 1 -a -f "${1}/README" ]
+ then
+ gzip -9 "${1}/README" && echo "${1}/README.gz"
+ fi
+ done | sort -u # kill dupes
+}
+
+src_compile() {
+ einfo "nothing to compile"
+}
+
+src_install() {
+ local DIR FILES
+ dodoc LICENSE.txt README.txt
+ find -type d | sort | while read DIR
+ do
+ FILES=$(select_files "$DIR")
+ if [ -n "${FILES}" ]
+ then
+ einfo "Installing ${DIR#*/}"
+ insinto "${CLIPART}/${DIR#*/}"
+ doins ${FILES}
+ fi
+ done
+}