summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-05-16 03:36:12 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-05-16 03:36:12 +0000
commit02939313f478e46134eb28aa913dba81f967c67a (patch)
tree3820652ff6f6d3f5e104122399bcfbf88ff000f3 /x11-misc/mixer_app
parentAdd ~x86-fbsd. #412915 (diff)
downloadgentoo-2-02939313f478e46134eb28aa913dba81f967c67a.tar.gz
gentoo-2-02939313f478e46134eb28aa913dba81f967c67a.tar.bz2
gentoo-2-02939313f478e46134eb28aa913dba81f967c67a.zip
Respect CXX, CXXFLAGS and LDFLAGS wrt -build.patch. Mark stable for amd64 (following others). Fix HOMEPAGE wrt #416187 by "df".
(Portage version: 2.2.0_alpha105/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/mixer_app')
-rw-r--r--x11-misc/mixer_app/ChangeLog9
-rw-r--r--x11-misc/mixer_app/files/mixer_app-1.8.0-build.patch44
-rw-r--r--x11-misc/mixer_app/mixer_app-1.8.0.ebuild33
3 files changed, 69 insertions, 17 deletions
diff --git a/x11-misc/mixer_app/ChangeLog b/x11-misc/mixer_app/ChangeLog
index 1d940e2bd225..aac1a0c985c2 100644
--- a/x11-misc/mixer_app/ChangeLog
+++ b/x11-misc/mixer_app/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/mixer_app
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/mixer_app/ChangeLog,v 1.19 2007/07/22 03:59:10 dberkholz Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mixer_app/ChangeLog,v 1.20 2012/05/16 03:36:12 ssuominen Exp $
+
+ 16 May 2012; Samuli Suominen <ssuominen@gentoo.org> mixer_app-1.8.0.ebuild,
+ +files/mixer_app-1.8.0-build.patch:
+ Respect CXX, CXXFLAGS and LDFLAGS wrt -build.patch. Mark stable for amd64
+ (following others). Fix HOMEPAGE wrt #416187 by "df".
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
mixer_app-1.8.0.ebuild:
diff --git a/x11-misc/mixer_app/files/mixer_app-1.8.0-build.patch b/x11-misc/mixer_app/files/mixer_app-1.8.0-build.patch
new file mode 100644
index 000000000000..f36ea6e78ec6
--- /dev/null
+++ b/x11-misc/mixer_app/files/mixer_app-1.8.0-build.patch
@@ -0,0 +1,44 @@
+--- Makefile
++++ Makefile
+@@ -2,32 +2,24 @@
+ # Mixer.app Makefile
+ #
+
+-DESTDIR =
+-GNUSTEP_BINDIR = /usr/local/GNUstep/Apps/Mixer.app
+-X11_BINDIR = /usr/X11R6/bin
+-
+-CXX=c++
+-CXXFLAGS += -Wall -pedantic -fno-rtti -fno-exceptions -O2 -I/usr/X11R6/include
+-LDFLAGS += -L/usr/X11R6/lib -lXpm -lXext -lX11
++BINDIR = /usr/bin
++
++CXX ?= g++
++CXXFLAGS += -Wall -pedantic -fno-rtti -fno-exceptions
++LIBS = -lXpm -lXext -lX11
+
+ OBJECTS = Main.o Mixer.o Xpm.o
+
+ all: Mixer.app
+
+ Mixer.app: $(OBJECTS)
+- $(CXX) $(OBJECTS) -o $@ $(LDFLAGS)
++ $(CXX) $(LDFLAGS) $(OBJECTS) -o $@ $(LIBS)
+
+ .PHONY: install clean distclean
+
+-install: install-gnustep
+-
+-install-gnustep: all
+- install -d $(DESTDIR)$(GNUSTEP_BINDIR)
+- install -m 0755 Mixer.app $(DESTDIR)$(GNUSTEP_BINDIR)/Mixer
+-
+-install-x11: all
+- install -d $(DESTDIR)$(X11_BINDIR)
+- install -m 0755 Mixer.app $(DESTDIR)$(X11_BINDIR)/Mixer.app
++install: all
++ install -d $(DESTDIR)$(BINDIR)
++ install -m 0755 Mixer.app $(DESTDIR)$(BINDIR)/Mixer.app
+
+ clean:
+ rm -f *~ *.o
diff --git a/x11-misc/mixer_app/mixer_app-1.8.0.ebuild b/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
index 68782aac59c9..3ec1107bd9b9 100644
--- a/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
+++ b/x11-misc/mixer_app/mixer_app-1.8.0.ebuild
@@ -1,19 +1,19 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/mixer_app/mixer_app-1.8.0.ebuild,v 1.12 2007/07/22 03:59:10 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/mixer_app/mixer_app-1.8.0.ebuild,v 1.13 2012/05/16 03:36:12 ssuominen Exp $
-#need to do some name mangling
-#so that ebuild name adheres to "standart"
-Name=Mixer.app
-S=${WORKDIR}/${Name}-${PV}
+EAPI=4
+inherit eutils toolchain-funcs
+
+MY_P=Mixer.app-${PV}
DESCRIPTION="mixer utility that has three volume controllers that can be configured to handle any sound source"
-HOMEPAGE="http://www.fukt.bth.se/~per/mixer/"
-SRC_URI="http://www.fukt.bth.se/~per/mixer/${Name}-${PV}.tar.gz"
+HOMEPAGE="http://www.fukt.bsnet.se/~per/mixer/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ppc sparc x86"
+KEYWORDS="amd64 ppc sparc x86"
IUSE=""
RDEPEND="x11-libs/libX11
@@ -22,12 +22,15 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-proto/xextproto"
-src_compile() {
- emake || die
+S=${WORKDIR}/${MY_P}
+
+DOCS="ChangeLog README"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
}
-src_install() {
- #make DESTDIR=${D} install || die
- dobin Mixer.app
- dodoc README ChangeLog
+src_compile() {
+ tc-export CXX
+ emake
}