summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2004-09-27 19:04:03 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2004-09-27 19:04:03 +0000
commitc17743f96f253659a638990f64f413b45d86395a (patch)
treef20c09ce6448ed72e023b250fce1d8aecca643eb /x11-misc/fbdesk/fbdesk-1.2.1.ebuild
parentia64 KEYWORDS (Manifest recommit) (diff)
downloadgentoo-2-c17743f96f253659a638990f64f413b45d86395a.tar.gz
gentoo-2-c17743f96f253659a638990f64f413b45d86395a.tar.bz2
gentoo-2-c17743f96f253659a638990f64f413b45d86395a.zip
Version bump
Diffstat (limited to 'x11-misc/fbdesk/fbdesk-1.2.1.ebuild')
-rw-r--r--x11-misc/fbdesk/fbdesk-1.2.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/fbdesk/fbdesk-1.2.1.ebuild b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
new file mode 100644
index 000000000000..e3980e7b71e1
--- /dev/null
+++ b/x11-misc/fbdesk/fbdesk-1.2.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.2.1.ebuild,v 1.1 2004/09/27 19:04:03 sekretarz Exp $
+
+inherit eutils gcc
+
+DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
+HOMEPAGE="http://www.fluxbox.org/fbdesk/"
+SRC_URI="http://www.fluxbox.org/download/${P}.tar.gz"
+IUSE="debug png"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc ~sparc ~ia64"
+
+DEPEND="media-libs/libpng
+ virtual/x11
+ png? ( media-libs/libpng )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ econf \
+ `use_enable debug` \
+ `use_enable png` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS COPYING ChangeLog README
+}