summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-09-17 01:25:59 +0000
committerJeroen Roovers <jer@gentoo.org>2010-09-17 01:25:59 +0000
commit4887cfae1c66d56798d67c2fa7440e9c41d81032 (patch)
tree6b5362133b25b1368dd923361935d90eb4aa6d92 /x11-misc/chgres
parentUpdate glibc dependency, see bug #335101 by Victor Orozco <tuxtor@shekalug.org> (diff)
downloadgentoo-2-4887cfae1c66d56798d67c2fa7440e9c41d81032.tar.gz
gentoo-2-4887cfae1c66d56798d67c2fa7440e9c41d81032.tar.bz2
gentoo-2-4887cfae1c66d56798d67c2fa7440e9c41d81032.zip
Respect LDFLAGS (bug #337183), CC, CFLAGS. Use pkg-config for LIBS and INCLUDES. Fix includes.
(Portage version: 2.2_rc82/cvs/Linux i686)
Diffstat (limited to 'x11-misc/chgres')
-rw-r--r--x11-misc/chgres/ChangeLog11
-rw-r--r--x11-misc/chgres/chgres-0.1-r1.ebuild38
-rw-r--r--x11-misc/chgres/files/chgres-0.1-flags.patch21
-rw-r--r--x11-misc/chgres/files/chgres-0.1-includes.patch15
4 files changed, 83 insertions, 2 deletions
diff --git a/x11-misc/chgres/ChangeLog b/x11-misc/chgres/ChangeLog
index 5451a8d54ab3..ca456d94b8b5 100644
--- a/x11-misc/chgres/ChangeLog
+++ b/x11-misc/chgres/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-misc/chgres
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/chgres/ChangeLog,v 1.13 2008/07/23 17:44:08 coldwind Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/chgres/ChangeLog,v 1.14 2010/09/17 01:25:58 jer Exp $
+
+*chgres-0.1-r1 (17 Sep 2010)
+
+ 17 Sep 2010; Jeroen Roovers <jer@gentoo.org> +chgres-0.1-r1.ebuild,
+ +files/chgres-0.1-flags.patch, +files/chgres-0.1-includes.patch:
+ Respect LDFLAGS (bug #337183), CC, CFLAGS. Use pkg-config for LIBS and
+ INCLUDES. Fix includes.
23 Jul 2008; Santiago M. Mola <coldwind@gentoo.org> chgres-0.1.ebuild:
amd64 stable
diff --git a/x11-misc/chgres/chgres-0.1-r1.ebuild b/x11-misc/chgres/chgres-0.1-r1.ebuild
new file mode 100644
index 000000000000..7a36f1ad9f5a
--- /dev/null
+++ b/x11-misc/chgres/chgres-0.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/chgres/chgres-0.1-r1.ebuild,v 1.1 2010/09/17 01:25:58 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A very simple command line utility for changing X resolutions"
+HOMEPAGE="http://hpwww.ec-lyon.fr/~vincent/"
+SRC_URI="http://hpwww.ec-lyon.fr/~vincent/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXxf86dga
+ x11-libs/libXext
+ x11-libs/libXxf86vm"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ x11-proto/xf86dgaproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-{flags,includes}.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin chgres
+ dodoc README
+}
diff --git a/x11-misc/chgres/files/chgres-0.1-flags.patch b/x11-misc/chgres/files/chgres-0.1-flags.patch
new file mode 100644
index 000000000000..78ed2476f799
--- /dev/null
+++ b/x11-misc/chgres/files/chgres-0.1-flags.patch
@@ -0,0 +1,21 @@
+--- Makefile.orig 2001-04-18 23:07:56.000000000 +0200
++++ Makefile 2010-09-17 03:08:55.000000000 +0200
+@@ -1,9 +1,9 @@
+-CFLAGS=
+-LDFLAGS= -L/usr/X11R6/lib -lXext -lX11 -lXxf86vm -lXxf86dga
++LIBS= $(shell pkg-config --libs xext x11 xxf86vm xxf86dga)
++INCLUDES= $(shell pkg-config --cflags xext x11 xxf86vm xxf86dga)
+ prefix=/usr
+
+ chgres: chgres.o
+- $(CC) -o $@ $< $(LDFLAGS)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $< $(LIBS)
+
+ install: chgres
+ install -D -m 0555 chgres $(prefix)/bin/
+@@ -12,4 +12,4 @@
+ rm -f core chgres.o chgres
+
+ .c.o:
+- $(CC) $(CFLAGS) -c $< -o $@
++ $(CC) $(CFLAGS) $(INCLUDES) -c $< -o $@
diff --git a/x11-misc/chgres/files/chgres-0.1-includes.patch b/x11-misc/chgres/files/chgres-0.1-includes.patch
new file mode 100644
index 000000000000..6c686c255967
--- /dev/null
+++ b/x11-misc/chgres/files/chgres-0.1-includes.patch
@@ -0,0 +1,15 @@
+--- chgres.c.orig 2001-04-18 22:40:05.000000000 +0200
++++ chgres.c 2010-09-17 03:20:37.000000000 +0200
+@@ -17,9 +17,11 @@
+ */
+
+ #include <X11/Xlib.h>
+-#include <X11/extensions/xf86dga.h>
++#include <X11/extensions/Xxf86dga.h>
+ #include <X11/extensions/xf86vmode.h>
+ #include <stdio.h>
++#include <stdlib.h> /* exit() */
++#include <strings.h> /* strcasecmp() */
+
+ #define VERSION "0.1"
+