summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2006-04-28 09:05:21 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2006-04-28 09:05:21 +0000
commit308b70e4ef7b0ef936158a261d320939108f5ca4 (patch)
tree3e60841eeecb1bc1c2ee120e0ef7e8b29f5c305a /x11-misc/adesklets
parentBump pycrypto dependency to >=dev-python/pycrypto-2.0.1-r5 for bugs #131293 a... (diff)
downloadgentoo-2-308b70e4ef7b0ef936158a261d320939108f5ca4.tar.gz
gentoo-2-308b70e4ef7b0ef936158a261d320939108f5ca4.tar.bz2
gentoo-2-308b70e4ef7b0ef936158a261d320939108f5ca4.zip
Version bump, with fixes for bug #128018 and bug #128303
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'x11-misc/adesklets')
-rw-r--r--x11-misc/adesklets/Manifest6
-rw-r--r--x11-misc/adesklets/adesklets-0.6.1.ebuild111
-rw-r--r--x11-misc/adesklets/files/digest-adesklets-0.6.13
3 files changed, 120 insertions, 0 deletions
diff --git a/x11-misc/adesklets/Manifest b/x11-misc/adesklets/Manifest
index d642cb814f2c..cef4566d84a5 100644
--- a/x11-misc/adesklets/Manifest
+++ b/x11-misc/adesklets/Manifest
@@ -13,6 +13,9 @@ SHA256 620642423d16e91e3fa46706a78f98d27591f7a9711e34b28ffdbc05c5c87cdb adesklet
MD5 9724d255aba988e43a66e834084d023b adesklets-0.6.0.ebuild 2723
RMD160 57d7402aba88d13e3bcb574b72e840d05c4607f5 adesklets-0.6.0.ebuild 2723
SHA256 70dea7389a95b6ee843294e1beeac8762540318aa9bedd82ec3ac2e70de902ea adesklets-0.6.0.ebuild 2723
+MD5 d60c32fb4c456180d85974ffc0e9d638 adesklets-0.6.1.ebuild 2757
+RMD160 f3be2d0142260495c9578c89be94243bf8937003 adesklets-0.6.1.ebuild 2757
+SHA256 d063f77a97eb7635096df6485eb4b50740f329f270d0b4a57f4b222218c4f439 adesklets-0.6.1.ebuild 2757
MD5 e045c26201a3144d26662d727f31e7a8 files/adesklets-0.5.0-adesklets_installer.patch 1743
RMD160 bcf7c62f1e02d63e42f27dd34b90218fa362b76c files/adesklets-0.5.0-adesklets_installer.patch 1743
SHA256 c00864541593c5252910815aa41334c97f8c86529f1093a53f01ca12d3096df4 files/adesklets-0.5.0-adesklets_installer.patch 1743
@@ -34,6 +37,9 @@ SHA256 9d3dbfac7263c54aa412a9a039cdbe5c018de6db8e1a7c3711e2c55fc4bc5502 files/di
MD5 4b10fc900bfffb69703a40d18fc80d2b files/digest-adesklets-0.6.0 250
RMD160 92c8bacef7c500d920d2b52021f97b9421181659 files/digest-adesklets-0.6.0 250
SHA256 bfdc913f644fa8491b29ad2409fb202dcc6b9c1c05f8689415088b341987d7bc files/digest-adesklets-0.6.0 250
+MD5 a2ab582e0187319f71cf0f5af237f095 files/digest-adesklets-0.6.1 250
+RMD160 48b082b853c5f1ef670c9531b9d734b314dc63f1 files/digest-adesklets-0.6.1 250
+SHA256 33691330baa736d4a7ff8f2413194e42e9071dc7d86bb63680d383d64a1c03ea files/digest-adesklets-0.6.1 250
MD5 ba2766b0b67886a694c4c93cdab3c972 metadata.xml 551
RMD160 99b9eb03ca5c5ab03e1625584e1d09cd1724f7c3 metadata.xml 551
SHA256 a6180c2f4d9890bb483e436f94c17de4a08b9e027d54d712240df00b62950e54 metadata.xml 551
diff --git a/x11-misc/adesklets/adesklets-0.6.1.ebuild b/x11-misc/adesklets/adesklets-0.6.1.ebuild
new file mode 100644
index 000000000000..7d0a8935f813
--- /dev/null
+++ b/x11-misc/adesklets/adesklets-0.6.1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/adesklets/adesklets-0.6.1.ebuild,v 1.1 2006/04/28 09:05:21 s4t4n Exp $
+
+inherit eutils
+
+DESCRIPTION="An interactive Imlib2 console for the X Window system"
+HOMEPAGE="http://adesklets.sf.net/"
+SRC_URI="mirror://sourceforge/adesklets/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="X python perl debug ctrlmenu"
+
+RDEPEND="X? ( || ( (
+ x11-libs/libX11
+ x11-apps/xprop
+ x11-libs/libXt
+ x11-apps/xwininfo )
+ virtual/x11 ) )
+ >=sys-apps/sed-4.1.4-r1
+ >=sys-apps/coreutils-5.94-r1
+ >=sys-process/procps-3.2.6"
+
+DEPEND=">=media-libs/imlib2-1.2.0-r2
+ X? ( || ( x11-proto/xproto virtual/x11 ) )
+ python? ( >=dev-lang/python-2.3.4-r1 )
+ perl? ( >=dev-lang/perl-5.8.2 )"
+
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ #Fix for bug #123538: control context menu fix
+ epatch ${FILESDIR}/${PN}-ctrlmenu.patch
+
+ # when performing minor changes to src/adesklets.c or src/commands.c,
+ # touching these files will avoid unneeded processing
+ touch scripting/enums scripting/prototypes \
+ scripting/python/adesklets/commands.py \
+ scripting/perl/adesklets.pm
+}
+
+src_compile()
+{
+ local myconf=""
+
+ use X || myconf="--without-x"
+ use python || myconf="${myconf} --without-python-support"
+ use perl || myconf="${myconf} --without-perl-support"
+ myconf="${myconf} $(use_enable debug)"
+ use ctrlmenu && myconf="--enable-control-on-context-menu"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install()
+{
+ dodir usr/share/info
+ dodir usr/share/man/man1
+ make DESTDIR=${D} install || die
+ doinfo doc/*.info || die "info page installation failed"
+ doman doc/*.1 || die "man page installation failed"
+ dodoc ChangeLog NEWS TODO AUTHORS
+ use debug &&
+ {
+ echo 'ADESKLETS_LOG="/tmp/adesklets_log"' > 70adesklets
+ doenvd 70adesklets
+ }
+}
+
+pkg_postinst()
+{
+ use X ||
+ {
+ ewarn "You did not install the X Window support for ${P}"
+ ewarn "If you intend to use it to display desklets, this"
+ ewarn "is a mistake."
+ echo
+ ewarn "Type USE=\"X\" emerge adesklets to correct this."
+ echo
+ einfo "Please also note that if it is what you intended"
+ einfo "to do, you need also to install imlib2 without"
+ einfo "X support to effectively remove all dependencies."
+ echo
+ }
+
+ use python ||
+ {
+ ewarn "You did not install the python bindings for ${P}"
+ ewarn "If you intend to use it to display desklets, this"
+ ewarn "is most probably an error."
+ echo
+ ewarn "Type USE=\"python\" emerge adesklets to correct this."
+ echo
+ }
+
+ use debug &&
+ {
+ ewarn "You installed a debug build. Make sure you do:"
+ echo
+ ewarn "source /etc/profile"
+ echo
+ ewarn "If you want to use adesklets from your already"
+ ewarn "opened sessions. The sessions log are automatically"
+ ewarn "saved to /tmp/adesklets_log.pid*."
+ }
+}
diff --git a/x11-misc/adesklets/files/digest-adesklets-0.6.1 b/x11-misc/adesklets/files/digest-adesklets-0.6.1
new file mode 100644
index 000000000000..a7aa89b2fdbb
--- /dev/null
+++ b/x11-misc/adesklets/files/digest-adesklets-0.6.1
@@ -0,0 +1,3 @@
+MD5 cd390c9398449c5566033e2e4792bccb adesklets-0.6.1.tar.bz2 387553
+RMD160 65cca6fe53f23f029c74cb101022e4481ee114d0 adesklets-0.6.1.tar.bz2 387553
+SHA256 9998e240715c34b5d4c8b31b5ed1fef38262a39fad08fa65be0b58a47eccc3c2 adesklets-0.6.1.tar.bz2 387553