summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:07:07 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-03-01 19:07:07 +0000
commitecb2b21f15e53d3b689902103684905a630af938 (patch)
tree2dfe9a58e1945d49fc02770c2bebcfbc28b85655 /x11-libs
parentVersion bump Qt 4.7.2 (diff)
downloadgentoo-2-ecb2b21f15e53d3b689902103684905a630af938.tar.gz
gentoo-2-ecb2b21f15e53d3b689902103684905a630af938.tar.bz2
gentoo-2-ecb2b21f15e53d3b689902103684905a630af938.zip
Version bump Qt 4.7.2
(Portage version: 2.2.0_alpha25/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-declarative/ChangeLog10
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.2.ebuild57
2 files changed, 65 insertions, 2 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
index 8f4b84d5783a..f7076e737599 100644
--- a/x11-libs/qt-declarative/ChangeLog
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-declarative
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.16 2010/12/10 18:36:36 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.17 2011/03/01 19:07:07 tampakrap Exp $
+
+*qt-declarative-4.7.2 (01 Mar 2011)
+
+ 01 Mar 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-declarative-4.7.2.ebuild:
+ Version bump Qt 4.7.2
10 Dec 2010; Fabian Groffen <grobian@gentoo.org>
qt-declarative-4.7.1-r2.ebuild:
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.2.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.2.ebuild
new file mode 100644
index 000000000000..7aa5c78e4b09
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.2.ebuild,v 1.1 2011/03/01 19:07:07 tampakrap Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="private-headers qt3support"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-opengl-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-script-${PV}[aqua=]
+ ~x11-libs/qt-sql-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-svg-${PV}[aqua=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=]
+ qt3support? ( ~x11-libs/qt-qt3support-${PV}[aqua=] )
+ "
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QCONFIG_ADD="declarative"
+
+ QT4_TARGET_DIRECTORIES="
+ src/declarative
+ src/imports
+ tools/designer/src/plugins/qdeclarativeview
+ tools/qml"
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -declarative $(qt_use qt3support)"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use private-headers; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
+ # ran for the 2nd time, need it for the updated headers
+ fix_includes
+ else
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ fi
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+ fi
+}