summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-25 08:56:25 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-11-25 08:56:25 +0000
commite1d67e173300947a94eafd18483ef80eee06b031 (patch)
tree935913dfb7c5e127dc5570a2a7ffcec3579cb5c9 /x11-libs
parentsci-chemistry/ccpn: Todays pthon patches (diff)
downloadgentoo-2-e1d67e173300947a94eafd18483ef80eee06b031.tar.gz
gentoo-2-e1d67e173300947a94eafd18483ef80eee06b031.tar.bz2
gentoo-2-e1d67e173300947a94eafd18483ef80eee06b031.zip
Revbump for bug #488906 and revert changes to stable ebuild.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/glamor/ChangeLog8
-rw-r--r--x11-libs/glamor/glamor-0.5.1-r1.ebuild43
-rw-r--r--x11-libs/glamor/glamor-0.5.1.ebuild8
3 files changed, 52 insertions, 7 deletions
diff --git a/x11-libs/glamor/ChangeLog b/x11-libs/glamor/ChangeLog
index 656e4ec1987f..518cc390fa3f 100644
--- a/x11-libs/glamor/ChangeLog
+++ b/x11-libs/glamor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/glamor
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.24 2013/11/24 20:51:45 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/ChangeLog,v 1.25 2013/11/25 08:56:25 chithanh Exp $
+
+*glamor-0.5.1-r1 (25 Nov 2013)
+
+ 25 Nov 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +glamor-0.5.1-r1.ebuild, glamor-0.5.1.ebuild:
+ Revbump for bug #488906 and revert changes to stable ebuild.
24 Nov 2013; Magnus Granberg <zorry@gentoo.org> glamor-0.5.1.ebuild:
Fix bug 488906 fail to load driver with hardened compiler
diff --git a/x11-libs/glamor/glamor-0.5.1-r1.ebuild b/x11-libs/glamor/glamor-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..ef905444f7e0
--- /dev/null
+++ b/x11-libs/glamor/glamor-0.5.1-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.1-r1.ebuild,v 1.1 2013/11/25 08:56:25 chithanh Exp $
+
+EAPI=5
+
+XORG_DRI=always
+XORG_EAUTORECONF=yes
+XORG_MODULE=driver/
+XORG_MODULE_REBUILD=yes
+S=${WORKDIR}/${PN}-egl-${PV}
+
+inherit xorg-2 toolchain-funcs
+
+DESCRIPTION="OpenGL based 2D rendering acceleration library"
+SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gles"
+
+RDEPEND=">=x11-base/xorg-server-1.10
+ media-libs/mesa[egl,gbm]
+ gles? (
+ || ( media-libs/mesa[gles2] media-libs/mesa[gles] )
+ )
+ >=x11-libs/pixman-0.21.8"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable gles glamor-gles2)
+ )
+ xorg-2_src_configure
+}
+
+src_prepare() {
+ sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
+ xorg-2_src_prepare
+ # fail to load grafic driver with hardened compiler #488906
+ if gcc-specs-now ; then
+ append-ldflags -Wl,-z,lazy
+ fi
+}
diff --git a/x11-libs/glamor/glamor-0.5.1.ebuild b/x11-libs/glamor/glamor-0.5.1.ebuild
index eec04bcb794e..e6412c3b2b0d 100644
--- a/x11-libs/glamor/glamor-0.5.1.ebuild
+++ b/x11-libs/glamor/glamor-0.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.1.ebuild,v 1.9 2013/11/24 20:51:45 zorry Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/glamor/glamor-0.5.1.ebuild,v 1.10 2013/11/25 08:56:25 chithanh Exp $
EAPI=5
@@ -10,7 +10,7 @@ XORG_MODULE=driver/
XORG_MODULE_REBUILD=yes
S=${WORKDIR}/${PN}-egl-${PV}
-inherit xorg-2 toolchain-funcs
+inherit xorg-2
DESCRIPTION="OpenGL based 2D rendering acceleration library"
SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/${XORG_MODULE}${PN}-egl-${PV}.tar.bz2"
@@ -36,8 +36,4 @@ src_configure() {
src_prepare() {
sed -i 's/inst_LTLIBRARIES/lib_LTLIBRARIES/' src/Makefile.am || die
xorg-2_src_prepare
- # fail to load grafic driver with hardened compiler #488906
- if gcc-specs-now ; then
- append-ldflags -Wl,-z,lazy
- fi
}