summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-16 15:06:01 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-16 15:06:01 +0000
commitb26381174babca96a4954a465b473707b42a10c7 (patch)
treedb76499407725a010890bbe9acf77327c98b6b93 /x11-libs
parentVersion bump #233274 by Benjamin Schleinzer. (diff)
downloadgentoo-2-b26381174babca96a4954a465b473707b42a10c7.tar.gz
gentoo-2-b26381174babca96a4954a465b473707b42a10c7.tar.bz2
gentoo-2-b26381174babca96a4954a465b473707b42a10c7.zip
Change pdep to qt-gui
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-hh1 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-core/ChangeLog6
-rw-r--r--x11-libs/qt-core/qt-core-4.4.1-r1.ebuild4
-rw-r--r--x11-libs/qt-core/qt-core-4.4.1.ebuild3
3 files changed, 9 insertions, 4 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 30e34a8c47c7..a01e0526b9be 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.11 2008/08/13 09:28:02 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.12 2008/08/16 15:06:01 yngwin Exp $
+
+ 16 Aug 2008; Ben de Groot <yngwin@gentoo.org> qt-core-4.4.1.ebuild,
+ qt-core-4.4.1-r1.ebuild:
+ Change pdepend to qt-gui to prevent circular dep
*qt-core-4.4.1-r1 (13 Aug 2008)
diff --git a/x11-libs/qt-core/qt-core-4.4.1-r1.ebuild b/x11-libs/qt-core/qt-core-4.4.1-r1.ebuild
index 23cd4fc16525..1e4be51d690a 100644
--- a/x11-libs/qt-core/qt-core-4.4.1-r1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.4.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.1-r1.ebuild,v 1.1 2008/08/13 09:28:02 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.1-r1.ebuild,v 1.2 2008/08/16 15:06:01 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -19,7 +19,7 @@ RDEPEND="sys-libs/zlib
!<=x11-libs/qt-4.4.0_alpha:${SLOT}"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
-PDEPEND="qt3support? ( ~x11-libs/qt-qt3support-${PV} )"
+PDEPEND="qt3support? ( ~x11-libs/qt-gui-${PV} )"
QT4_TARGET_DIRECTORIES="
src/tools/moc/
diff --git a/x11-libs/qt-core/qt-core-4.4.1.ebuild b/x11-libs/qt-core/qt-core-4.4.1.ebuild
index ffa0c50c760f..f60a47d9387a 100644
--- a/x11-libs/qt-core/qt-core-4.4.1.ebuild
+++ b/x11-libs/qt-core/qt-core-4.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.1.ebuild,v 1.1 2008/08/11 12:59:34 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.4.1.ebuild,v 1.2 2008/08/16 15:06:01 yngwin Exp $
EAPI="1"
inherit qt4-build
@@ -19,6 +19,7 @@ RDEPEND="sys-libs/zlib
!<=x11-libs/qt-4.4.0_alpha:${SLOT}"
DEPEND="${RDEPEND}
dev-util/pkgconfig"
+PDEPEND="qt3support? ( ~x11-libs/qt-gui-${PV} )"
QT4_TARGET_DIRECTORIES="
src/tools/moc/