summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2002-10-27 15:21:32 +0000
committerMarinus Schraal <foser@gentoo.org>2002-10-27 15:21:32 +0000
commit4f616015a78951b84211fb304e4d8350c2074088 (patch)
tree9ba27ad0ed3723d59db7d8357094bfdb10768ae6 /x11-libs
parentgnome 2.1 (diff)
downloadgentoo-2-4f616015a78951b84211fb304e4d8350c2074088.tar.gz
gentoo-2-4f616015a78951b84211fb304e4d8350c2074088.tar.bz2
gentoo-2-4f616015a78951b84211fb304e4d8350c2074088.zip
gnome 2.1
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.1.11
-rw-r--r--x11-libs/gtk+/gtk+-2.1.1.ebuild67
-rw-r--r--x11-libs/libwnck/ChangeLog7
-rw-r--r--x11-libs/libwnck/files/digest-libwnck-2.1.11
-rw-r--r--x11-libs/libwnck/libwnck-2.1.1.ebuild26
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.1.21
-rw-r--r--x11-libs/pango/pango-1.1.2.ebuild52
-rw-r--r--x11-libs/xft/ChangeLog10
-rw-r--r--x11-libs/xft/files/digest-xft-2.01
-rw-r--r--x11-libs/xft/xft-2.0.ebuild24
12 files changed, 201 insertions, 3 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 2460672d7142..684096f319e4 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.27 2002/10/21 20:26:41 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.28 2002/10/27 15:19:16 foser Exp $
+
+*gtk+-2.1.1 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> gtk+-2.1.1.ebuild :
+ gnome 2.1
*gtk+-2.0.6-r3 (21 Oct 2002)
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.1.1 b/x11-libs/gtk+/files/digest-gtk+-2.1.1
new file mode 100644
index 000000000000..fd68af837eb1
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.1.1
@@ -0,0 +1 @@
+MD5 2b7380efbd72d842d0f53943f434c2e1 gtk+-2.1.1.tar.bz2 5778437
diff --git a/x11-libs/gtk+/gtk+-2.1.1.ebuild b/x11-libs/gtk+/gtk+-2.1.1.ebuild
new file mode 100644
index 000000000000..be1fac27ca6a
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.1.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.1.1.ebuild,v 1.1 2002/10/27 15:19:16 foser Exp $
+
+IUSE="tiff doc jpeg directfb"
+
+inherit libtool flag-o-matic debug
+
+SLOT="2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.6-r1
+ >=dev-libs/atk-1.1
+ >=x11-libs/pango-1.1
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ directfb? ( dev-libs/DirectFB )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+ # see bug 8762
+ replace-flags "-O3" "-O2"
+
+ elibtoolize
+
+ local myconf=""
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf --with-gdktarget=x11 ${myconf} || die
+
+ # gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.1/gtk.immodules
+ gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders
+}
+
diff --git a/x11-libs/libwnck/ChangeLog b/x11-libs/libwnck/ChangeLog
index 46876181b146..e8a4dff4ceef 100644
--- a/x11-libs/libwnck/ChangeLog
+++ b/x11-libs/libwnck/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libwnck
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.10 2002/09/17 15:41:34 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/ChangeLog,v 1.11 2002/10/27 15:19:16 foser Exp $
+
+*libwnck-2.1.1 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> libwnck-2.1.1.ebuild :
+ gnome 2.1
*libwnck-0.17 (06 Sep 2002)
diff --git a/x11-libs/libwnck/files/digest-libwnck-2.1.1 b/x11-libs/libwnck/files/digest-libwnck-2.1.1
new file mode 100644
index 000000000000..65f164563c96
--- /dev/null
+++ b/x11-libs/libwnck/files/digest-libwnck-2.1.1
@@ -0,0 +1 @@
+MD5 6f99b9d37f60cf7a5942930a01a251fe libwnck-2.1.1.tar.bz2 227530
diff --git a/x11-libs/libwnck/libwnck-2.1.1.ebuild b/x11-libs/libwnck/libwnck-2.1.1.ebuild
new file mode 100644
index 000000000000..4626a838ffcb
--- /dev/null
+++ b/x11-libs/libwnck/libwnck-2.1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libwnck/libwnck-2.1.1.ebuild,v 1.1 2002/10/27 15:19:16 foser Exp $
+
+inherit gnome2 debug
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A window navigation construction kit"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64 ppc alpha"
+
+RDEPEND="virtual/glibc
+ x11-libs/pango
+ dev-libs/glib
+ =x11-libs/gtk+-2.1*"
+DEPEND=">=dev-util/pkgconfig-0.12.0 ${RDEPEND}"
+
+
+LICENSE="GPL-2"
+DOCS="ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+
+
+
+
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 3ffbe12925b0..d2a7d292b351 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.13 2002/10/13 23:02:15 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.14 2002/10/27 15:19:16 foser Exp $
+
+*pango-1.1.2 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> pango-1.1.2.ebuild :
+ gnome 2.1
*pango-1.0.5 (14 Oct 2002)
diff --git a/x11-libs/pango/files/digest-pango-1.1.2 b/x11-libs/pango/files/digest-pango-1.1.2
new file mode 100644
index 000000000000..e744f39634ac
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.1.2
@@ -0,0 +1 @@
+MD5 cd76cc74ed2e3c74c6af19b5d5fd10ad pango-1.1.2.tar.bz2 758864
diff --git a/x11-libs/pango/pango-1.1.2.ebuild b/x11-libs/pango/pango-1.1.2.ebuild
new file mode 100644
index 000000000000..51ca68427591
--- /dev/null
+++ b/x11-libs/pango/pango-1.1.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.1.2.ebuild,v 1.1 2002/10/27 15:19:16 foser Exp $
+
+IUSE="doc"
+
+inherit libtool debug
+
+SLOT="1"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Text rendering and Layout library"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.1/${P}.tar.bz2"
+HOMEPAGE="http://www.pango.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ virtual/xft
+ >=dev-libs/glib-2
+ >=media-libs/fontconfig-2.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="--enable-gtk-doc" || myconf="--disable-gtk-doc"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+
+ econf ${myconf} --without-qt || die
+ make || die "serial make failed"
+}
+
+src_install() {
+ einstall
+ rm ${D}/etc/pango/pango.modules
+
+
+ dodoc AUTHORS ChangeLog COPYING README INSTALL NEWS TODO*
+}
+
+pkg_postinst() {
+ pango-querymodules >/etc/pango/pango.modules
+}
+
diff --git a/x11-libs/xft/ChangeLog b/x11-libs/xft/ChangeLog
new file mode 100644
index 000000000000..ffe752aae48e
--- /dev/null
+++ b/x11-libs/xft/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/xft
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/ChangeLog,v 1.1 2002/10/27 15:19:16 foser Exp $
+
+*xft-2.0 (27 Oct 2002)
+
+ 27 Oct 2002; foser <foser@gentoo.org> xft-2.0.ebuild, ChangeLog :
+ Gnome 2.1 commit
+ This package provides xft2 support, as used by the pango devel series
+ Usage will probably break a lot of other things
diff --git a/x11-libs/xft/files/digest-xft-2.0 b/x11-libs/xft/files/digest-xft-2.0
new file mode 100644
index 000000000000..05efa21a9a47
--- /dev/null
+++ b/x11-libs/xft/files/digest-xft-2.0
@@ -0,0 +1 @@
+MD5 5ef5c58e501b0cb873ee2b2a04ed74e3 fcpackage.2_0.tar.gz 538159
diff --git a/x11-libs/xft/xft-2.0.ebuild b/x11-libs/xft/xft-2.0.ebuild
new file mode 100644
index 000000000000..61a8d307b3de
--- /dev/null
+++ b/x11-libs/xft/xft-2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/xft/xft-2.0.ebuild,v 1.1 2002/10/27 15:19:16 foser Exp $
+
+PROVIDE="virtual/xft"
+DESCRIPTION="Xft2"
+SRC_URI="http://fontconfig.org/release/fcpackage.${PV/\./_}.tar.gz"
+HOMEPAGE="http://fontconfig.org/"
+LICENSE="fontconfig"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+DEPEND="x11-base/xfree"
+S="${WORKDIR}/fcpackage.${PV/\./_}/Xft"
+
+src_compile() {
+ econf || die "Xft2 config failed"
+ emake || die "Xft2 make failed"
+}
+
+src_install() {
+ einstall confdir=${D}/etc/fonts \
+ datadir=${D}/usr/share || die
+}