summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-18 08:48:37 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-18 08:48:37 +0000
commit6432e89df0af79edf245fdb8fdbc59ecc2a85eb8 (patch)
treebe87761639e4d3f998c09c4e439a2ef9f1e30fdd /x11-libs/vte
parentVersion bump. Add linux 3 warning (bug 376441). (diff)
downloadgentoo-2-6432e89df0af79edf245fdb8fdbc59ecc2a85eb8.tar.gz
gentoo-2-6432e89df0af79edf245fdb8fdbc59ecc2a85eb8.tar.bz2
gentoo-2-6432e89df0af79edf245fdb8fdbc59ecc2a85eb8.zip
Update meta key patch to fix Alt-? and Alt-/ handling.
(Portage version: 2.2.0_alpha75/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog10
-rw-r--r--x11-libs/vte/files/vte-0.30.1-alt-meta.patch53
-rw-r--r--x11-libs/vte/vte-0.28.2-r202.ebuild (renamed from x11-libs/vte/vte-0.28.2-r201.ebuild)2
-rw-r--r--x11-libs/vte/vte-0.30.1-r2.ebuild (renamed from x11-libs/vte/vte-0.30.1-r1.ebuild)2
4 files changed, 61 insertions, 6 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 01a11e5db6e6..5d3afbfb4710 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.299 2011/11/16 20:54:48 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.300 2011/11/18 08:48:37 tetromino Exp $
+
+*vte-0.30.1-r2 (18 Nov 2011)
+*vte-0.28.2-r202 (18 Nov 2011)
+
+ 18 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ -vte-0.28.2-r201.ebuild, +vte-0.28.2-r202.ebuild, -vte-0.30.1-r1.ebuild,
+ +vte-0.30.1-r2.ebuild, files/vte-0.30.1-alt-meta.patch:
+ Update meta key patch to fix Alt-? and Alt-/ handling.
16 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
vte-0.28.2-r201.ebuild, vte-0.30.1-r1.ebuild:
diff --git a/x11-libs/vte/files/vte-0.30.1-alt-meta.patch b/x11-libs/vte/files/vte-0.30.1-alt-meta.patch
index 9ea611fde51c..bd364be5846c 100644
--- a/x11-libs/vte/files/vte-0.30.1-alt-meta.patch
+++ b/x11-libs/vte/files/vte-0.30.1-alt-meta.patch
@@ -1,14 +1,61 @@
-From 299e28dd3e5549b13ec54de991d583ac6a6ff11e Mon Sep 17 00:00:00 2001
+From 180dcc578e13c6096e277fb853e7162db640f207 Mon Sep 17 00:00:00 2001
From: Alexandre Rostovtsev <tetromino@gentoo.org>
Date: Tue, 15 Nov 2011 03:06:40 -0500
Subject: [PATCH] Map both gdk's Meta and Alt to vte's Meta for >=gtk+-3.2.2
compatibility
+Also, since VTE_META_MASK is now a mask with multiple bits set, code that
+compares gdk key modifiers to VTE_META_MASK by numerical equality is no
+longer guaranteed to work. Therefore, for such comparisons a new function,
+vte_keymap_fixup_modifiers, is introduced; it ensures that if any bits
+matching matching VTE_META_MASK are set, then all are set.
+
https://bugzilla.gnome.org/show_bug.cgi?id=663779
---
+ src/keymap.c | 15 +++++++++++++--
src/keymap.h | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
+ 2 files changed, 14 insertions(+), 3 deletions(-)
+diff --git a/src/keymap.c b/src/keymap.c
+index 9a21669..95b4c5b 100644
+--- a/src/keymap.c
++++ b/src/keymap.c
+@@ -990,6 +990,17 @@ static const struct _vte_keymap_group {
+ {GDK_KEY (F35), _vte_keymap_GDK_F35},
+ };
+
++/* Restrict modifiers to the specified mask and ensure that VTE_META_MASK,
++ * despite being a compound mask, is treated as indivisible. */
++GdkModifierType
++_vte_keymap_fixup_modifiers(GdkModifierType modifiers,
++ GdkModifierType mask)
++{
++ if (modifiers & VTE_META_MASK)
++ modifiers |= VTE_META_MASK;
++ return modifiers & mask;
++}
++
+ /* Map the specified keyval/modifier setup, dependent on the mode, to either
+ * a literal string or a capability name. */
+ void
+@@ -1104,7 +1115,7 @@ _vte_keymap_map(guint keyval,
+ } else {
+ fkey_mode = fkey_default;
+ }
+- modifiers &= (GDK_SHIFT_MASK | GDK_CONTROL_MASK | VTE_META_MASK | VTE_NUMLOCK_MASK);
++ modifiers = _vte_keymap_fixup_modifiers(modifiers, GDK_SHIFT_MASK | GDK_CONTROL_MASK | VTE_META_MASK | VTE_NUMLOCK_MASK);
+
+ /* Search for the conditions. */
+ for (i = 0; entries[i].normal_length || entries[i].special[0]; i++)
+@@ -1375,7 +1386,7 @@ _vte_keymap_key_add_key_modifiers(guint keyval,
+ return;
+ }
+
+- switch (modifiers & significant_modifiers) {
++ switch (_vte_keymap_fixup_modifiers(modifiers, significant_modifiers)) {
+ case 0:
+ modifier = 0;
+ break;
diff --git a/src/keymap.h b/src/keymap.h
index 243e22e..21d9b8e 100644
--- a/src/keymap.h
@@ -23,5 +70,5 @@ index 243e22e..21d9b8e 100644
/* Map the specified keyval/modifier setup, dependent on the mode, to either
--
-1.7.8.rc1
+1.7.8.rc3
diff --git a/x11-libs/vte/vte-0.28.2-r201.ebuild b/x11-libs/vte/vte-0.28.2-r202.ebuild
index 2ed069a11282..744b8db19a28 100644
--- a/x11-libs/vte/vte-0.28.2-r201.ebuild
+++ b/x11-libs/vte/vte-0.28.2-r202.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.28.2-r201.ebuild,v 1.2 2011/11/16 20:54:48 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.28.2-r202.ebuild,v 1.1 2011/11/18 08:48:37 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"
diff --git a/x11-libs/vte/vte-0.30.1-r1.ebuild b/x11-libs/vte/vte-0.30.1-r2.ebuild
index 238ee7b73993..80a32dd16446 100644
--- a/x11-libs/vte/vte-0.30.1-r1.ebuild
+++ b/x11-libs/vte/vte-0.30.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1-r1.ebuild,v 1.2 2011/11/16 20:54:48 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.30.1-r2.ebuild,v 1.1 2011/11/18 08:48:37 tetromino Exp $
EAPI="4"
GCONF_DEBUG="yes"