summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-03-14 04:17:50 +0000
committerAron Griffis <agriffis@gentoo.org>2005-03-14 04:17:50 +0000
commit1c7a6a7ea8d97df61762782550efb7c18422d4d0 (patch)
tree44424ab0a5b940bf9f91c23d6f045c7c02f3c04d /x11-libs/rep-gtk
parentRespect USE=gnome #62029 (diff)
downloadgentoo-2-1c7a6a7ea8d97df61762782550efb7c18422d4d0.tar.gz
gentoo-2-1c7a6a7ea8d97df61762782550efb7c18422d4d0.tar.bz2
gentoo-2-1c7a6a7ea8d97df61762782550efb7c18422d4d0.zip
Remove reference to gtk internal functions. These functions are no longer
available in recent versions of gtk, and sawfish doesn't use them anyway. Bug 48439, patch from fn_x (Portage version: 2.0.51.19)
Diffstat (limited to 'x11-libs/rep-gtk')
-rw-r--r--x11-libs/rep-gtk/ChangeLog8
-rw-r--r--x11-libs/rep-gtk/files/rep-gtk-0.18-gtk26.patch24
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild7
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index 38bde8b2ae4f..9bb68bd53d28 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/rep-gtk
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.32 2005/03/14 04:07:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.33 2005/03/14 04:17:50 agriffis Exp $
+
+ 14 Mar 2005; Aron Griffis <agriffis@gentoo.org>
+ +files/rep-gtk-0.18-gtk26.patch, rep-gtk-0.18-r1.ebuild:
+ Remove reference to gtk internal functions. These functions are no longer
+ available in recent versions of gtk, and sawfish doesn't use them anyway.
+ Bug 48439, patch from fn_x
*rep-gtk-0.18-r1 (14 Mar 2005)
diff --git a/x11-libs/rep-gtk/files/rep-gtk-0.18-gtk26.patch b/x11-libs/rep-gtk/files/rep-gtk-0.18-gtk26.patch
new file mode 100644
index 000000000000..6325445f53d3
--- /dev/null
+++ b/x11-libs/rep-gtk/files/rep-gtk-0.18-gtk26.patch
@@ -0,0 +1,24 @@
+Remove reference to gtk internal functions. These functions are no longer
+available in recent versions of gtk, and sawfish doesn't use them anyway.
+Bug 48439, patch from fn_x
+
+13 Mar 2005 agriffis
+
+--- gtk.defs.orig 2005-01-14 02:58:25.104563416 +0100
++++ gtk.defs 2005-01-14 02:58:53.158298600 +0100
+@@ -1717,15 +1717,6 @@
+ ((GtkWindow window)
+ (string geometry)))
+
+-;; XXX GtkWindowGroup
+-
+-;; XXX marked as internal
+-(define-func _gtk_window_internal_set_focus
+- none
+- ((GtkWindow window)
+- (GtkWidget focus))
+- (scm-name "gtk-window-set-focus"))
+-
+ ;;; HandleBox
+
+ (define-object GtkHandleBox (GtkBin))
diff --git a/x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild b/x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild
index a1578d2a8fdd..45f9c3af35dd 100644
--- a/x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild
+++ b/x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild,v 1.1 2005/03/14 04:07:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.18-r1.ebuild,v 1.2 2005/03/14 04:17:50 agriffis Exp $
inherit eutils
@@ -33,6 +33,11 @@ src_unpack() {
if has_version '>=x11-libs/gtk+-2.4'; then
epatch ${FILESDIR}/rep-gtk-0.18-gtk24.patch
fi
+
+ # Remove reference to gtk internal functions. These functions are no
+ # longer available in recent versions of gtk, and sawfish doesn't use
+ # them anyway. Bug 48439, patch from fn_x
+ epatch ${FILESDIR}/rep-gtk-0.18-gtk26.patch
}
src_compile() {