summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-02-15 15:12:04 +0000
committerDror Levin <spatz@gentoo.org>2010-02-15 15:12:04 +0000
commit867263110310c96e0884eff221eaee9024918841 (patch)
treed6036acc9ecf4f4fa1734d7774895f73c25b0421 /x11-libs/qt-svg
parentVersion bump. (diff)
downloadgentoo-2-867263110310c96e0884eff221eaee9024918841.tar.gz
gentoo-2-867263110310c96e0884eff221eaee9024918841.tar.bz2
gentoo-2-867263110310c96e0884eff221eaee9024918841.zip
Version bump.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-svg')
-rw-r--r--x11-libs/qt-svg/ChangeLog7
-rw-r--r--x11-libs/qt-svg/qt-svg-4.6.2.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/x11-libs/qt-svg/ChangeLog b/x11-libs/qt-svg/ChangeLog
index 5cd7217a18d1..5193b2fe2b4d 100644
--- a/x11-libs/qt-svg/ChangeLog
+++ b/x11-libs/qt-svg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-svg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.59 2010/02/09 21:10:08 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/ChangeLog,v 1.60 2010/02/15 15:12:04 spatz Exp $
+
+*qt-svg-4.6.2 (15 Feb 2010)
+
+ 15 Feb 2010; Dror Levin <spatz@gentoo.org> +qt-svg-4.6.2.ebuild:
+ Version bump.
09 Feb 2010; Dror Levin <spatz@gentoo.org> -qt-svg-4.6.0-r1.ebuild:
Remove old.
diff --git a/x11-libs/qt-svg/qt-svg-4.6.2.ebuild b/x11-libs/qt-svg/qt-svg-4.6.2.ebuild
new file mode 100644
index 000000000000..92afbd2a97d8
--- /dev/null
+++ b/x11-libs/qt-svg/qt-svg-4.6.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-svg/qt-svg-4.6.2.ebuild,v 1.1 2010/02/15 15:12:04 spatz Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SVG module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="iconv"
+
+DEPEND="~x11-libs/qt-gui-${PV}[aqua=,debug=]"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/svg
+src/plugins/imageformats/svg
+src/plugins/iconengines/svgiconengine"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/QtSvg/
+include/Qt/
+include/QtGui/
+include/QtCore/
+include/QtXml/
+src/corelib/
+src/gui/
+src/plugins/
+src/xml
+src/3rdparty"
+
+QCONFIG_ADD="svg"
+QCONFIG_DEFINE="QT_SVG"
+
+src_configure() {
+ myconf="${myconf} $(qt_use iconv) -svg -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-qt3support -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -v -no-fontconfig -no-glib -no-opengl -no-gtkstyle -continue"
+ qt4-build_src_configure
+}