summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-09-08 09:19:29 +0000
committerAlex Alexander <wired@gentoo.org>2011-09-08 09:19:29 +0000
commit09059623a18d418064a28c857fbb0c88cdcf9940 (patch)
tree04f270ad89bdaa36c50cc99abeddc1e9523e7465 /x11-libs/qt-declarative
parentversion bump, 4.7.4 (diff)
downloadgentoo-2-09059623a18d418064a28c857fbb0c88cdcf9940.tar.gz
gentoo-2-09059623a18d418064a28c857fbb0c88cdcf9940.tar.bz2
gentoo-2-09059623a18d418064a28c857fbb0c88cdcf9940.zip
version bump, 4.7.4
(Portage version: 2.2.0_alpha54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-declarative')
-rw-r--r--x11-libs/qt-declarative/ChangeLog7
-rw-r--r--x11-libs/qt-declarative/qt-declarative-4.7.4.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-libs/qt-declarative/ChangeLog b/x11-libs/qt-declarative/ChangeLog
index da0b07d6f4b0..c5a7eceec208 100644
--- a/x11-libs/qt-declarative/ChangeLog
+++ b/x11-libs/qt-declarative/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-declarative
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.28 2011/07/13 12:54:51 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/ChangeLog,v 1.29 2011/09/08 09:19:29 wired Exp $
+
+*qt-declarative-4.7.4 (08 Sep 2011)
+
+ 08 Sep 2011; Alex Alexander <wired@gentoo.org> +qt-declarative-4.7.4.ebuild:
+ version bump, 4.7.4
13 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
qt-declarative-4.7.2-r1.ebuild:
diff --git a/x11-libs/qt-declarative/qt-declarative-4.7.4.ebuild b/x11-libs/qt-declarative/qt-declarative-4.7.4.ebuild
new file mode 100644
index 000000000000..52cf1e27889e
--- /dev/null
+++ b/x11-libs/qt-declarative/qt-declarative-4.7.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-declarative/qt-declarative-4.7.4.ebuild,v 1.1 2011/09/08 09:19:29 wired Exp $
+
+EAPI="3"
+inherit qt4-build
+
+DESCRIPTION="The Declarative module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="private-headers qt3support webkit"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-gui-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-opengl-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-script-${PV}[aqua=]
+ ~x11-libs/qt-sql-${PV}[aqua=,qt3support=]
+ ~x11-libs/qt-svg-${PV}[aqua=]
+ ~x11-libs/qt-xmlpatterns-${PV}[aqua=]
+ qt3support? ( ~x11-libs/qt-qt3support-${PV}[aqua=] )
+ webkit? ( ~x11-libs/qt-webkit-${PV}[aqua=] )
+ "
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ QCONFIG_ADD="declarative"
+
+ QT4_TARGET_DIRECTORIES="
+ src/declarative
+ src/imports
+ tools/designer/src/plugins/qdeclarativeview
+ tools/qml"
+
+ if use webkit; then
+ QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ src/3rdparty/webkit/WebKit/qt/declarative"
+ fi
+
+ QT4_EXTRACT_DIRECTORIES="
+ include/
+ src/
+ tools/"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -declarative $(qt_use qt3support) $(qt_use webkit)"
+ qt4-build_src_configure
+}
+
+src_install() {
+ qt4-build_src_install
+ if use private-headers; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ insinto "${QTLIBDIR#${EPREFIX}}"/QtDeclarative.framework/Headers/private
+ # ran for the 2nd time, need it for the updated headers
+ fix_includes
+ else
+ insinto "${QTHEADERDIR#${EPREFIX}}"/QtDeclarative/private
+ fi
+ find "${S}"/src/declarative/ -type f -name "*_p.h" -exec doins {} \;
+ fi
+}