summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-09-19 00:10:45 +0000
committerBen de Groot <yngwin@gentoo.org>2008-09-19 00:10:45 +0000
commitf6246f0e6819f25e8506d12a18e6e11029fba664 (patch)
tree627c226aa40722c3965cc299a072f487104abfce /x11-libs/qt-dbus
parentqt-4.4.2 version bump (diff)
downloadgentoo-2-f6246f0e6819f25e8506d12a18e6e11029fba664.tar.gz
gentoo-2-f6246f0e6819f25e8506d12a18e6e11029fba664.tar.bz2
gentoo-2-f6246f0e6819f25e8506d12a18e6e11029fba664.zip
qt-4.4.2 version bump
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.5 i686)
Diffstat (limited to 'x11-libs/qt-dbus')
-rw-r--r--x11-libs/qt-dbus/ChangeLog7
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.4.2.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index b76e63be76e1..2ba9920ad2b0 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.11 2008/08/11 13:00:51 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.12 2008/09/19 00:10:45 yngwin Exp $
+
+*qt-dbus-4.4.2 (18 Sep 2008)
+
+ 18 Sep 2008; Ben de Groot <yngwin@gentoo.org> +qt-dbus-4.4.2.ebuild:
+ Version bump
*qt-dbus-4.4.1 (11 Aug 2008)
diff --git a/x11-libs/qt-dbus/qt-dbus-4.4.2.ebuild b/x11-libs/qt-dbus/qt-dbus-4.4.2.ebuild
new file mode 100644
index 000000000000..4b1f8b943121
--- /dev/null
+++ b/x11-libs/qt-dbus/qt-dbus-4.4.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.4.2.ebuild,v 1.1 2008/09/19 00:10:45 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The DBus module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# depend on gui instead of core. There's a GUI based viewer that's built, and since it's a desktop
+# protocol I don't know if there's value trying to derive it out into a core build
+# The library itself, however, only depends on core and xml
+DEPEND="~x11-libs/qt-core-${PV}
+ >=sys-apps/dbus-1.0.2
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/dbus
+tools/qdbus/qdbus
+tools/qdbus/qdbusxml2cpp
+tools/qdbus/qdbuscpp2xml"
+QCONFIG_ADD="dbus dbus-linked"
+QCONFIG_DEFINE="QT_DBUS"
+
+#FIXME: Check if these are still needed with the header package
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtDBus/
+src/corelib/global/
+src/corelib/io/
+src/corelib/kernel/
+src/corelib/thread/
+src/corelib/tools/
+"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -dbus-linked"
+
+ qt4-build_src_compile
+}