summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-12-03 17:22:08 +0000
committerAlex Alexander <wired@gentoo.org>2009-12-03 17:22:08 +0000
commitbf71c584f7f4c4a71150d54a76408c0a7194112d (patch)
tree6f20c28ac970d1a5fa083231e0c7106cff9847ee /x11-libs/qt-core
parentMarking gst-plugins-soup-0.10.14 ppc64 for bug 281427 (diff)
downloadgentoo-2-bf71c584f7f4c4a71150d54a76408c0a7194112d.tar.gz
gentoo-2-bf71c584f7f4c4a71150d54a76408c0a7194112d.tar.bz2
gentoo-2-bf71c584f7f4c4a71150d54a76408c0a7194112d.zip
added qt-4.6-nolibx11.diff patch
(Portage version: 2.2_rc54/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-core')
-rw-r--r--x11-libs/qt-core/ChangeLog6
-rw-r--r--x11-libs/qt-core/files/qt-4.6-nolibx11.diff18
-rw-r--r--x11-libs/qt-core/qt-core-4.6.0.ebuild6
3 files changed, 28 insertions, 2 deletions
diff --git a/x11-libs/qt-core/ChangeLog b/x11-libs/qt-core/ChangeLog
index 7fd0badfa5b1..a8bd800af802 100644
--- a/x11-libs/qt-core/ChangeLog
+++ b/x11-libs/qt-core/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-core
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.80 2009/12/01 18:10:44 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/ChangeLog,v 1.81 2009/12/03 17:22:07 wired Exp $
+
+ 03 Dec 2009; Alex Alexander <wired@gentoo.org>
+ +files/qt-4.6-nolibx11.diff, qt-core-4.6.0.ebuild:
+ added qt-4.6-nolibx11.diff patch
01 Dec 2009; Theo Chatzimichos <tampakrap@gentoo.org>
-qt-core-4.6.0_rc1.ebuild:
diff --git a/x11-libs/qt-core/files/qt-4.6-nolibx11.diff b/x11-libs/qt-core/files/qt-4.6-nolibx11.diff
new file mode 100644
index 000000000000..d3c1d1f75121
--- /dev/null
+++ b/x11-libs/qt-core/files/qt-4.6-nolibx11.diff
@@ -0,0 +1,18 @@
+--- configure.old 2009-12-03 18:52:58.061117684 +0200
++++ configure 2009-12-03 18:53:09.065116496 +0200
+@@ -5010,15 +5010,6 @@
+ X11TESTS_FLAGS="$X11TESTS_FLAGS -fpermissive"
+ fi
+
+- # Check we actually have X11 :-)
+- "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/xlib "XLib" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS
+- if [ $? != "0" ]; then
+- echo "Basic XLib functionality test failed!"
+- echo " You might need to modify the include and library search paths by editing"
+- echo " QMAKE_INCDIR_X11 and QMAKE_LIBDIR_X11 in ${XQMAKESPEC}."
+- exit 1
+- fi
+-
+ # auto-detect OpenGL support (es1 = OpenGL ES 1.x Common, es1cl = ES 1.x common lite, es2 = OpenGL ES 2.x)
+ if [ "$CFG_OPENGL" = "auto" ] || [ "$CFG_OPENGL" = "yes" ]; then
+ if "$unixtests/compile.test" "$XQMAKESPEC" "$QMAKE_CONFIG" $OPT_VERBOSE "$relpath" "$outpath" config.tests/x11/opengl "OpenGL" $L_FLAGS $I_FLAGS $l_FLAGS $X11TESTS_FLAGS; then
diff --git a/x11-libs/qt-core/qt-core-4.6.0.ebuild b/x11-libs/qt-core/qt-core-4.6.0.ebuild
index d3c7c628031b..1ca7628fc7b1 100644
--- a/x11-libs/qt-core/qt-core-4.6.0.ebuild
+++ b/x11-libs/qt-core/qt-core-4.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.6.0.ebuild,v 1.1 2009/12/01 14:45:44 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-core/qt-core-4.6.0.ebuild,v 1.2 2009/12/03 17:22:07 wired Exp $
EAPI="2"
inherit qt4-build
@@ -52,6 +52,10 @@ src/script
tools/linguist/shared
translations"
+PATCHES=(
+ "${FILESDIR}/qt-4.6-nolibx11.diff"
+)
+
pkg_setup() {
qt4-build_pkg_setup