summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-08-14 22:26:41 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-08-14 22:26:41 +0000
commit21e13a5a3d373f2e8b51c691a3f7e5e073bbd8a6 (patch)
treeeb7e3abeb51afab2e19a7f2b3905ed841392a437 /x11-libs/libxcb/libxcb-1.7.ebuild
parentAdd support for USE=webserver #305229 by Jan Vansteenkiste. (diff)
downloadgentoo-2-21e13a5a3d373f2e8b51c691a3f7e5e073bbd8a6.tar.gz
gentoo-2-21e13a5a3d373f2e8b51c691a3f7e5e073bbd8a6.tar.bz2
gentoo-2-21e13a5a3d373f2e8b51c691a3f7e5e073bbd8a6.zip
Version bump. Drop older.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libxcb/libxcb-1.7.ebuild')
-rw-r--r--x11-libs/libxcb/libxcb-1.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-libs/libxcb/libxcb-1.7.ebuild b/x11-libs/libxcb/libxcb-1.7.ebuild
new file mode 100644
index 000000000000..7f18d34155b8
--- /dev/null
+++ b/x11-libs/libxcb/libxcb-1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxcb/libxcb-1.7.ebuild,v 1.1 2010/08/14 22:26:41 scarabeus Exp $
+
+EAPI=3
+
+inherit python xorg-2
+
+DESCRIPTION="X C-language Bindings library"
+HOMEPAGE="http://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/libxcb"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="http://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc selinux"
+
+RDEPEND="x11-libs/libXau
+ x11-libs/libXdmcp
+ dev-libs/libpthread-stubs"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ dev-libs/libxslt
+ >=x11-proto/xcb-proto-1.6
+ =dev-lang/python-2*[xml]"
+
+pkg_setup() {
+ python_set_active_version 2
+ xorg-2_pkg_setup
+ CONFIGURE_OPTIONS="$(use_enable doc build-docs)
+ $(use_enable selinux)
+ --enable-xinput"
+}