summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-09-14 15:22:37 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-09-14 15:22:37 +0000
commitfecfb846f3f19cff86270f053f67a93b915c747d (patch)
tree0870a885977029545ec5120413aad864e732c10f /x11-libs/libsexy
parentForcing Manifest regeneration. (diff)
downloadgentoo-2-fecfb846f3f19cff86270f053f67a93b915c747d.tar.gz
gentoo-2-fecfb846f3f19cff86270f053f67a93b915c747d.tar.bz2
gentoo-2-fecfb846f3f19cff86270f053f67a93b915c747d.zip
Use Libs.private instead of Libs to pass libraries for static linking wrt #380193 by Diego Elio Pettenò
(Portage version: 2.2.0_alpha55/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libsexy')
-rw-r--r--x11-libs/libsexy/ChangeLog9
-rw-r--r--x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch12
-rw-r--r--x11-libs/libsexy/libsexy-0.1.11-r3.ebuild52
3 files changed, 72 insertions, 1 deletions
diff --git a/x11-libs/libsexy/ChangeLog b/x11-libs/libsexy/ChangeLog
index 9c0eae12924c..7114ed21514c 100644
--- a/x11-libs/libsexy/ChangeLog
+++ b/x11-libs/libsexy/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/libsexy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/ChangeLog,v 1.53 2011/05/21 04:43:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/ChangeLog,v 1.54 2011/09/14 15:22:37 ssuominen Exp $
+
+*libsexy-0.1.11-r3 (14 Sep 2011)
+
+ 14 Sep 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +libsexy-0.1.11-r3.ebuild, +files/libsexy-0.1.11-pkgconfig-pollution.patch:
+ Use Libs.private instead of Libs to pass libraries for static linking wrt
+ #380193 by Diego Elio Pettenò
21 May 2011; Samuli Suominen <ssuominen@gentoo.org> libsexy-0.1.11-r2.ebuild:
ppc/ppc64 stable wrt #361917
diff --git a/x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch b/x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch
new file mode 100644
index 000000000000..faf16dea71ca
--- /dev/null
+++ b/x11-libs/libsexy/files/libsexy-0.1.11-pkgconfig-pollution.patch
@@ -0,0 +1,12 @@
+--- libsexy.pc.in
++++ libsexy.pc.in
+@@ -6,7 +6,8 @@
+ Name: libsexy
+ Description: Doing naughty things to good widgets
+ Version: @VERSION@
+-Libs: -L${libdir} -lsexy @PACKAGE_LIBS@
++Libs: -L${libdir} -lsexy
++Libs.private: @PACKAGE_LIBS@
+ Cflags: -I${includedir} @PACKAGE_CFLAGS@
+
+
diff --git a/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild b/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild
new file mode 100644
index 000000000000..c1859410d647
--- /dev/null
+++ b/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libsexy/libsexy-0.1.11-r3.ebuild,v 1.1 2011/09/14 15:22:37 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Sexy GTK+ Widgets"
+HOMEPAGE="http://www.chipx86.com/wiki/Libsexy"
+SRC_URI="http://releases.chipx86.com/${PN}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.6:2
+ dev-libs/libxml2
+ >=x11-libs/pango-1.4.0
+ >=app-text/iso-codes-0.49"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/pkgconfig-0.19
+ dev-util/gtk-doc-am
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS=( AUTHORS ChangeLog NEWS )
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-fix-null-list.patch \
+ "${FILESDIR}"/${P}-pkgconfig-pollution.patch
+
+ sed -i \
+ -e 's:noinst_PROGRAMS:check_PROGRAMS:' \
+ tests/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable doc gtk-doc) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}