summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-05-04 12:03:19 +0000
committerJustin Lecher <jlec@gentoo.org>2013-05-04 12:03:19 +0000
commitd8b5c9fc9e7ef4e4b3bad1506c36031c4c0abab9 (patch)
tree2c1bcd6240da25c2c9b6cc2fee506c4ba2a0ede4 /x11-libs/guile-gtk
parentVersion bump (diff)
downloadgentoo-2-d8b5c9fc9e7ef4e4b3bad1506c36031c4c0abab9.tar.gz
gentoo-2-d8b5c9fc9e7ef4e4b3bad1506c36031c4c0abab9.tar.bz2
gentoo-2-d8b5c9fc9e7ef4e4b3bad1506c36031c4c0abab9.zip
x11-libs/guile-gtk: Moved to autotools-utils.eclass, fixed old macros for automake-1.13, #468562
(Portage version: 2.2.0_alpha173/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'x11-libs/guile-gtk')
-rw-r--r--x11-libs/guile-gtk/ChangeLog7
-rw-r--r--x11-libs/guile-gtk/guile-gtk-2.1-r2.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-libs/guile-gtk/ChangeLog b/x11-libs/guile-gtk/ChangeLog
index 03ea771ac55c..8073927b6be4 100644
--- a/x11-libs/guile-gtk/ChangeLog
+++ b/x11-libs/guile-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/guile-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/ChangeLog,v 1.44 2013/02/13 20:32:52 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/ChangeLog,v 1.45 2013/05/04 12:03:19 jlec Exp $
+
+*guile-gtk-2.1-r2 (04 May 2013)
+
+ 04 May 2013; Justin Lecher <jlec@gentoo.org> +guile-gtk-2.1-r2.ebuild:
+ Moved to autotools-utils.eclass, fixed old macros for automake-1.13, #468562
13 Feb 2013; Pacho Ramos <pacho@gentoo.org>
-files/guile-gtk-0.19-Makefile.in.patch, -guile-gtk-1.2.0.31.ebuild,
diff --git a/x11-libs/guile-gtk/guile-gtk-2.1-r2.ebuild b/x11-libs/guile-gtk/guile-gtk-2.1-r2.ebuild
new file mode 100644
index 000000000000..e9e80648e8e5
--- /dev/null
+++ b/x11-libs/guile-gtk/guile-gtk-2.1-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/guile-gtk-2.1-r2.ebuild,v 1.1 2013/05/04 12:03:19 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils virtualx
+
+DESCRIPTION="GTK+ bindings for guile"
+HOMEPAGE="http://www.gnu.org/software/guile-gtk/"
+SRC_URI="ftp://ftp.gnu.org/gnu/guile-gtk/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-scheme/guile[deprecated(+)]
+ x11-libs/gtk+:2
+ gnome-base/libglade:2.0
+ >=x11-libs/gtkglarea-1.90:2"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.0-g-object-ref.diff
+ "${FILESDIR}"/${PV}-prll-install.patch
+ "${FILESDIR}"/${PV}-brokentest.patch
+)
+
+src_prepare() {
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_test() {
+ cd "${BUILD_DIR}" || die
+ Xemake check
+}
+
+src_install() {
+ autotools-utils_src_install
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}