summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-10-07 10:59:55 +0000
committerMart Raudsepp <leio@gentoo.org>2008-10-07 10:59:55 +0000
commitdf0c5c673b609d274f111b35e3c70eaec5ca49a0 (patch)
treeff72790660210caecc4255874bf2abb18b1c7fbf /x11-libs/gtksourceview
parentAdded patches to prevent stripping of binaries and repect LDFLAGS (see bug #2... (diff)
downloadgentoo-2-df0c5c673b609d274f111b35e3c70eaec5ca49a0.tar.gz
gentoo-2-df0c5c673b609d274f111b35e3c70eaec5ca49a0.tar.bz2
gentoo-2-df0c5c673b609d274f111b35e3c70eaec5ca49a0.zip
New major version. Adds function to guess language for a given filename and mime type; allows setting background color of paragraphs with marks; supports drawing white spaces; improvements to some language syntax files
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog9
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.4.0.ebuild31
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index 436c75834b02..25f5e58f9f08 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.143 2008/09/25 14:36:44 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.144 2008/10/07 10:59:55 leio Exp $
+
+*gtksourceview-2.4.0 (07 Oct 2008)
+
+ 07 Oct 2008; Mart Raudsepp <leio@gentoo.org> +gtksourceview-2.4.0.ebuild:
+ New major version. Adds function to guess language for a given filename
+ and mime type; allows setting background color of paragraphs with marks;
+ supports drawing white spaces; improvements to some language syntax files
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> gtksourceview-2.2.2.ebuild:
Stable for HPPA (bug #236971).
diff --git a/x11-libs/gtksourceview/gtksourceview-2.4.0.ebuild b/x11-libs/gtksourceview/gtksourceview-2.4.0.ebuild
new file mode 100644
index 000000000000..b607ecfa8137
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.4.0.ebuild,v 1.1 2008/10/07 10:59:55 leio Exp $
+
+inherit gnome2
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2.14"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}