summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-15 23:50:53 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-15 23:50:53 +0000
commit7d9e5b8d61495c062c008e007115d778f2007ad8 (patch)
tree0b540ad681bef1d8d15b2aa49f97e36dc43446e9 /x11-libs/gtksourceview
parentVersion bump, remove old. (diff)
downloadgentoo-2-7d9e5b8d61495c062c008e007115d778f2007ad8.tar.gz
gentoo-2-7d9e5b8d61495c062c008e007115d778f2007ad8.tar.bz2
gentoo-2-7d9e5b8d61495c062c008e007115d778f2007ad8.zip
Version bump.
(Portage version: 2.1.10.27/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtksourceview')
-rw-r--r--x11-libs/gtksourceview/ChangeLog7
-rw-r--r--x11-libs/gtksourceview/gtksourceview-3.2.1.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/x11-libs/gtksourceview/ChangeLog b/x11-libs/gtksourceview/ChangeLog
index b67f54921577..a2cb61c9aa82 100644
--- a/x11-libs/gtksourceview/ChangeLog
+++ b/x11-libs/gtksourceview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtksourceview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.209 2011/09/28 11:27:24 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/ChangeLog,v 1.210 2011/10/15 23:50:53 pacho Exp $
+
+*gtksourceview-3.2.1 (15 Oct 2011)
+
+ 15 Oct 2011; Pacho Ramos <pacho@gentoo.org> +gtksourceview-3.2.1.ebuild:
+ Version bump.
*gtksourceview-3.2.0 (28 Sep 2011)
diff --git a/x11-libs/gtksourceview/gtksourceview-3.2.1.ebuild b/x11-libs/gtksourceview/gtksourceview-3.2.1.ebuild
new file mode 100644
index 000000000000..fd2fd1159927
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-3.2.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.2.1.ebuild,v 1.1 2011/10/15 23:50:53 pacho Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 virtualx
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://projects.gnome.org/gtksourceview/"
+
+LICENSE="GPL-2"
+SLOT="3.0"
+IUSE="doc glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
+
+# Note: has native OSX support, prefix teams, attack!
+RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
+ >=dev-libs/libxml2-2.6:2
+ >=dev-libs/glib-2.28:2
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.17
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1.11 )"
+
+pkg_setup() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-deprecations
+ --disable-maintainer-mode
+ --enable-providers
+ $(use_enable glade glade-catalog)
+ $(use_enable introspection)"
+}
+
+src_prepare() {
+ sed -i -e 's:--warn-all::' gtksourceview/Makefile.in || die
+
+ # Skip broken test until upstream bug #621383 is solved
+ sed -e "/guess-language/d" \
+ -e "/get-language/d" \
+ -i tests/test-languagemanager.c || die
+
+ gnome2_src_prepare
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-3.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}