summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-12-05 23:27:08 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-12-05 23:27:08 +0000
commit22845521c2c2d028d668c26d96a9426f07abbb06 (patch)
treeeb904cd7bec6f442dfd146219a7932fa871b3e0d /x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild
parentBunch of fixes from project overlay (diff)
downloadgentoo-2-22845521c2c2d028d668c26d96a9426f07abbb06.tar.gz
gentoo-2-22845521c2c2d028d668c26d96a9426f07abbb06.tar.bz2
gentoo-2-22845521c2c2d028d668c26d96a9426f07abbb06.zip
bump to 2.0.2
(Portage version: 2.1.4_rc7)
Diffstat (limited to 'x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild')
-rw-r--r--x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild b/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild
new file mode 100644
index 000000000000..9bf17b30798b
--- /dev/null
+++ b/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-2.0.2.ebuild,v 1.1 2007/12/05 23:27:07 eva Exp $
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="A text widget implementing syntax highlighting and other features"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/glib-2
+ >=dev-libs/libpcre-7.4"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ # Removes the gnome-vfs dep
+ G2CONF="${G2CONF} --disable-build-tests --with-system-pcre"
+}
+
+src_install() {
+ gnome2_src_install
+
+ insinto /usr/share/${PN}-2.0/language-specs
+ doins "${FILESDIR}"/2.0/gentoo.lang
+}