summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-11-16 23:44:46 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-11-16 23:44:46 +0000
commit707792d7a4f8b32bf35cb2a6c01f552e2675bdb0 (patch)
treec3acabcaec6c3c871d87be5368b3a05f126f0478 /x11-libs/gtk+
parentQA: do not pass unrecognized configure options (diff)
downloadgentoo-2-707792d7a4f8b32bf35cb2a6c01f552e2675bdb0.tar.gz
gentoo-2-707792d7a4f8b32bf35cb2a6c01f552e2675bdb0.tar.bz2
gentoo-2-707792d7a4f8b32bf35cb2a6c01f552e2675bdb0.zip
Fix abort when icon widgets on gtktoolbuttons aren't GtkMisc, needed by gnome-boxes
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/gtk+-3.2.2-toolbutton-icon-widget-GtkMisc.patch52
-rw-r--r--x11-libs/gtk+/gtk+-3.2.2-r1.ebuild200
3 files changed, 260 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index ec31dac3124b..c780de1f0992 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.550 2011/11/16 21:54:12 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.551 2011/11/16 23:44:46 nirbheek Exp $
+
+*gtk+-3.2.2-r1 (16 Nov 2011)
+
+ 16 Nov 2011; Nirbheek Chauhan <nirbheek@gentoo.org> +gtk+-3.2.2-r1.ebuild,
+ +files/gtk+-3.2.2-toolbutton-icon-widget-GtkMisc.patch:
+ Fix abort when icon widgets on gtktoolbuttons aren't GtkMisc, needed by
+ gnome-boxes
*gtk+-2.24.8 (16 Nov 2011)
diff --git a/x11-libs/gtk+/files/gtk+-3.2.2-toolbutton-icon-widget-GtkMisc.patch b/x11-libs/gtk+/files/gtk+-3.2.2-toolbutton-icon-widget-GtkMisc.patch
new file mode 100644
index 000000000000..fa9c52eed829
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.2.2-toolbutton-icon-widget-GtkMisc.patch
@@ -0,0 +1,52 @@
+From 5cf0450c69f7bbdb0d1ca22ec54355e3b3e8c9c2 Mon Sep 17 00:00:00 2001
+From: Cosimo Cecchi <cosimoc@gnome.org>
+Date: Tue, 27 Sep 2011 21:06:59 +0000
+Subject: toolbutton: don't force the icon widget to be a GtkMisc
+
+There's really no reason the icon widget must be a GtkMisc. You might
+want to use e.g. a GtkSpinner.
+---
+diff --git a/gtk/gtktoolbutton.c b/gtk/gtktoolbutton.c
+index 8ee5fdf..934ca61 100644
+--- a/gtk/gtktoolbutton.c
++++ b/gtk/gtktoolbutton.c
+@@ -972,9 +972,9 @@ gtk_tool_button_new_from_stock (const gchar *stock_id)
+ /**
+ * gtk_tool_button_new:
+ * @label: (allow-none): a string that will be used as label, or %NULL
+- * @icon_widget: (allow-none): a #GtkMisc widget that will be used as icon widget, or %NULL
++ * @icon_widget: (allow-none): a widget that will be used as the button contents, or %NULL
+ *
+- * Creates a new %GtkToolButton using @icon_widget as icon and @label as
++ * Creates a new %GtkToolButton using @icon_widget as contents and @label as
+ * label.
+ *
+ * Return value: A new #GtkToolButton
+@@ -987,7 +987,7 @@ gtk_tool_button_new (GtkWidget *icon_widget,
+ {
+ GtkToolButton *button;
+
+- g_return_val_if_fail (icon_widget == NULL || GTK_IS_MISC (icon_widget), NULL);
++ g_return_val_if_fail (icon_widget == NULL || GTK_IS_WIDGET (icon_widget), NULL);
+
+ button = g_object_new (GTK_TYPE_TOOL_BUTTON,
+ "label", label,
+diff --git a/tests/testtoolbar.c b/tests/testtoolbar.c
+index 16d847a..aafac3d 100644
+--- a/tests/testtoolbar.c
++++ b/tests/testtoolbar.c
+@@ -680,6 +680,12 @@ main (gint argc, gchar **argv)
+ add_item_to_list (store, item, "Terminal");
+ gtk_toolbar_insert (GTK_TOOLBAR (toolbar), item, -1);
+
++ image = gtk_spinner_new ();
++ gtk_spinner_start (GTK_SPINNER (image));
++ item = gtk_tool_button_new (image, "Spinner");
++ add_item_to_list (store, item, "Spinner");
++ gtk_toolbar_insert (GTK_TOOLBAR (toolbar), item, -1);
++
+ hbox = gtk_box_new (GTK_ORIENTATION_HORIZONTAL, 5);
+ gtk_container_set_border_width (GTK_CONTAINER (hbox), 5);
+ gtk_container_add (GTK_CONTAINER (vbox), hbox);
+--
+cgit v0.9.0.2
diff --git a/x11-libs/gtk+/gtk+-3.2.2-r1.ebuild b/x11-libs/gtk+/gtk+-3.2.2-r1.ebuild
new file mode 100644
index 000000000000..c314f0fcf048
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.2.2-r1.ebuild
@@ -0,0 +1,200 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.2.2-r1.ebuild,v 1.1 2011/11/16 23:44:46 nirbheek Exp $
+
+EAPI="4"
+
+inherit eutils flag-o-matic gnome.org gnome2-utils libtool virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="3"
+# NOTE: This gtk+ has multi-gdk-backend support, see:
+# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
+# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
+# I tried this and got it all compiling, but the end result is unusable as it
+# horribly mixes up the backends -- grobian
+IUSE="aqua colord cups debug doc examples +introspection packagekit test vim-syntax xinerama"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# FIXME: introspection data is built against system installation of gtk+:3
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+# Use gtk+:2 for gtk-update-icon-cache and gtk-builder-convert
+# >=x11-libs/gtk+-2.24:2 is needed for bug 359555
+COMMON_DEPEND="!aqua? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ >=x11-libs/cairo-1.10.0[X,glib,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[X,introspection?]
+ )
+ aqua? (
+ >=x11-libs/cairo-1.10.0[aqua,glib,svg]
+ >=x11-libs/gdk-pixbuf-2.23.5:2[introspection?]
+ )
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.29.14
+ >=x11-libs/pango-1.29.0[introspection?]
+ >=dev-libs/atk-2.1.5[introspection?]
+ >=x11-libs/gtk+-2.24:2
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ colord? ( >=x11-misc/colord-0.1.9 )
+ cups? ( net-print/cups )
+ introspection? ( >=dev-libs/gobject-introspection-0.10.1 )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/pkgconfig-0.9
+ !aqua? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ !<x11-libs/vte-0.30.1-r1:2.90
+ packagekit? ( app-admin/packagekit-base )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ # Fix invalid aborts, taken from git, will probably go into next release
+ epatch "${FILESDIR}/${P}-toolbutton-icon-widget-GtkMisc.patch"
+
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+ sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
+ -i gtk/tests/recentmanager.c || die "sed 2 failed"
+
+ # Missing file, required for tests; https://bugzilla.gnome.org/show_bug.cgi?id=662024
+ cp "${FILESDIR}/${PN}-3.2.1-selector.errors" \
+ tests/css/parser/selector.errors || die "cp failed"
+
+ # FIXME: multiple reftests fail when run from portage (but succeed when
+ # run from a manual compile in a temp directory)
+ sed -e 's:\(SUBDIRS.*\)reftests:\1:' \
+ -i tests/Makefile.* || die "sed 3 failed"
+
+ # Test results depend on the list of mounted filesystems!
+ rm -v tests/a11y/pickers.{ui,txt} || die "rm failed"
+
+ # Failing treeview scrolling tests; bug #384855,
+ # https://bugzilla.gnome.org/show_bug.cgi?id=660931
+ epatch "${FILESDIR}/${PN}-3.2.1-failing-tests.patch"
+
+ if ! use test; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS tests Makefile.am
+ strip_builddir SRC_SUBDIRS tests Makefile.in
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am
+ strip_builddir SRC_SUBDIRS demos Makefile.in
+ fi
+}
+
+src_configure() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc)
+ $(use_enable xinerama)
+ $(use_enable packagekit)
+ $(use_enable cups cups auto)
+ $(use_enable colord)
+ $(use_enable introspection)
+ --disable-papi
+ --enable-gtk2-dependency"
+
+ # XXX: Maybe with multi-backend we should enable x11 all the time?
+ if use aqua; then
+ myconf="${myconf} --enable-quartz-backend --disable-xinput"
+ else
+ myconf="${myconf} --enable-x11-backend --enable-xinput"
+ fi
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ econf --libdir="${EPREFIX}/usr/$(get_libdir)" ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Exporting HOME fixes tests using XDG directories spec since all defaults
+ # are based on $HOME. It is also backward compatible with functions not
+ # yet ported to this spec.
+ XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+
+ # Remove unneeded *.la files
+ find "${D}" -name '*.la' -exec rm -f {} +
+
+ # add -framework Carbon to the .pc files
+ use aqua && for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
+ sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+ done
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+
+ local GTK3_MODDIR="${EROOT}usr/$(get_libdir)/gtk-3.0/3.0.0"
+ gtk-query-immodules-3.0 > "${GTK3_MODDIR}/immodules.cache" \
+ || ewarn "Failed to run gtk-query-immodules-3.0"
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_schemas_update --uninstall
+}