summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-07 18:41:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-07 18:41:50 +0000
commited2527ff06e6e891f0fc6997f16be4003392069a (patch)
treeda8f9e10d788844aa4b449b5bc239b3e33cfcad7 /x11-libs/gl2ps
parentStable on alpha, bug #264512 (diff)
downloadgentoo-2-ed2527ff06e6e891f0fc6997f16be4003392069a.tar.gz
gentoo-2-ed2527ff06e6e891f0fc6997f16be4003392069a.tar.bz2
gentoo-2-ed2527ff06e6e891f0fc6997f16be4003392069a.zip
Initial import
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gl2ps')
-rw-r--r--x11-libs/gl2ps/ChangeLog10
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.3.ebuild37
-rw-r--r--x11-libs/gl2ps/metadata.xml14
3 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/gl2ps/ChangeLog b/x11-libs/gl2ps/ChangeLog
new file mode 100644
index 000000000000..130e12201385
--- /dev/null
+++ b/x11-libs/gl2ps/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/gl2ps
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.1 2009/04/07 18:41:50 bicatali Exp $
+
+*gl2ps-1.3.3 (07 Apr 2009)
+
+ 07 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+ +gl2ps-1.3.3.ebuild:
+ Initial import
+
diff --git a/x11-libs/gl2ps/gl2ps-1.3.3.ebuild b/x11-libs/gl2ps/gl2ps-1.3.3.ebuild
new file mode 100644
index 000000000000..7e0e71a6218f
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.3.ebuild,v 1.1 2009/04/07 18:41:50 bicatali Exp $
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="virtual/glut"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} -fPIC -c gl2ps.c -o gl2ps.o \
+ || die "compiling gl2ps failed"
+ $(tc-getCC) -shared ${LDFLAGS} -Wl,-soname,libgl2ps.so.1 \
+ gl2ps.o -o libgl2ps.so.1 -lm -lGL -lGLU -lglut \
+ || die "linking libgl2ps failed"
+}
+
+src_install () {
+ dolib.so libgl2ps.so.1 || die
+ dosym libgl2ps.so.1 /usr/$(get_libdir)/libgl2ps.so
+ insinto /usr/include
+ doins gl2ps.h || die
+ dodoc TODO
+ insinto /usr/share/doc/${PF}
+ if use doc; then
+ doins gl2psTest* *.pdf || die
+ fi
+}
diff --git a/x11-libs/gl2ps/metadata.xml b/x11-libs/gl2ps/metadata.xml
new file mode 100644
index 000000000000..a9170dc7ac53
--- /dev/null
+++ b/x11-libs/gl2ps/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ GL2PS is a C library providing high quality vector output for any
+ OpenGL application. The main difference between GL2PS and other
+ similar libraries is the use of sorting algorithms
+ capable of handling intersecting and stretched polygons, as well as
+ non manifold objects. GL2PS provides advanced smooth shading and
+ text rendering, culling of invisible primitives, mixed vector/bitmap
+ output, and much more.
+</longdescription>
+</pkgmetadata>