summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2009-12-12 18:22:03 +0000
committerAlexis Ballier <aballier@gentoo.org>2009-12-12 18:22:03 +0000
commite4948068acc454c81531c02c27308f8bdf77c6b0 (patch)
tree21e832ecc4d5144c6f6e60a7758c362d76fb9601 /x11-libs/flowcanvas
parentremove X useflag, only xcb is available now, enable xcb by default (diff)
downloadgentoo-2-e4948068acc454c81531c02c27308f8bdf77c6b0.tar.gz
gentoo-2-e4948068acc454c81531c02c27308f8bdf77c6b0.tar.bz2
gentoo-2-e4948068acc454c81531c02c27308f8bdf77c6b0.zip
version bump
(Portage version: 2.2_rc58/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/flowcanvas')
-rw-r--r--x11-libs/flowcanvas/ChangeLog8
-rw-r--r--x11-libs/flowcanvas/files/ldconfig.patch14
-rw-r--r--x11-libs/flowcanvas/flowcanvas-0.6.0.ebuild48
3 files changed, 69 insertions, 1 deletions
diff --git a/x11-libs/flowcanvas/ChangeLog b/x11-libs/flowcanvas/ChangeLog
index df98aed7fd33..6d631b19c178 100644
--- a/x11-libs/flowcanvas/ChangeLog
+++ b/x11-libs/flowcanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/flowcanvas
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.7 2009/08/02 21:09:04 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.8 2009/12/12 18:22:03 aballier Exp $
+
+*flowcanvas-0.6.0 (12 Dec 2009)
+
+ 12 Dec 2009; Alexis Ballier <aballier@gentoo.org>
+ +flowcanvas-0.6.0.ebuild, +files/ldconfig.patch:
+ version bump
02 Aug 2009; <chainsaw@gentoo.org> flowcanvas-0.5.1.ebuild:
Marked stable on AMD64 as a dependency of media-sound/patchage-0.4.2;
diff --git a/x11-libs/flowcanvas/files/ldconfig.patch b/x11-libs/flowcanvas/files/ldconfig.patch
new file mode 100644
index 000000000000..f53ff9e7df59
--- /dev/null
+++ b/x11-libs/flowcanvas/files/ldconfig.patch
@@ -0,0 +1,14 @@
+Index: slv2-0.6.2/autowaf.py
+===================================================================
+--- slv2-0.6.2.orig/autowaf.py
++++ slv2-0.6.2/autowaf.py
+@@ -324,8 +324,5 @@ def build_dox(bld, name, version, srcdir
+ out1.command_is_external = True
+
+ def shutdown():
+- # This isn't really correct (for packaging), but people asking is annoying
+- if Options.commands['install']:
+- try: os.popen("/sbin/ldconfig")
+- except: pass
++ return
+
diff --git a/x11-libs/flowcanvas/flowcanvas-0.6.0.ebuild b/x11-libs/flowcanvas/flowcanvas-0.6.0.ebuild
new file mode 100644
index 000000000000..c490fea2e38d
--- /dev/null
+++ b/x11-libs/flowcanvas/flowcanvas-0.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/flowcanvas-0.6.0.ebuild,v 1.1 2009/12/12 18:22:03 aballier Exp $
+
+EAPI=2
+
+inherit toolchain-funcs multilib eutils
+
+DESCRIPTION="Gtkmm/Gnomecanvasmm widget for boxes and lines environments"
+HOMEPAGE="http://wiki.drobilla.net/FlowCanvas"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-libs/boost
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libgnomecanvasmm-2.6
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig.patch"
+}
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--build-docs") \
+ || die
+}
+
+src_compile() {
+ ./waf || die
+}
+
+src_install() {
+ ./waf install --destdir="${D}" || die
+ dodoc AUTHORS README ChangeLog
+}