summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-08-25 22:34:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-08-25 22:34:50 +0000
commita561129b011b69df38e4c4acba238a960ac4db5a (patch)
tree8b045d261a5131d9c7c836460f28137c186d065f /x11-libs/colord-gtk
parentVersion bump, bug #481902. (diff)
downloadgentoo-2-a561129b011b69df38e4c4acba238a960ac4db5a.tar.gz
gentoo-2-a561129b011b69df38e4c4acba238a960ac4db5a.tar.bz2
gentoo-2-a561129b011b69df38e4c4acba238a960ac4db5a.zip
Version bump.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-libs/colord-gtk')
-rw-r--r--x11-libs/colord-gtk/ChangeLog8
-rw-r--r--x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/x11-libs/colord-gtk/ChangeLog b/x11-libs/colord-gtk/ChangeLog
index 8f59bc929f52..fa3cfadbede1 100644
--- a/x11-libs/colord-gtk/ChangeLog
+++ b/x11-libs/colord-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/colord-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/colord-gtk/ChangeLog,v 1.21 2013/03/30 17:16:01 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/colord-gtk/ChangeLog,v 1.22 2013/08/25 22:34:50 eva Exp $
+
+*colord-gtk-0.1.25 (25 Aug 2013)
+
+ 25 Aug 2013; Gilles Dartiguelongue <eva@gentoo.org>
+ +colord-gtk-0.1.25.ebuild:
+ Version bump.
30 Mar 2013; Gilles Dartiguelongue <eva@gentoo.org>
-files/colord-gtk-0.1.22-automagic-vala.patch,
diff --git a/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild b/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild
new file mode 100644
index 000000000000..e60ba7a337ea
--- /dev/null
+++ b/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/colord-gtk/colord-gtk-0.1.25.ebuild,v 1.1 2013/08/25 22:34:50 eva Exp $
+
+EAPI="5"
+VALA_MIN_API_VERSION="0.14"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils vala
+
+DESCRIPTION="GTK support library for colord"
+HOMEPAGE="http://www.freedesktop.org/software/colord/"
+SRC_URI="http://www.freedesktop.org/software/colord/releases/${P}.tar.xz"
+
+LICENSE="LGPL-3+"
+SLOT="0/1" # subslot = libcolord-gtk soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.28:2
+ >=media-libs/lcms-2.2:2=
+ x11-libs/gdk-pixbuf:2[introspection?]
+ x11-libs/gtk+:3[X(+),introspection?]
+ x11-misc/colord:=[introspection?,vala?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.8 )"
+# ${PN} was part of x11-misc/colord until 0.1.22
+RDEPEND="${COMMON_DEPEND}
+ !<x11-misc/colord-0.1.27
+"
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-libs/libxslt
+ >=dev-util/intltool-0.35
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ >=dev-util/gtk-doc-1.9
+ )
+ vala? ( $(vala_depend) )
+"
+
+RESTRICT="test" # Tests need a display device with a default color profile set
+
+src_prepare() {
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable doc gtk-doc) \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+}