summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2006-11-18 06:58:08 +0000
committerDoug Goldstein <cardoe@gentoo.org>2006-11-18 06:58:08 +0000
commit735fa419896954c9fa2939d8b82d78f766418481 (patch)
treeca5a8691bad111f16fd66c1c9e72773ecb43509d /x11-libs/cairo
parentdrop gnome useflag for gnome-1.x removal (diff)
downloadgentoo-2-735fa419896954c9fa2939d8b82d78f766418481.tar.gz
gentoo-2-735fa419896954c9fa2939d8b82d78f766418481.tar.bz2
gentoo-2-735fa419896954c9fa2939d8b82d78f766418481.zip
rev bump. always enable png since it was causing a mess without it and doesn't make sense without it really
(Portage version: 2.1.2_rc2)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog9
-rw-r--r--x11-libs/cairo/cairo-1.2.4.ebuild8
-rw-r--r--x11-libs/cairo/cairo-1.2.6.ebuild61
-rw-r--r--x11-libs/cairo/files/digest-cairo-1.2.63
4 files changed, 76 insertions, 5 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 776631be5fa3..cc30b1e945de 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.82 2006/10/20 13:27:12 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.83 2006/11/18 06:58:08 cardoe Exp $
+
+*cairo-1.2.6 (18 Nov 2006)
+
+ 18 Nov 2006; Doug Goldstein <cardoe@gentoo.org> cairo-1.2.4.ebuild,
+ +cairo-1.2.6.ebuild:
+ rev bump. always enable png since it was causing a mess without it and
+ doesn't make sense without it really
20 Oct 2006; Aron Griffis <agriffis@gentoo.org> cairo-1.0.4-r1.ebuild:
Mark 1.0.4-r1 stable on alpha
diff --git a/x11-libs/cairo/cairo-1.2.4.ebuild b/x11-libs/cairo/cairo-1.2.4.ebuild
index c7c98e68a760..317dfb1840b2 100644
--- a/x11-libs/cairo/cairo-1.2.4.ebuild
+++ b/x11-libs/cairo/cairo-1.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.4.ebuild,v 1.1 2006/08/26 01:06:47 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.4.ebuild,v 1.2 2006/11/18 06:58:08 cardoe Exp $
inherit eutils flag-o-matic
@@ -18,6 +18,7 @@ RESTRICT="test"
RDEPEND="media-libs/fontconfig
>=media-libs/freetype-2.1.4
+ media-libs/libpng
X? (
|| (
(
@@ -31,7 +32,6 @@ RDEPEND="media-libs/fontconfig
)
directfb? ( >=dev-libs/DirectFB-0.9.24 )
glitz? ( >=media-libs/glitz-0.5.1 )
- png? ( media-libs/libpng )
svg? ( dev-libs/libxml2 )
!<x11-libs/cairo-0.2"
DEPEND="${RDEPEND}
@@ -47,8 +47,8 @@ src_compile() {
append-flags -finline-limit=1200
econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
- $(use_enable png) $(use_enable svg) $(use_enable pdf) \
- $(use_enable glitz) --enable-freetype --enable-ps \
+ $(use_enable svg) $(use_enable pdf) \
+ $(use_enable glitz) --enable-png --enable-freetype --enable-ps \
|| die "configure failed"
emake || die "compile failed"
diff --git a/x11-libs/cairo/cairo-1.2.6.ebuild b/x11-libs/cairo/cairo-1.2.6.ebuild
new file mode 100644
index 000000000000..c45192388a0d
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.2.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.2.6.ebuild,v 1.1 2006/11/18 06:58:08 cardoe Exp $
+
+inherit eutils flag-o-matic debug
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="directfb doc glitz pdf png svg X"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.4
+ media-libs/libpng
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ X? ( x11-proto/renderproto )
+ doc? (
+ >=dev-util/gtk-doc-1.3
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_compile() {
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) $(use_enable directfb) \
+ $(use_enable debug) $(use_enable svg) $(use_enable pdf) \
+ $(use_enable glitz) --enable-png --enable-freetype --enable-ps \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ echo
+ ewarn "You will most likely need to run revdep-rebuild after emerging this"
+ echo
+}
diff --git a/x11-libs/cairo/files/digest-cairo-1.2.6 b/x11-libs/cairo/files/digest-cairo-1.2.6
new file mode 100644
index 000000000000..5d40c4d7de36
--- /dev/null
+++ b/x11-libs/cairo/files/digest-cairo-1.2.6
@@ -0,0 +1,3 @@
+MD5 487b3d7515752fe57f780d0fd707b01a cairo-1.2.6.tar.gz 2973689
+RMD160 4469a661b294e342ee77e726c1cefccd4837ae2e cairo-1.2.6.tar.gz 2973689
+SHA256 7d36449c9a05c2c9b44248b10e9f82f0bca99f30e24848435e65aca77c28b3f9 cairo-1.2.6.tar.gz 2973689