summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-06-04 19:07:15 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-06-04 19:07:15 +0000
commitf0ecc3e816cdab1c64165c40d7752ab9f51a6864 (patch)
treea35777a22e2b2f4a0d1e199a23857af86730ab46 /x11-libs/cairo/files
parentVersion bump (diff)
downloadgentoo-2-f0ecc3e816cdab1c64165c40d7752ab9f51a6864.tar.gz
gentoo-2-f0ecc3e816cdab1c64165c40d7752ab9f51a6864.tar.bz2
gentoo-2-f0ecc3e816cdab1c64165c40d7752ab9f51a6864.zip
remove 1.6.x pre-releases
(Portage version: 2.1.5.3)
Diffstat (limited to 'x11-libs/cairo/files')
-rw-r--r--x11-libs/cairo/files/cairo-1.6.2-fix-g++-linking.patch17
-rw-r--r--x11-libs/cairo/files/cairo-1.6.2-mutex-crash-fix.patch12
2 files changed, 0 insertions, 29 deletions
diff --git a/x11-libs/cairo/files/cairo-1.6.2-fix-g++-linking.patch b/x11-libs/cairo/files/cairo-1.6.2-fix-g++-linking.patch
deleted file mode 100644
index f96e115bfb59..000000000000
--- a/x11-libs/cairo/files/cairo-1.6.2-fix-g++-linking.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/src/Makefile.am b/src/Makefile.am
-index dfdcf1e..16c8301 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -235,11 +235,10 @@ beos_sources = cairo-beos-surface.cpp
- cairo_all_sources += $(beos_headers) $(beos_sources)
- if CAIRO_HAS_BEOS_SURFACE
- cairo_headers += $(beos_headers)
--cairo_sources += $(beos_sources)
- backend_pkgconfigs += cairo-beos.pc
-
- noinst_LTLIBRARIES = libcairo_beos.la
--libcairo_beos_la_SOURCES = $(libcairo_beos_sources)
-+libcairo_beos_la_SOURCES = $(beos_sources)
- # BeOS system headers trigger this warning
- libcairo_beos_la_CXXFLAGS = -Wno-multichar
- endif
diff --git a/x11-libs/cairo/files/cairo-1.6.2-mutex-crash-fix.patch b/x11-libs/cairo/files/cairo-1.6.2-mutex-crash-fix.patch
deleted file mode 100644
index 4632ea1ff5ac..000000000000
--- a/x11-libs/cairo/files/cairo-1.6.2-mutex-crash-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/cairo-xlib-screen.c b/src/cairo-xlib-screen.c
-index c456b16..60421cd 100644
---- a/src/cairo-xlib-screen.c
-+++ b/src/cairo-xlib-screen.c
-@@ -400,6 +400,7 @@ _cairo_xlib_screen_get_gc (cairo_xlib_screen_info_t *info, int depth)
- gc = info->gc[depth];
- info->gc[depth] = NULL;
- needs_reset = info->gc_needs_clip_reset & (1 << depth);
-+ info->gc_needs_clip_reset &= ~(1 << depth);
- CAIRO_MUTEX_UNLOCK (info->mutex);
-
- if (needs_reset)