summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-03-15 02:16:34 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-03-15 02:16:34 +0000
commitb9dee276fe25f118cd88029a89be634afc0d64d9 (patch)
tree51f4c37b6378d659cb1b6cfc7dd5765599c8a6d3 /x11-drivers/xf86-video-i810
parentUnmask xf86-video-ati 6.8 (and older RCs). (diff)
downloadgentoo-2-b9dee276fe25f118cd88029a89be634afc0d64d9.tar.gz
gentoo-2-b9dee276fe25f118cd88029a89be634afc0d64d9.tar.bz2
gentoo-2-b9dee276fe25f118cd88029a89be634afc0d64d9.zip
Detect libpciaccess correctly to fix build with 1.5 servers.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-drivers/xf86-video-i810')
-rw-r--r--x11-drivers/xf86-video-i810/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-i810/files/0001-fixup-pciaccess-version-detect.patch28
-rw-r--r--x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild5
3 files changed, 37 insertions, 3 deletions
diff --git a/x11-drivers/xf86-video-i810/ChangeLog b/x11-drivers/xf86-video-i810/ChangeLog
index f5fe7948fd90..143662a0ad1e 100644
--- a/x11-drivers/xf86-video-i810/ChangeLog
+++ b/x11-drivers/xf86-video-i810/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-i810
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/ChangeLog,v 1.80 2008/02/27 10:55:37 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/ChangeLog,v 1.81 2008/03/15 02:16:33 dberkholz Exp $
+
+ 15 Mar 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/0001-fixup-pciaccess-version-detect.patch,
+ xf86-video-i810-2.2.1.ebuild:
+ Detect libpciaccess correctly to fix build with 1.5 servers.
*xf86-video-i810-2.2.1 (27 Feb 2008)
diff --git a/x11-drivers/xf86-video-i810/files/0001-fixup-pciaccess-version-detect.patch b/x11-drivers/xf86-video-i810/files/0001-fixup-pciaccess-version-detect.patch
new file mode 100644
index 000000000000..0644a02c11b1
--- /dev/null
+++ b/x11-drivers/xf86-video-i810/files/0001-fixup-pciaccess-version-detect.patch
@@ -0,0 +1,28 @@
+From 13ae79b415d944891cfdc2cd2d5397fec36a4e8e Mon Sep 17 00:00:00 2001
+From: Dave Airlie <airlied@redhat.com>
+Date: Fri, 7 Mar 2008 08:04:37 +1000
+Subject: [PATCH] fixup pciaccess version detect
+
+---
+ configure.ac | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 9e7c5b9..da44018 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -115,9 +115,9 @@ AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
+ CFLAGS="$save_CFLAGS"
+
+ if test x$XSERVER_LIBPCIACCESS = xyes; then
+- PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10.0])
++ PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10])
+ else
+- PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10.0],
++ PKG_CHECK_MODULES([PCIACCESS], [pciaccess >= 0.10],
+ have_libpciaccess=yes,
+ have_libpciaccess=no)
+ fi
+--
+1.5.4.3
+
diff --git a/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild b/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild
index c871673245e6..e907ac505d5f 100644
--- a/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild
+++ b/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild,v 1.1 2008/02/27 10:55:37 remi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-i810/xf86-video-i810-2.2.1.ebuild,v 1.2 2008/03/15 02:16:33 dberkholz Exp $
# Must be before x-modular eclass is inherited
# Enable snapshot to get the man page in the right place
# This should be fixed with a XDP patch later
-#SNAPSHOT="yes"
+SNAPSHOT="yes"
XDPVER=-1
inherit x-modular
@@ -33,6 +33,7 @@ DEPEND="${RDEPEND}
>=x11-libs/libdrm-2.2
x11-libs/libX11 )"
+PATCHES="${FILESDIR}/0001-fixup-pciaccess-version-detect.patch"
CONFIGURE_OPTIONS="$(use_enable dri)"
pkg_setup() {