summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-09-24 05:25:05 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-09-24 05:25:05 +0000
commitb84441fe37beaed82fa168a053a35476b3d5bfdb (patch)
tree20cd1258f0d09f65b6d2eed15069a25d8302b3ae /x11-drivers/xf86-video-ati
parentTested and working on MIPS. Keyworded ~mips. (diff)
downloadgentoo-2-b84441fe37beaed82fa168a053a35476b3d5bfdb.tar.gz
gentoo-2-b84441fe37beaed82fa168a053a35476b3d5bfdb.tar.bz2
gentoo-2-b84441fe37beaed82fa168a053a35476b3d5bfdb.zip
Adds support for Mac Mini 'MacModel' option; fixes Xv crash bug; lots of fixes for LVDS panels (generally laptops); external TMDS (generally dual DVI) should work again.
(Portage version: 2.1.3.9)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.1946
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.7.194.ebuild35
3 files changed, 50 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 2ea98acd6946..c3d5f8fd257d 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.52 2007/09/21 01:15:43 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.53 2007/09/24 05:25:04 dberkholz Exp $
+
+*xf86-video-ati-6.7.194 (24 Sep 2007)
+
+ 24 Sep 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.7.194.ebuild:
+ Adds support for Mac Mini 'MacModel' option; fixes Xv crash bug; lots of
+ fixes for LVDS panels (generally laptops); external TMDS (generally dual
+ DVI) should work again.
*xf86-video-ati-6.7.193 (21 Sep 2007)
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.194 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.194
new file mode 100644
index 000000000000..6a030c4051a5
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.194
@@ -0,0 +1,6 @@
+MD5 56566e8c3fb4bb99791d1788d0a9a1a8 x11-driver-patches-4.tar.bz2 346
+RMD160 fcbd405de080d07612d46f455b927035fd8123a8 x11-driver-patches-4.tar.bz2 346
+SHA256 07069bbd072f2def50e83801a8f2a41a4c96495104f15cd6f56f7df7f89769bf x11-driver-patches-4.tar.bz2 346
+MD5 bac7c8da4d80503aeb53085e643e2dab xf86-video-ati-6.7.194.tar.bz2 732773
+RMD160 4e76a9c9df827c496567d202df235046d9fafe03 xf86-video-ati-6.7.194.tar.bz2 732773
+SHA256 540572177d1a1d9f9896972bd4ffbbd59efd9782964e957bf2d6cd6f306e91ce xf86-video-ati-6.7.194.tar.bz2 732773
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.194.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.194.ebuild
new file mode 100644
index 000000000000..f0784c320378
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.194.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.194.ebuild,v 1.1 2007/09/24 05:25:04 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}