summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-11-03 00:00:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-11-03 00:00:12 +0000
commitfaef91da8b0901eb93faa759ce07bb8b680fd21d (patch)
tree706f651e6f1cbbb731de0f4ae3c8ca07b38011ed /x11-drivers/synaptics
parents:sys-apps/sandbox:>=sys-apps/sandbox-1.2.17:g for bug #153788 (diff)
downloadgentoo-2-faef91da8b0901eb93faa759ce07bb8b680fd21d.tar.gz
gentoo-2-faef91da8b0901eb93faa759ce07bb8b680fd21d.tar.bz2
gentoo-2-faef91da8b0901eb93faa759ce07bb8b680fd21d.zip
version bump, which renders the prior patches unnecessary, sinceupstream fixed the compile issues with xorg-7.1. Also, the manpage installation location is actually finally fixed (closing bug #14112 by KIMURA Masaru / hiyuh). Closes bug #144308 where Pietro Franchi provided the new version
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'x11-drivers/synaptics')
-rw-r--r--x11-drivers/synaptics/ChangeLog11
-rw-r--r--x11-drivers/synaptics/files/digest-synaptics-0.14.63
-rw-r--r--x11-drivers/synaptics/synaptics-0.14.6.ebuild54
3 files changed, 67 insertions, 1 deletions
diff --git a/x11-drivers/synaptics/ChangeLog b/x11-drivers/synaptics/ChangeLog
index 31aa53aa77f7..5fb26456181d 100644
--- a/x11-drivers/synaptics/ChangeLog
+++ b/x11-drivers/synaptics/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-drivers/synaptics
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/ChangeLog,v 1.18 2006/11/02 23:40:05 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/ChangeLog,v 1.19 2006/11/03 00:00:12 seemant Exp $
+
+*synaptics-0.14.6 (02 Nov 2006)
+
+ 02 Nov 2006; Seemant Kulleen <seemant@gentoo.org>
+ +synaptics-0.14.6.ebuild:
+ version bump, which renders the prior patches unnecessary, sinceupstream
+ fixed the compile issues with xorg-7.1. Also, the manpage installation
+ location is actually finally fixed (closing bug #14112 by KIMURA Masaru /
+ hiyuh). Closes bug #144308 where Pietro Franchi provided the new version
02 Nov 2006; Seemant Kulleen <seemant@gentoo.org>
-synaptics-0.14.2.ebuild, -synaptics-0.14.3.ebuild,
diff --git a/x11-drivers/synaptics/files/digest-synaptics-0.14.6 b/x11-drivers/synaptics/files/digest-synaptics-0.14.6
new file mode 100644
index 000000000000..5d3ea56e43f5
--- /dev/null
+++ b/x11-drivers/synaptics/files/digest-synaptics-0.14.6
@@ -0,0 +1,3 @@
+MD5 1102cd575045640a064ab6f9b1e391af synaptics-0.14.6.tar.bz2 126833
+RMD160 7a8b103aa314eb13dc512c663c501108cc24a574 synaptics-0.14.6.tar.bz2 126833
+SHA256 f88b967258a0484b0aa02f26acfb31a70cc8afd4872608b7f81c44dc29ae8429 synaptics-0.14.6.tar.bz2 126833
diff --git a/x11-drivers/synaptics/synaptics-0.14.6.ebuild b/x11-drivers/synaptics/synaptics-0.14.6.ebuild
new file mode 100644
index 000000000000..9b6f2b47fb8d
--- /dev/null
+++ b/x11-drivers/synaptics/synaptics-0.14.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/synaptics-0.14.6.ebuild,v 1.1 2006/11/03 00:00:12 seemant Exp $
+
+inherit toolchain-funcs eutils
+
+IUSE="dlloader"
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://w1.894.telia.com/~u89404340/touchpad/"
+SRC_URI="http://w1.894.telia.com/~u89404340/touchpad/files/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="|| ( x11-libs/libXext virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-base/xorg-server virtual/x11 )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ # Switch up the CC and CFLAGS stuff.
+ sed -i \
+ -e "s:CC = gcc:CC = $(tc-getCC):g" \
+ -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" \
+ ${S}/Makefile
+}
+
+src_compile() {
+# if use dlloader
+# then
+# PICFLAG="-fPic"
+# fi
+
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ dodoc script/usbmouse script/usbhid alps.patch trouble-shooting.txt
+ dodoc COMPATIBILITY FILES INSTALL* LICENSE NEWS TODO README*
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd ${FILESDIR}/rc.init syndaemon
+ newconfd ${FILESDIR}/rc.conf syndaemon
+}