summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2008-04-01 23:57:32 +0000
committerBryan Stine <battousai@gentoo.org>2008-04-01 23:57:32 +0000
commit90620b501861e3411fddacfbe98cb8206a4926cc (patch)
tree788beda27f485c1119b006888d4266cb4e7a97d5 /x11-drivers/synaptics
parentfixed compile of 6.8 with USE=-jpeg as per bug #201710 thanks to Florian Phil... (diff)
downloadgentoo-2-90620b501861e3411fddacfbe98cb8206a4926cc.tar.gz
gentoo-2-90620b501861e3411fddacfbe98cb8206a4926cc.tar.bz2
gentoo-2-90620b501861e3411fddacfbe98cb8206a4926cc.zip
Ebuild r-bump with features to fix bugs #134309, #206614, #215323.
(Portage version: 2.1.4.4)
Diffstat (limited to 'x11-drivers/synaptics')
-rw-r--r--x11-drivers/synaptics/ChangeLog18
-rw-r--r--x11-drivers/synaptics/files/synaptics-fix-xinerama.patch16
-rw-r--r--x11-drivers/synaptics/files/synaptics-install-so-exec.patch11
-rw-r--r--x11-drivers/synaptics/synaptics-0.14.6-r2.ebuild89
4 files changed, 133 insertions, 1 deletions
diff --git a/x11-drivers/synaptics/ChangeLog b/x11-drivers/synaptics/ChangeLog
index 90383a37da8a..343966ffe1e8 100644
--- a/x11-drivers/synaptics/ChangeLog
+++ b/x11-drivers/synaptics/ChangeLog
@@ -1,6 +1,22 @@
# ChangeLog for x11-drivers/synaptics
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/ChangeLog,v 1.32 2008/02/24 02:45:10 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/ChangeLog,v 1.33 2008/04/01 23:57:31 battousai Exp $
+
+*synaptics-0.14.6-r2 (01 Apr 2008)
+
+ 01 Apr 2008; Bryan Stine <battousai@gentoo.org>
+ +files/synaptics-fix-xinerama.patch,
+ +files/synaptics-install-so-exec.patch, +synaptics-0.14.6-r2.ebuild:
+ Ebuild revision bump with a few new features. First, added a patch to
+ driver code to allow the touchpad to interact correctly with multiple
+ screens using Xinerama, fixing bug #206614. Second, added a patch to the
+ Makefile to install the Xorg module as executable to allow the Xorg loader
+ to bring it in automatically, fixing bug #215323. Finally, added
+ linux-info logic to the ebuild to check the kernel config for
+ CONFIG_INPUT_EVDEV (either as a module or built-in) as the driver requires
+ that interface for full support; fixes bug #134309. Revision-bumped the
+ ebuild to ensure the Xinerama and executable patches get pulled onto
+ users' systems.
24 Feb 2008; Donnie Berkholz <dberkholz@gentoo.org>; ChangeLog:
Update my email.
diff --git a/x11-drivers/synaptics/files/synaptics-fix-xinerama.patch b/x11-drivers/synaptics/files/synaptics-fix-xinerama.patch
new file mode 100644
index 000000000000..7d97af690b59
--- /dev/null
+++ b/x11-drivers/synaptics/files/synaptics-fix-xinerama.patch
@@ -0,0 +1,16 @@
+--- synaptics-0.14.6.orig/synaptics.c 2008-01-18 23:32:59.000000000 -0500
++++ synaptics-0.14.6/synaptics.c 2008-01-18 23:32:15.000000000 -0500
+@@ -617,10 +617,10 @@
+ miPointerGetMotionBufferSize());
+
+ /* X valuator */
+- xf86InitValuatorAxisStruct(dev, 0, 0, -1, 1, 0, 1);
++ xf86InitValuatorAxisStruct(dev, 0, -1, -1, 1, 0, 1);
+ xf86InitValuatorDefaults(dev, 0);
+ /* Y valuator */
+- xf86InitValuatorAxisStruct(dev, 1, 0, -1, 1, 0, 1);
++ xf86InitValuatorAxisStruct(dev, 1, -1, -1, 1, 0, 1);
+ xf86InitValuatorDefaults(dev, 1);
+
+ xf86MotionHistoryAllocate(local);
+
diff --git a/x11-drivers/synaptics/files/synaptics-install-so-exec.patch b/x11-drivers/synaptics/files/synaptics-install-so-exec.patch
new file mode 100644
index 000000000000..c71f4d5198a6
--- /dev/null
+++ b/x11-drivers/synaptics/files/synaptics-install-so-exec.patch
@@ -0,0 +1,11 @@
+--- synaptics-0.14.6/Makefile.orig 2008-04-01 16:10:04.000000000 -0400
++++ synaptics-0.14.6/Makefile 2008-04-01 16:10:23.000000000 -0400
+@@ -115,7 +115,7 @@
+ install -D $< $@
+
+ $(INPUT_MODULE_DIR)/$(SYNAPTICS_DRV) : $(SYNAPTICS_DRV)
+- install --mode=0644 -D $< $@
++ install --mode=0755 -D $< $@
+
+ $(SYNAPTICS_DRV): $(OBJS)
+ $(RM) $@
diff --git a/x11-drivers/synaptics/synaptics-0.14.6-r2.ebuild b/x11-drivers/synaptics/synaptics-0.14.6-r2.ebuild
new file mode 100644
index 000000000000..318860ca3587
--- /dev/null
+++ b/x11-drivers/synaptics/synaptics-0.14.6-r2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/synaptics-0.14.6-r2.ebuild,v 1.1 2008/04/01 23:57:31 battousai Exp $
+
+inherit toolchain-funcs eutils linux-info
+
+IUSE=""
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://w1.894.telia.com/~u89404340/touchpad/"
+SRC_URI="http://w1.894.telia.com/~u89404340/touchpad/files/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-server
+ >=sys-apps/sed-4"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "Synaptics driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_unpack() {
+ unpack ${A} ; cd "${S}"
+
+ # Switch up the CC and CFLAGS stuff.
+ sed -i \
+ -e "s:CC = gcc:CC = $(tc-getCC):g" \
+ -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" \
+ "${S}"/Makefile
+
+ # Fix grabbing of event devices so it will not stop working together with
+ # packages which grab their devices at their own like sys-apps/inputd does.
+ epatch "${FILESDIR}"/synaptics-fixeventgrab.diff
+
+ epatch "${FILESDIR}"/synaptics_input_api.diff
+
+ # Patch the Makefile to install the library as executable. Bug #215323.
+ epatch "${FILESDIR}"/synaptics-install-so-exec.patch
+
+ # Fix to handle multiple screens through Xinerama properly. Bug #206614.
+ epatch "${FILESDIR}"/synaptics-fix-xinerama.patch
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ MANDIR="${D}"/usr/share/man \
+ install || die
+
+ dodoc script/usbmouse script/usbhid alps.patch trouble-shooting.txt
+ dodoc COMPATIBILITY FILES INSTALL* NEWS TODO README*
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd "${FILESDIR}"/rc.init syndaemon
+ newconfd "${FILESDIR}"/rc.conf syndaemon
+}