summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2009-09-30 07:37:38 +0000
committerZac Medico <zmedico@gentoo.org>2009-09-30 07:37:38 +0000
commita3b0cc13c2715f592086825bcfaf3db5842374e9 (patch)
tree90051cff227d54b344db8164211b9f7237f93404 /x11-drivers/psb-kmod
parentNo git-svn by default. (diff)
downloadgentoo-2-a3b0cc13c2715f592086825bcfaf3db5842374e9.tar.gz
gentoo-2-a3b0cc13c2715f592086825bcfaf3db5842374e9.tar.bz2
gentoo-2-a3b0cc13c2715f592086825bcfaf3db5842374e9.zip
Bug #286753 - Version bump for compatibility with linux 2.6.31.
(Portage version: 2.2_rc42_p14468/cvs/Linux i686)
Diffstat (limited to 'x11-drivers/psb-kmod')
-rw-r--r--x11-drivers/psb-kmod/ChangeLog7
-rw-r--r--x11-drivers/psb-kmod/psb-kmod-4.41.1_p10.ebuild68
2 files changed, 74 insertions, 1 deletions
diff --git a/x11-drivers/psb-kmod/ChangeLog b/x11-drivers/psb-kmod/ChangeLog
index 0a58ede713b9..737e822f3e48 100644
--- a/x11-drivers/psb-kmod/ChangeLog
+++ b/x11-drivers/psb-kmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/psb-kmod
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/psb-kmod/ChangeLog,v 1.1 2009/09/13 20:10:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/psb-kmod/ChangeLog,v 1.2 2009/09/30 07:37:38 zmedico Exp $
+
+*psb-kmod-4.41.1_p10 (30 Sep 2009)
+
+ 30 Sep 2009; Zac Medico <zmedico@gentoo.org> +psb-kmod-4.41.1_p10.ebuild:
+ Bug #286753 - Version bump for compatibility with linux 2.6.31.
*psb-kmod-4.41.1_p8 (13 Sep 2009)
diff --git a/x11-drivers/psb-kmod/psb-kmod-4.41.1_p10.ebuild b/x11-drivers/psb-kmod/psb-kmod-4.41.1_p10.ebuild
new file mode 100644
index 000000000000..73a8a201d4ba
--- /dev/null
+++ b/x11-drivers/psb-kmod/psb-kmod-4.41.1_p10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/psb-kmod/psb-kmod-4.41.1_p10.ebuild,v 1.1 2009/09/30 07:37:38 zmedico Exp $
+
+EAPI="2"
+
+inherit rpm linux-info linux-mod
+
+DESCRIPTION="kernel module for the intel gma500 (poulsbo)"
+HOMEPAGE="http://www.happyassassin.net/2009/09/26/gma-500-poulsbo-driver-for-fedora-11-soon-to-be-in-rpm-fusion/"
+SRC_URI="http://download1.rpmfusion.org/nonfree/fedora/updates/testing/11/SRPMS/psb-kmod-4.41.1-10.fc11.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="x11-drivers/psb-firmware"
+RDEPEND=""
+
+S=${WORKDIR}/psb-kernel-source-4.41.1
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ local CONFIG_CHECK="FB_CFB_FILLRECT FB_CFB_COPYAREA FB_CFB_IMAGEBLIT ~FRAMEBUFFER_CONSOLE !DRM"
+ local ERROR_FB_CFB_FILLRECT="You don't have CONFIG_FB_CFB_FILLRECT enabled in you kernel config. To do this either hack drivers/video/Kconfig or enable an FB driver that pulls it in (for example VESAFB)"
+ local ERROR_FB_CFB_COPYAREA="You don't have CONFIG_FB_CFB_FILLRECT enabled in you kernel config. To do this either hack drivers/video/Kconfig or enable an FB driver that pulls it in (for example VESAFB)"
+ local ERROR_FB_CFB_IMAGEBLIT="You don't have CONFIG_FB_CFB_IMAGEBLIT enabled in you kernel config. To do this either hack drivers/video/Kconfig or enable an FB driver that pulls it in (for example VESAFB)"
+ local WARNING_FBCON="You should really have CONFIG_FRAMEBUFFER_CONSOLE set in your kernel config. Otherwise you will get a seriously messed up console. You can work around this by loading the psb module with no_fb=1"
+
+ check_extra_config
+
+ linux_chkconfig_builtin "FRAMEBUFFER_CONSOLE" || ewarn "You really should not have CONFIG_FRAMEBUFFER_CONSOLE as a module. Otherwise you will get a seriously messed up console. You can work around this by loading the psb module with no_fb=1"
+}
+
+src_prepare()
+{
+ if kernel_is ge 2 6 29 ; then
+ epatch "${WORKDIR}/psb-kmd-4.34-current_euid.patch"
+ epatch "${WORKDIR}/psb-kernel-source-4.41.1-i2c-intelfb.patch"
+ fi
+ if kernel_is ge 2 6 30 ; then
+ epatch "${WORKDIR}/${PN}-4.41.1_irqreturn.patch"
+ epatch "${WORKDIR}/${PN}-4.41.1_busid.patch"
+ fi
+ if kernel_is ge 2 6 31 ; then
+ epatch "${WORKDIR}/psb-kernel-source-4.41.1-agp_memory.patch"
+ fi
+ epatch "${WORKDIR}/psb-kernel-source-4.41.1-drmpsb.patch"
+}
+
+src_compile()
+{
+ # dirty hack :(
+ LINUXDIR=/usr/src/linux emake DRM_MODULES=psb || die
+}
+
+src_install()
+{
+ MODULE_NAMES="drm-psb(kernel/drivers/gpu/drm:${S}:${S}) psb(kernel/drivers/gpu/drm:${S}:${S})"
+ MODULESD_PSB_ALIASES=(
+ "pci:v00008086d00008108sv*sd*bc*sc*i* psb"
+ "pci:v00008086d00008109sv*sd*bc*sc*i* psb"
+ )
+
+ linux-mod_src_install
+}