summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2008-02-12 22:29:19 +0000
committerMike Auty <ikelos@gentoo.org>2008-02-12 22:29:19 +0000
commit6420e03b2fe3aa1cb6f2f5a3da280de9df45377e (patch)
tree712f74a0d471134c7861cd70bab2e2cbcd21fb9b /x11-drivers/linuxwacom/files
parentAdd a local USE flag for module building in linuxwacom. (diff)
downloadgentoo-2-6420e03b2fe3aa1cb6f2f5a3da280de9df45377e.tar.gz
gentoo-2-6420e03b2fe3aa1cb6f2f5a3da280de9df45377e.tar.bz2
gentoo-2-6420e03b2fe3aa1cb6f2f5a3da280de9df45377e.zip
Include masked linuxwacom for testing to work with 2.6.24.
(Portage version: 2.1.4.3)
Diffstat (limited to 'x11-drivers/linuxwacom/files')
-rw-r--r--x11-drivers/linuxwacom/files/linuxwacom-0.7.9-2.6.24.patch439
-rw-r--r--x11-drivers/linuxwacom/files/linuxwacom-0.7.9-no-tcl.patch19
2 files changed, 458 insertions, 0 deletions
diff --git a/x11-drivers/linuxwacom/files/linuxwacom-0.7.9-2.6.24.patch b/x11-drivers/linuxwacom/files/linuxwacom-0.7.9-2.6.24.patch
new file mode 100644
index 000000000000..001f6c43b717
--- /dev/null
+++ b/x11-drivers/linuxwacom/files/linuxwacom-0.7.9-2.6.24.patch
@@ -0,0 +1,439 @@
+From: Magnus Vigerlöf <Magnus.Vigerlof@ipbo.se>
+Date: Sat, 26 Jan 2008 21:40:43 +0000 (+0100)
+Subject: Support for 2.6.24 linux kernel
+X-Git-Url: http://git.debian.org/?p=collab-maint%2Flinux-wacom.git;a=commitdiff_plain;h=840c30dbf4207c1d702b9e8dfbce56eb1406e483;hp=4276619580732a8a9d51386af612920bd7ba19bc
+
+Support for 2.6.24 linux kernel
+---
+
+diff --git a/configure.in b/configure.in
+index 51ea19e..c3edcd2 100644
+--- a/configure.in
++++ b/configure.in
+@@ -175,7 +175,8 @@ else
+ 16|17) WCM_KERNEL_VER="2.6.16";;
+ 18) WCM_KERNEL_VER="2.6.18";;
+ 19|20|21) WCM_KERNEL_VER="2.6.19";;
+- *) WCM_KERNEL_VER="2.6.22";;
++ 22|23) WCM_KERNEL_VER="2.6.22";;
++ *) WCM_KERNEL_VER="2.6.24";;
+ esac
+ else
+ AC_MSG_WARN([support for kernels older than 2.6.8 has been dropped after 0.7.4])
+@@ -858,6 +859,7 @@ AC_OUTPUT(Makefile
+ src/2.6.18/Makefile
+ src/2.6.19/Makefile
+ src/2.6.22/Makefile
++ src/2.6.24/Makefile
+ src/wacomxi/Makefile
+ src/wacomxi/wacomcpl)
+
+diff --git a/src/2.6.24/.gitignore b/src/2.6.24/.gitignore
+new file mode 100644
+index 0000000..a2409d1
+--- /dev/null
++++ b/src/2.6.24/.gitignore
+@@ -0,0 +1,4 @@
++# Lines starting with '#' are considered comments.
++# Ignore files that are copied from other directories
++/wacom_wac.[ch]
++/wacom.h
+diff --git a/src/2.6.24/Makefile.in b/src/2.6.24/Makefile.in
+new file mode 100644
+index 0000000..7dbd0c3
+--- /dev/null
++++ b/src/2.6.24/Makefile.in
+@@ -0,0 +1,45 @@
++############################ 2.6 kernel compile ###############################
++ifneq ($(KERNELRELEASE),)
++# We were called by kbuild
++# Do NOT indent stuff in this part! It has to be like this to make the
++# $(error ... ) stuff work
++
++ifeq ($(WCM_OPTION_WACOM),yes)
++ifneq ($(CONFIG_USB_WACOM),y)
++wacom-objs := wacom_wac.o wacom_sys.o
++obj-m += wacom.o
++else
++$(error You requested to build wacom with configure, but wacom is configured as built-in in your kernel config)
++endif # CONFIG_USB_WACOM
++endif # WCM_OPTION_WACOM
++
++else # We were called from command line
++PWD := $(shell pwd)
++
++WCM_KERNEL_DIR := @WCM_KERNEL_DIR@
++WCM_OPTION_WACOM := @WCM_OPTION_WACOM@
++
++export WCM_OPTION_WACOM
++
++all:
++# Copy Wacom specific code which is common to all kernel releases
++ifeq ($(WCM_OPTION_WACOM),yes)
++ cp -f ../2.6.19/wacom_wac.c .
++ cp -f ../2.6.19/wacom.h .
++ cp -f ../2.6.22/wacom_wac.h .
++endif
++ @echo ' Building linuxwacom drivers for 2.6 kernel.'
++ @echo '***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built'
++ $(MAKE) -C $(WCM_KERNEL_DIR) M=$(PWD)
++
++endif # End kbuild check
++
++######################### Version independent targets ##########################
++
++clean:
++ rm -rf *.o *.ko *.mod.* .[a-z]* core *.i
++
++EMPTY_AUTOMAKE_TARGETS = distdir install install-data install-exec uninstall install-info
++EMPTY_AUTOMAKE_TARGETS += installdirs check dvi pdf ps info html tags ctags mostlyclean distclean maintainer-clean
++.PHONY: $(EMPTY_AUTOMAKE_TARGETS)
++ $(EMPTY_AUTOMAKE_TARGETS):
+diff --git a/src/2.6.24/wacom_sys.c b/src/2.6.24/wacom_sys.c
+new file mode 100644
+index 0000000..41caaef
+--- /dev/null
++++ b/src/2.6.24/wacom_sys.c
+@@ -0,0 +1,342 @@
++/*
++ * drivers/input/tablet/wacom_sys.c
++ *
++ * USB Wacom Graphire and Wacom Intuos tablet support - system specific code
++ */
++
++/*
++ * This program is free software; you can redistribute it and/or modify
++ * it under the terms of the GNU General Public License as published by
++ * the Free Software Foundation; either version 2 of the License, or
++ * (at your option) any later version.
++ */
++
++#include "wacom.h"
++#include "wacom_wac.h"
++
++#define USB_REQ_GET_REPORT 0x01
++#define USB_REQ_SET_REPORT 0x09
++
++static int usb_get_report(struct usb_interface *intf, unsigned char type,
++ unsigned char id, void *buf, int size)
++{
++ return usb_control_msg(interface_to_usbdev(intf),
++ usb_rcvctrlpipe(interface_to_usbdev(intf), 0),
++ USB_REQ_GET_REPORT, USB_TYPE_CLASS | USB_RECIP_INTERFACE,
++ (type << 8) + id, intf->altsetting[0].desc.bInterfaceNumber,
++ buf, size, 100);
++}
++
++static int usb_set_report(struct usb_interface *intf, unsigned char type,
++ unsigned char id, void *buf, int size)
++{
++ return usb_control_msg(interface_to_usbdev(intf),
++ usb_sndctrlpipe(interface_to_usbdev(intf), 0),
++ USB_REQ_SET_REPORT, USB_TYPE_CLASS | USB_RECIP_INTERFACE,
++ (type << 8) + id, intf->altsetting[0].desc.bInterfaceNumber,
++ buf, size, 1000);
++}
++
++static struct input_dev * get_input_dev(struct wacom_combo *wcombo)
++{
++ return wcombo->wacom->dev;
++}
++
++static void wacom_sys_irq(struct urb *urb)
++{
++ struct wacom *wacom = urb->context;
++ struct wacom_combo wcombo;
++ int retval;
++
++ switch (urb->status) {
++ case 0:
++ /* success */
++ break;
++ case -ECONNRESET:
++ case -ENOENT:
++ case -ESHUTDOWN:
++ /* this urb is terminated, clean up */
++ dbg("%s - urb shutting down with status: %d", __FUNCTION__, urb->status);
++ return;
++ default:
++ dbg("%s - nonzero urb status received: %d", __FUNCTION__, urb->status);
++ goto exit;
++ }
++
++ wcombo.wacom = wacom;
++ wcombo.urb = urb;
++
++ if (wacom_wac_irq(wacom->wacom_wac, (void *)&wcombo))
++ input_sync(get_input_dev(&wcombo));
++
++ exit:
++ retval = usb_submit_urb (urb, GFP_ATOMIC);
++ if (retval)
++ err ("%s - usb_submit_urb failed with result %d",
++ __FUNCTION__, retval);
++}
++
++void wacom_report_key(void *wcombo, unsigned int key_type, int key_data)
++{
++ input_report_key(get_input_dev((struct wacom_combo *)wcombo), key_type, key_data);
++ return;
++}
++
++void wacom_report_abs(void *wcombo, unsigned int abs_type, int abs_data)
++{
++ input_report_abs(get_input_dev((struct wacom_combo *)wcombo), abs_type, abs_data);
++ return;
++}
++
++void wacom_report_rel(void *wcombo, unsigned int rel_type, int rel_data)
++{
++ input_report_rel(get_input_dev((struct wacom_combo *)wcombo), rel_type, rel_data);
++ return;
++}
++
++void wacom_input_event(void *wcombo, unsigned int type, unsigned int code, int value)
++{
++ input_event(get_input_dev((struct wacom_combo *)wcombo), type, code, value);
++ return;
++}
++
++__u16 wacom_be16_to_cpu(unsigned char *data)
++{
++ __u16 value;
++ value = be16_to_cpu(*(__be16 *) data);
++ return value;
++}
++
++__u16 wacom_le16_to_cpu(unsigned char *data)
++{
++ __u16 value;
++ value = le16_to_cpu(*(__le16 *) data);
++ return value;
++}
++
++void wacom_input_sync(void *wcombo)
++{
++ input_sync(get_input_dev((struct wacom_combo *)wcombo));
++ return;
++}
++
++static int wacom_open(struct input_dev *dev)
++{
++ struct wacom *wacom = input_get_drvdata(dev);
++
++ wacom->irq->dev = wacom->usbdev;
++ if (usb_submit_urb(wacom->irq, GFP_KERNEL))
++ return -EIO;
++
++ return 0;
++}
++
++static void wacom_close(struct input_dev *dev)
++{
++ struct wacom *wacom = input_get_drvdata(dev);
++
++ usb_kill_urb(wacom->irq);
++}
++
++void input_dev_mo(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_1) |
++ BIT_MASK(BTN_5);
++ input_set_abs_params(input_dev, ABS_WHEEL, 0, 71, 0, 0);
++}
++
++void input_dev_g4(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->evbit[0] |= BIT_MASK(EV_MSC);
++ input_dev->mscbit[0] |= BIT_MASK(MSC_SERIAL);
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_TOOL_FINGER);
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_0) |
++ BIT_MASK(BTN_4);
++}
++
++void input_dev_g(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->evbit[0] |= BIT_MASK(EV_REL);
++ input_dev->relbit[0] |= BIT_MASK(REL_WHEEL);
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_LEFT) |
++ BIT_MASK(BTN_RIGHT) | BIT_MASK(BTN_MIDDLE);
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_TOOL_RUBBER) |
++ BIT_MASK(BTN_TOOL_MOUSE) | BIT_MASK(BTN_STYLUS2);
++ input_set_abs_params(input_dev, ABS_DISTANCE, 0, wacom_wac->features->distance_max, 0, 0);
++}
++
++void input_dev_i3s(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_TOOL_FINGER);
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_0) |
++ BIT_MASK(BTN_1) | BIT_MASK(BTN_2) | BIT_MASK(BTN_3);
++ input_set_abs_params(input_dev, ABS_RX, 0, 4096, 0, 0);
++ input_set_abs_params(input_dev, ABS_Z, -900, 899, 0, 0);
++}
++
++void input_dev_i3(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_4) |
++ BIT_MASK(BTN_5) | BIT_MASK(BTN_6) | BIT_MASK(BTN_7);
++ input_set_abs_params(input_dev, ABS_RY, 0, 4096, 0, 0);
++}
++
++void input_dev_bee(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_8) | BIT_MASK(BTN_9);
++}
++
++void input_dev_i(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->evbit[0] |= BIT_MASK(EV_MSC) | BIT_MASK(EV_REL);
++ input_dev->mscbit[0] |= BIT_MASK(MSC_SERIAL);
++ input_dev->relbit[0] |= BIT_MASK(REL_WHEEL);
++ input_dev->keybit[BIT_WORD(BTN_LEFT)] |= BIT_MASK(BTN_LEFT) |
++ BIT_MASK(BTN_RIGHT) | BIT_MASK(BTN_MIDDLE) |
++ BIT_MASK(BTN_SIDE) | BIT_MASK(BTN_EXTRA);
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_TOOL_RUBBER) |
++ BIT_MASK(BTN_TOOL_MOUSE) | BIT_MASK(BTN_TOOL_BRUSH) |
++ BIT_MASK(BTN_TOOL_PENCIL) | BIT_MASK(BTN_TOOL_AIRBRUSH) |
++ BIT_MASK(BTN_TOOL_LENS) | BIT_MASK(BTN_STYLUS2);
++ input_set_abs_params(input_dev, ABS_DISTANCE, 0, wacom_wac->features->distance_max, 0, 0);
++ input_set_abs_params(input_dev, ABS_WHEEL, 0, 1023, 0, 0);
++ input_set_abs_params(input_dev, ABS_TILT_X, 0, 127, 0, 0);
++ input_set_abs_params(input_dev, ABS_TILT_Y, 0, 127, 0, 0);
++ input_set_abs_params(input_dev, ABS_RZ, -900, 899, 0, 0);
++ input_set_abs_params(input_dev, ABS_THROTTLE, -1023, 1023, 0, 0);
++}
++
++void input_dev_pl(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_STYLUS2) |
++ BIT_MASK(BTN_TOOL_RUBBER);
++}
++
++void input_dev_pt(struct input_dev *input_dev, struct wacom_wac *wacom_wac)
++{
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_TOOL_RUBBER);
++}
++
++static int wacom_probe(struct usb_interface *intf, const struct usb_device_id *id)
++{
++ struct usb_device *dev = interface_to_usbdev(intf);
++ struct usb_endpoint_descriptor *endpoint;
++ struct wacom *wacom;
++ struct wacom_wac *wacom_wac;
++ struct input_dev *input_dev;
++ int error = -ENOMEM;
++ char rep_data[2], limit = 0;
++
++ wacom = kzalloc(sizeof(struct wacom), GFP_KERNEL);
++ wacom_wac = kzalloc(sizeof(struct wacom_wac), GFP_KERNEL);
++ input_dev = input_allocate_device();
++ if (!wacom || !input_dev || !wacom_wac)
++ goto fail1;
++
++ wacom_wac->data = usb_buffer_alloc(dev, 10, GFP_KERNEL, &wacom->data_dma);
++ if (!wacom_wac->data)
++ goto fail1;
++
++ wacom->irq = usb_alloc_urb(0, GFP_KERNEL);
++ if (!wacom->irq)
++ goto fail2;
++
++ wacom->usbdev = dev;
++ wacom->dev = input_dev;
++ usb_make_path(dev, wacom->phys, sizeof(wacom->phys));
++ strlcat(wacom->phys, "/input0", sizeof(wacom->phys));
++
++ wacom_wac->features = get_wacom_feature(id);
++ BUG_ON(wacom_wac->features->pktlen > 10);
++
++ input_dev->name = wacom_wac->features->name;
++ wacom->wacom_wac = wacom_wac;
++ usb_to_input_id(dev, &input_dev->id);
++
++ input_dev->dev.parent = &intf->dev;
++
++ input_set_drvdata(input_dev, wacom);
++
++ input_dev->open = wacom_open;
++ input_dev->close = wacom_close;
++
++ input_dev->evbit[0] |= BIT_MASK(EV_KEY) | BIT_MASK(EV_ABS);
++ input_dev->keybit[BIT_WORD(BTN_DIGI)] |= BIT_MASK(BTN_TOOL_PEN) |
++ BIT_MASK(BTN_TOUCH) | BIT_MASK(BTN_STYLUS);
++ input_set_abs_params(input_dev, ABS_X, 0, wacom_wac->features->x_max, 4, 0);
++ input_set_abs_params(input_dev, ABS_Y, 0, wacom_wac->features->y_max, 4, 0);
++ input_set_abs_params(input_dev, ABS_PRESSURE, 0, wacom_wac->features->pressure_max, 0, 0);
++ input_dev->absbit[BIT_WORD(ABS_MISC)] |= BIT_MASK(ABS_MISC);
++
++ wacom_init_input_dev(input_dev, wacom_wac);
++
++ endpoint = &intf->cur_altsetting->endpoint[0].desc;
++
++ usb_fill_int_urb(wacom->irq, dev,
++ usb_rcvintpipe(dev, endpoint->bEndpointAddress),
++ wacom_wac->data, wacom_wac->features->pktlen,
++ wacom_sys_irq, wacom, endpoint->bInterval);
++ wacom->irq->transfer_dma = wacom->data_dma;
++ wacom->irq->transfer_flags |= URB_NO_TRANSFER_DMA_MAP;
++
++ error = input_register_device(wacom->dev);
++ if (error)
++ goto fail3;
++
++ /* Ask the tablet to report tablet data. Repeat until it succeeds */
++ do {
++ rep_data[0] = 2;
++ rep_data[1] = 2;
++ usb_set_report(intf, 3, 2, rep_data, 2);
++ usb_get_report(intf, 3, 2, rep_data, 2);
++ } while (rep_data[1] != 2 && limit++ < 5);
++
++ usb_set_intfdata(intf, wacom);
++ return 0;
++
++ fail3: usb_free_urb(wacom->irq);
++ fail2: usb_buffer_free(dev, 10, wacom_wac->data, wacom->data_dma);
++ fail1: input_free_device(input_dev);
++ kfree(wacom);
++ kfree(wacom_wac);
++ return error;
++}
++
++static void wacom_disconnect(struct usb_interface *intf)
++{
++ struct wacom *wacom = usb_get_intfdata (intf);
++
++ usb_set_intfdata(intf, NULL);
++ if (wacom) {
++ usb_kill_urb(wacom->irq);
++ input_unregister_device(wacom->dev);
++ usb_free_urb(wacom->irq);
++ usb_buffer_free(interface_to_usbdev(intf), 10, wacom->wacom_wac->data, wacom->data_dma);
++ kfree(wacom->wacom_wac);
++ kfree(wacom);
++ }
++}
++
++static struct usb_driver wacom_driver = {
++ .name = "wacom",
++ .probe = wacom_probe,
++ .disconnect = wacom_disconnect,
++};
++
++static int __init wacom_init(void)
++{
++ int result;
++ wacom_driver.id_table = get_device_table();
++ result = usb_register(&wacom_driver);
++ if (result == 0)
++ info(DRIVER_VERSION ":" DRIVER_DESC);
++ return result;
++}
++
++static void __exit wacom_exit(void)
++{
++ usb_deregister(&wacom_driver);
++}
++
++module_init(wacom_init);
++module_exit(wacom_exit);
diff --git a/x11-drivers/linuxwacom/files/linuxwacom-0.7.9-no-tcl.patch b/x11-drivers/linuxwacom/files/linuxwacom-0.7.9-no-tcl.patch
new file mode 100644
index 000000000000..c338a8af5f64
--- /dev/null
+++ b/x11-drivers/linuxwacom/files/linuxwacom-0.7.9-no-tcl.patch
@@ -0,0 +1,19 @@
+X-Git-Url: http://git.debian.org/?p=collab-maint%2Flinux-wacom.git;a=blobdiff_plain;f=configure.in;fp=configure.in;h=51ea19e45bf614cfb754864b28419fd551941ad4;hp=1534c84559d045a9e026fa23391995f59c4bcef6;hb=4276619580732a8a9d51386af612920bd7ba19bc;hpb=ad6caef3a2c498ca993e1e36719748f0a54cac40
+
+diff --git a/configure.in b/configure.in
+index 1534c84..51ea19e 100644
+--- a/configure.in
++++ b/configure.in
+@@ -619,11 +619,10 @@ if test "$enable_libwacomxi" != no; then
+ WCM_TCLLIBS="libwacomxi.la"
+ WCM_TCLPKGS="pkgIndex.tcl"
+ fi
+- AM_CONDITIONAL(WACOMXI_INSTALL, true)
+ else
+ AC_MSG_RESULT(no)
+- AM_CONDITIONAL(WACOMXI_INSTALL, false)
+ fi
++AM_CONDITIONAL(WACOMXI_INSTALL, [test "$WCM_OPTION_LIBWACOMXI" = yes] )
+
+ dnl =======================================================
+ dnl Check for wacdump build