summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2005-12-24 00:43:04 +0000
committerBryan Stine <battousai@gentoo.org>2005-12-24 00:43:04 +0000
commit1f2e38c650d72f1173f1fba2ceafb9bce15b5bbd (patch)
tree33dfc23aff62e0aa72730c42c1cb62120559c494 /x11-base
parentstable amd64 (diff)
downloadgentoo-2-1f2e38c650d72f1173f1fba2ceafb9bce15b5bbd.tar.gz
gentoo-2-1f2e38c650d72f1173f1fba2ceafb9bce15b5bbd.tar.bz2
gentoo-2-1f2e38c650d72f1173f1fba2ceafb9bce15b5bbd.zip
Snapshot bump to 20051223. Happy holidays.
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/x11-drm/ChangeLog7
-rw-r--r--x11-base/x11-drm/files/digest-x11-drm-200512232
-rw-r--r--x11-base/x11-drm/x11-drm-20051223.ebuild232
3 files changed, 240 insertions, 1 deletions
diff --git a/x11-base/x11-drm/ChangeLog b/x11-base/x11-drm/ChangeLog
index 0e8f413c1c0a..b780ec5cab38 100644
--- a/x11-base/x11-drm/ChangeLog
+++ b/x11-base/x11-drm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/x11-drm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.23 2005/12/14 15:59:54 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.24 2005/12/24 00:43:04 battousai Exp $
+
+*x11-drm-20051223 (24 Dec 2005)
+
+ 24 Dec 2005; Bryan Stine <battousai@gentoo.org> +x11-drm-20051223.ebuild:
+ Snapshot bump to 20051223. Happy holidays.
14 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
x11-drm-20051028.ebuild:
diff --git a/x11-base/x11-drm/files/digest-x11-drm-20051223 b/x11-base/x11-drm/files/digest-x11-drm-20051223
new file mode 100644
index 000000000000..411ef258aee1
--- /dev/null
+++ b/x11-base/x11-drm/files/digest-x11-drm-20051223
@@ -0,0 +1,2 @@
+MD5 e3586c43652beda09e68558528929d9e linux-drm-20051223-kernelsource.tar.bz2 560381
+MD5 0831381f1bfccba6fc80e5c1551dafb8 x11-drm-20051223-gentoo-0.1.tar.bz2 2106
diff --git a/x11-base/x11-drm/x11-drm-20051223.ebuild b/x11-base/x11-drm/x11-drm-20051223.ebuild
new file mode 100644
index 000000000000..250ca2e04c06
--- /dev/null
+++ b/x11-base/x11-drm/x11-drm-20051223.ebuild
@@ -0,0 +1,232 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20051223.ebuild,v 1.1 2005/12/24 00:43:04 battousai Exp $
+
+inherit eutils x11 linux-mod
+
+IUSE=""
+IUSE_VIDEO_CARDS="3dfx ffb i810 i830 i915 mach64 matrox nv rage128 radeon savage sis via"
+
+# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
+# that only we only strip stuff that are safe to strip ...
+RESTRICT="nostrip"
+
+S="${WORKDIR}/drm"
+PATCHVER="0.1"
+PATCHDIR="${WORKDIR}/patch"
+EXCLUDED="${WORKDIR}/excluded"
+
+DESCRIPTION="DRM Kernel Modules for X11"
+HOMEPAGE="http://dri.sf.net"
+SRC_URI="mirror://gentoo/${P}-gentoo-${PATCHVER}.tar.bz2
+ mirror://gentoo/linux-drm-${PV}-kernelsource.tar.bz2"
+
+SLOT="0"
+LICENSE="X11"
+KEYWORDS="~x86 ~alpha ~ia64 ~ppc ~amd64"
+
+DEPEND=">=sys-devel/automake-1.7
+ >=sys-devel/autoconf-2.59
+ >=sys-devel/libtool-1.5.14
+ >=sys-devel/m4-1.4
+ virtual/linux-sources
+ >=sys-apps/portage-2.0.49-r13"
+
+pkg_setup() {
+ get_version
+
+ # Require at least one video card
+ if [ -z "${VIDEO_CARDS}" ]
+ then
+ die "Please set at least one video card in VIDEO_CARDS in make.conf or the environment. Possible VIDEO_CARDS values are: ${IUSE_VIDEO_CARDS}."
+ fi
+
+ if [ "${ARCH}" != "sparc" ] && use video_cards_ffb
+ then
+ die "The ffb driver is for sparc-specific hardware. Please remove it from your VIDEO_CARDS."
+ fi
+
+ if linux_chkconfig_builtin "DRM"
+ then
+ die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
+ fi
+
+ if ! linux_chkconfig_present "AGP"
+ then
+ einfo "AGP support is not enabled in your kernel config. This may be needed for DRM to"
+ einfo "work, so you might want to double-check that setting. (CONFIG_AGP)"
+ echo
+ fi
+
+ # Set video cards to build for.
+ set_vidcards
+
+ # DRM CVS is undergoing changes which require splitting source to support both 2.4
+ # and 2.6 kernels. This determines which to use.
+ get_drm_build_dir
+
+ return 0
+}
+
+src_unpack() {
+ unpack linux-drm-${PV}-kernelsource.tar.bz2
+ unpack ${P}-gentoo-${PATCHVER}.tar.bz2
+
+ cd ${S}
+
+ patch_prepare
+
+ # Apply patches
+ EPATCH_SUFFIX="patch" epatch ${PATCHDIR}
+
+ # Substitute new directory under /lib/modules/${KV_FULL}
+ cd ${SRC_BUILD}
+ sed -ie "s:/kernel/drivers/char/drm:/${PN}:g" Makefile
+
+ cp ${S}/tests/*.c ${SRC_BUILD}
+
+ cd ${S}
+ WANT_AUTOCONF="2.59" WANT_AUTOMAKE="1.7" autoreconf -v --install
+}
+
+src_compile() {
+ einfo "Building DRM in ${SRC_BUILD}..."
+ cd ${SRC_BUILD}
+
+ # This now uses an M= build system. Makefile does most of the work.
+ unset ARCH
+ make M="${SRC_BUILD}" \
+ LINUXDIR="${KERNEL_DIR}" \
+ DRM_MODULES="${VIDCARDS}" \
+ modules || die_error
+
+ # Building the programs. These are useful for developers and getting info from DRI and DRM.
+ #
+ # libdrm objects are needed for drmstat.
+ cd ${S}
+ econf || die "libdrm configure failed."
+ emake || die "libdrm build failed."
+
+ if linux_chkconfig_present DRM
+ then
+ echo "Please disable in-kernel DRM support to use this package."
+ fi
+
+ cd ${SRC_BUILD}
+ # LINUXDIR is needed to allow Makefiles to find kernel release.
+ make LINUXDIR="${KERNEL_DIR}" dristat || die "Building dristat failed."
+ make LINUXDIR="${KERNEL_DIR}" drmstat || die "Building drmstat failed."
+}
+
+src_install() {
+ einfo "Installing DRM..."
+ cd ${SRC_BUILD}
+
+ unset ARCH
+ make KV="${KV_FULL}" \
+ LINUXDIR="${KERNEL_DIR}" \
+ DESTDIR="${D}" \
+ RUNNING_REL="${KV_FULL}" \
+ MODULE_LIST="${VIDCARDS} drm.${KV_OBJ}" \
+ install || die "Install failed."
+
+ dodoc README.drm
+
+ dobin dristat
+ dobin drmstat
+
+ # Strip binaries, leaving /lib/modules untouched (bug #24415)
+ strip_bins \/lib\/modules
+
+ # Yoinked from the sys-apps/touchpad ebuild. Thanks to whoever made this.
+ keepdir /etc/modules.d
+ sed 's:%PN%:'${PN}':g' ${FILESDIR}/modules.d-${PN} > ${D}/etc/modules.d/${PN}
+ sed -i 's:%KV%:'${KV_FULL}':g' ${D}/etc/modules.d/${PN}
+}
+
+pkg_postinst() {
+ if use video_cards_sis
+ then
+ einfo "SiS direct rendering only works on 300 series chipsets."
+ einfo "SiS framebuffer also needs to be enabled in the kernel."
+ fi
+
+ if use video_cards_mach64
+ then
+ einfo "The Mach64 DRI driver is insecure."
+ einfo "Malicious clients can write to system memory."
+ einfo "For more information, see:"
+ einfo "http://dri.sourceforge.net/cgi-bin/moin.cgi/ATIMach64?value=CategoryHardwareChipset."
+ fi
+
+ einfo "Checking kernel module dependencies"
+ update_modules
+ update_depmod
+}
+
+# Functions used above are defined below:
+
+set_vidcards() {
+ set_kvobj
+
+ VIDCARDS=""
+
+ use video_cards_matrox && \
+ VIDCARDS="${VIDCARDS} mga.${KV_OBJ}"
+ use video_cards_3dfx && \
+ VIDCARDS="${VIDCARDS} tdfx.${KV_OBJ}"
+ use video_cards_rage128 && \
+ VIDCARDS="${VIDCARDS} r128.${KV_OBJ}"
+ use video_cards_radeon && \
+ VIDCARDS="${VIDCARDS} radeon.${KV_OBJ}"
+ use video_cards_i810 && \
+ VIDCARDS="${VIDCARDS} i810.${KV_OBJ}"
+ use video_cards_i830 && \
+ VIDCARDS="${VIDCARDS} i830.${KV_OBJ}"
+ use video_cards_i915 && \
+ VIDCARDS="${VIDCARDS} i915.${KV_OBJ}"
+# use video_cards_gamma && \
+# VIDCARDS="${VIDCARDS} gamma.${KV_OBJ}"
+ use video_cards_mach64 && \
+ VIDCARDS="${VIDCARDS} mach64.${KV_OBJ}"
+ use video_cards_nv && \
+ VIDCARDS="${VIDCARDS} nv.${KV_OBJ}"
+ use video_cards_savage && \
+ VIDCARDS="${VIDCARDS} savage.${KV_OBJ}"
+ use video_cards_sis && \
+ VIDCARDS="${VIDCARDS} sis.${KV_OBJ}"
+ use video_cards_via && \
+ VIDCARDS="${VIDCARDS} via.${KV_OBJ}"
+ use video_cards_ffb && \
+ VIDCARDS="${VIDCARDS} ffb.${KV_OBJ}"
+}
+
+patch_prepare() {
+ # Handle exclusions based on the following...
+ # All trees (0**), Standard only (1**), Others (none right now)
+ # 2.4 vs. 2.6 kernels
+
+ kernel_is 2 4 && mv -f ${PATCHDIR}/*kernel-2.6* ${EXCLUDED}
+ kernel_is 2 6 && mv -f ${PATCHDIR}/*kernel-2.4* ${EXCLUDED}
+
+ # There is only one tree being maintained now. No numeric exclusions need
+ # to be done based on DRM tree.
+}
+
+die_error() {
+ eerror "Portage could not build the DRM modules. If you see an ACCESS DENIED error,"
+ eerror "this could mean that you were using an unsupported kernel build system. All"
+ eerror "2.4 kernels are supported, but only 2.6 kernels at least as new as 2.6.6"
+ eerror "are supported."
+ die "Unable to build DRM modules."
+}
+
+get_drm_build_dir() {
+ if kernel_is 2 4
+ then
+ SRC_BUILD="${S}/linux"
+ elif kernel_is 2 6
+ then
+ SRC_BUILD="${S}/linux-core"
+ fi
+}