summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-12-19 08:32:54 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-12-19 08:32:54 +0000
commit0eae131ea1a3bd8d84becfc83730cad275016fbd (patch)
treedab72be0540ede90550967e490824365b2a553a9 /x11-base
parentppc stable as per bug #67326 (Manifest recommit) (diff)
downloadgentoo-2-0eae131ea1a3bd8d84becfc83730cad275016fbd.tar.gz
gentoo-2-0eae131ea1a3bd8d84becfc83730cad275016fbd.tar.bz2
gentoo-2-0eae131ea1a3bd8d84becfc83730cad275016fbd.zip
PATCH_VER 0.3.1. This should help out PPC users on Radeon and Rage128.
(fd.o #2064) Add 5160_all_6.8.1-benh-radeon-ppc-fixes.patch, with tons of changes: 1. This patch adds the "VGAAccess" option (defaults to NO on PPC and YES on others) that disables all legacy VGA stuffs in the driver, since they are causing various issues on non-x86 machines. 2. This patch makes sure CRTC2_OFFSET_CNTL is cleared. None of the options in this register should be enabled with our current driver, and some firmwares setup a tiled display, which we _must_ disable for now. Without this, the second screen is completely scrambled on some PowerMacs. 3. This patch fix the routine that probes for PLL values in absence of a BIOS ROM. The measure is more precise, done several times to avoid "gliches" caused by scheduling latencies, plus the patch fixes actual bugs in the previous iteration of the code. It also add calculation of the mclk and sclk values for proper display bandwidth calculation and adds proper min/max PLL values for r420 type cards. 4. The display bandwidth calculation code has a small bug when looking at the memory controller setup on r300 chips. Hui from ATI confirmed that this was the right fix. 5. When using MergedFB, the driver would call RADEONInitPLLRegisters for the first head even when UseBiosDividers was set to TRUE, which was incorrect. This patch fixes it by moving the test of UseBiosDividers into RADEONInitPLLRegisters which simplifies the code in the caller and is more logical. 6. The dual head setup was recently re-broken (after having been fixed a while ago) with SURFACE_CNTL beeing written with the wrong value from the second head. The problem is that usually, only the first head had a correct value in there, and the driver would regular mixup which register setup was used to restore that value. This patch fixes it once for all by making sure the second head does carry the proper value too. 7. The second digital output of the radeon chip doesn't like when the P2PLL is set with an odd post-divider value. This makes sure we never chose a "wrong" value when calculating the P2PLL setting on a non-CRT screen. 8. On some cards where no BIOS provided output mapping infos is available, the driver would get the DDC flipped between the two outputs of the card. This typically happen on recent Mac cards. This adds an option to force the driver to reverse what it thinks is the primary display DDC and the secondary display DDC. Ultimately, we'll have to do a better job of recognizing those Mac cards though. 9. RadeonValidateFPModes() has a bug where it could try to dereference a NULL pointer in some cases when linking in modes. This fixes it. 10. This patch adds an option for probing the PLL value at server init time for LVDS panels and re-using it later (by setting UseBiosDividers). It's useful on machines without an X86 BIOS image providing the proper set of divider values for the LVDS, as the value calculated by RADEONInitPLLRegisters() tend not to be suitable for some LVDS panels. It also changes a bit the way the panel infos are extracted, the previous code didn't quite work for me, and after discussing with Hui, I decided to move the detection earlier in the discovery process and to do it slightly differently. (fd.o #2089) Add 5135_all_6.8.1-r128-ppc-vgaaccess.patch. This patch adds the "VGAAccess" option (defaults to NO on PPC and YES on others) that disables all legacy VGA stuffs in the driver, since they are causing various issues on non-x86 machines. (Manifest recommit)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-x11/ChangeLog71
-rw-r--r--x11-base/xorg-x11/Manifest6
-rw-r--r--x11-base/xorg-x11/files/digest-xorg-x11-6.8.1.9012
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild4
4 files changed, 76 insertions, 7 deletions
diff --git a/x11-base/xorg-x11/ChangeLog b/x11-base/xorg-x11/ChangeLog
index 96ff15639309..4ec6138cbe6f 100644
--- a/x11-base/xorg-x11/ChangeLog
+++ b/x11-base/xorg-x11/ChangeLog
@@ -1,6 +1,75 @@
# ChangeLog for x11-base/xorg-x11
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.245 2004/12/19 02:21:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.246 2004/12/19 08:32:54 spyderous Exp $
+
+ 19 Dec 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ xorg-x11-6.8.1.901.ebuild:
+ PATCH_VER 0.3.1. This should help out PPC users on Radeon and Rage128.
+
+ (fd.o #2064) Add 5160_all_6.8.1-benh-radeon-ppc-fixes.patch, with tons of
+ changes:
+
+ 1. This patch adds the "VGAAccess" option (defaults to NO on PPC and YES on
+ others) that disables all legacy VGA stuffs in the driver, since they are
+ causing various issues on non-x86 machines.
+
+ 2. This patch makes sure CRTC2_OFFSET_CNTL is cleared. None of the options in
+ this register should be enabled with our current driver, and some firmwares
+ setup a tiled display, which we _must_ disable for now. Without this, the
+ second screen is completely scrambled on some PowerMacs.
+
+ 3. This patch fix the routine that probes for PLL values in absence of a
+ BIOS ROM. The measure is more precise, done several times to avoid
+ "gliches" caused by scheduling latencies, plus the patch fixes actual
+ bugs in the previous iteration of the code. It also add calculation of
+ the mclk and sclk values for proper display bandwidth calculation and
+ adds proper min/max PLL values for r420 type cards.
+
+ 4. The display bandwidth calculation code has a small bug when looking at
+ the memory controller setup on r300 chips. Hui from ATI confirmed that
+ this was the right fix.
+
+ 5. When using MergedFB, the driver would call RADEONInitPLLRegisters for the
+ first head even when UseBiosDividers was set to TRUE, which was incorrect.
+ This patch fixes it by moving the test of UseBiosDividers into
+ RADEONInitPLLRegisters which simplifies the code in the caller and is more
+ logical.
+
+ 6. The dual head setup was recently re-broken (after having been fixed a while
+ ago) with SURFACE_CNTL beeing written with the wrong value from the second
+ head. The problem is that usually, only the first head had a correct value
+ in there, and the driver would regular mixup which register setup was used to
+ restore that value. This patch fixes it once for all by making sure the
+ second head does carry the proper value too.
+
+ 7. The second digital output of the radeon chip doesn't like when the P2PLL
+ is set with an odd post-divider value. This makes sure we never chose
+ a "wrong" value when calculating the P2PLL setting on a non-CRT screen.
+
+ 8. On some cards where no BIOS provided output mapping infos is available, the
+ driver would get the DDC flipped between the two outputs of the card. This
+ typically happen on recent Mac cards. This adds an option to force the
+ driver to reverse what it thinks is the primary display DDC and the
+ secondary display DDC. Ultimately, we'll have to do a better job of
+ recognizing those Mac cards though.
+
+ 9. RadeonValidateFPModes() has a bug where it could try to dereference
+ a NULL pointer in some cases when linking in modes. This fixes it.
+
+ 10. This patch adds an option for probing the PLL value at server init time
+ for LVDS panels and re-using it later (by setting UseBiosDividers). It's
+ useful on machines without an X86 BIOS image providing the proper set of
+ divider values for the LVDS, as the value calculated by
+ RADEONInitPLLRegisters() tend not to be suitable for some LVDS panels.
+ It also changes a bit the way the panel infos are extracted, the previous
+ code didn't quite work for me, and after discussing with Hui, I decided
+ to move the detection earlier in the discovery process and to do it slightly
+ differently.
+
+ (fd.o #2089) Add 5135_all_6.8.1-r128-ppc-vgaaccess.patch. This patch adds the
+ "VGAAccess" option (defaults to NO on PPC and YES on others) that disables
+ all legacy VGA stuffs in the driver, since they are causing various issues on
+ non-x86 machines.
*xorg-x11-6.8.1.901 (18 Dec 2004)
diff --git a/x11-base/xorg-x11/Manifest b/x11-base/xorg-x11/Manifest
index f9a81c56aa25..dcba1d05ff08 100644
--- a/x11-base/xorg-x11/Manifest
+++ b/x11-base/xorg-x11/Manifest
@@ -1,15 +1,15 @@
MD5 ac1137a20503dcb8f9ba2939a2a766f6 metadata.xml 230
MD5 88e62276e07e48e924930ddb651478b8 xorg-x11-6.7.0-r2.ebuild 38098
MD5 f35b03f0334e20f9ba75a2469fc59e14 xorg-x11-6.8.0-r1.ebuild 41352
-MD5 a3378a2ec4d5099bfc094906d8301af6 ChangeLog 57100
+MD5 7536e7a69e024c3f8428ea1d075694de ChangeLog 60844
MD5 96d2f0d13f75fb909c35e1eb9f25ceae xorg-x11-6.8.0-r4.ebuild 50462
MD5 aaa26043705f4f543594d8fdfca05a9f xorg-x11-6.7.0-r3.ebuild 38116
MD5 48ee3147d2f3c097a9d262a5473cd04c xorg-x11-6.8.0-r3.ebuild 39807
-MD5 54a5bc14ed38d0df3bf819c49de8080a xorg-x11-6.8.1.901.ebuild 50461
+MD5 66288c58315d7275ebbee6d16ed49574 xorg-x11-6.8.1.901.ebuild 50458
MD5 a3314fbdc270d7d84ea14fd477b8d048 files/digest-xorg-x11-6.7.0-r2 904
MD5 70facbdb85b7ef2bc9b9b702442eda7e files/digest-xorg-x11-6.8.0-r1 908
MD5 f14e22fa0891e99c1000c0d61d7e8a0c files/xpm-secfix-thomas.diff 55674
MD5 a3314fbdc270d7d84ea14fd477b8d048 files/digest-xorg-x11-6.7.0-r3 904
MD5 70facbdb85b7ef2bc9b9b702442eda7e files/digest-xorg-x11-6.8.0-r3 908
MD5 b9b96a08d415d8ba85146381bca512da files/digest-xorg-x11-6.8.0-r4 909
-MD5 f874fce603a8b8f5f264975e58e6e357 files/digest-xorg-x11-6.8.1.901 517
+MD5 e738e9479ae67f420a4ee03c3580e18d files/digest-xorg-x11-6.8.1.901 517
diff --git a/x11-base/xorg-x11/files/digest-xorg-x11-6.8.1.901 b/x11-base/xorg-x11/files/digest-xorg-x11-6.8.1.901
index d61954e70cbc..af5b54270969 100644
--- a/x11-base/xorg-x11/files/digest-xorg-x11-6.8.1.901
+++ b/x11-base/xorg-x11/files/digest-xorg-x11-6.8.1.901
@@ -3,5 +3,5 @@ MD5 01a21c248e5ac4ba02cbbea994fc774a xfsft-encodings-0.1.tar.bz2 11892
MD5 d0fab996daf97adf095e2dad0bd9012e gentoo-cursors-tad-0.3.1.tar.bz2 1196991
MD5 3d4ee581df78c9dacc6e97aa07a1af72 gemini-koi8-u.tar.bz2 439173
MD5 8e8905cf6863546481ec52f1101b6984 xorg-x11-6.8.1.901-files-0.6.tar.bz2 10139
-MD5 0ed0f96a7061903d9cb1e34278807129 xorg-x11-6.8.1.901-patches-0.3.0.tar.bz2 145740
+MD5 07c4fe2889b3fa08f6ea81a28f12d72a xorg-x11-6.8.1.901-patches-0.3.1.tar.bz2 156166
MD5 c69b36e2606657d66fd7706b40415e7f xorg-x11-6.8.1.901.tar.bz2 42603151
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild
index 7c2a3ed641c3..51fd68947925 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild,v 1.1 2004/12/19 02:21:52 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.1.901.ebuild,v 1.2 2004/12/19 08:32:54 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -44,7 +44,7 @@ IUSE="3dfx 3dnow bitmap-fonts cjk debug dlloader dmx doc font-server hardened
# IUSE_INPUT_DEVICES="synaptics wacom"
FILES_VER="0.6"
-PATCH_VER="0.3.0"
+PATCH_VER="0.3.1"
XCUR_VER="0.3.1"
#MGADRV_VER="1_3_0beta"
#VIADRV_VER="0.1"