summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-17 13:51:46 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-02-17 13:51:46 +0000
commitb645a454c3a0046929b0e456167d4ad0afa190f4 (patch)
treeeec8215a63668f20075769f6dc4b54fa38cb74d7 /x11-apps
parentVersion Bump (diff)
downloadgentoo-2-b645a454c3a0046929b0e456167d4ad0afa190f4.tar.gz
gentoo-2-b645a454c3a0046929b0e456167d4ad0afa190f4.tar.bz2
gentoo-2-b645a454c3a0046929b0e456167d4ad0afa190f4.zip
Restrict tests so 1.0.9-r1 can go stable, bug #511202.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x2324E7B566DF2611!)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xauth/ChangeLog10
-rw-r--r--x11-apps/xauth/xauth-1.0.9-r1.ebuild5
-rw-r--r--x11-apps/xauth/xauth-1.0.9-r2.ebuild34
3 files changed, 45 insertions, 4 deletions
diff --git a/x11-apps/xauth/ChangeLog b/x11-apps/xauth/ChangeLog
index 1c2c48d38a70..b2e9d4eb6ada 100644
--- a/x11-apps/xauth/ChangeLog
+++ b/x11-apps/xauth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xauth
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/ChangeLog,v 1.101 2014/11/28 15:35:15 chithanh Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/ChangeLog,v 1.102 2015/02/17 13:51:46 chithanh Exp $
+
+*xauth-1.0.9-r2 (17 Feb 2015)
+
+ 17 Feb 2015; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xauth-1.0.9-r2.ebuild, xauth-1.0.9-r1.ebuild:
+ Restrict tests so 1.0.9-r1 can go stable, bug #511202.
*xauth-1.0.9-r1 (28 Nov 2014)
diff --git a/x11-apps/xauth/xauth-1.0.9-r1.ebuild b/x11-apps/xauth/xauth-1.0.9-r1.ebuild
index 0450aedf4be4..1a980c6bcfe8 100644
--- a/x11-apps/xauth/xauth-1.0.9-r1.ebuild
+++ b/x11-apps/xauth/xauth-1.0.9-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/xauth-1.0.9-r1.ebuild,v 1.1 2014/11/28 15:33:42 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/xauth-1.0.9-r1.ebuild,v 1.2 2015/02/17 13:51:46 chithanh Exp $
EAPI=4
@@ -17,6 +17,7 @@ RDEPEND="x11-libs/libX11
x11-libs/libXmu"
DEPEND="${RDEPEND}"
+RESTRICT="test"
# Tests dependend on dev-util/cmdtest awaiting keywording, bug #511202.
# test? ( dev-util/cmdtest )
diff --git a/x11-apps/xauth/xauth-1.0.9-r2.ebuild b/x11-apps/xauth/xauth-1.0.9-r2.ebuild
new file mode 100644
index 000000000000..660e7db64a13
--- /dev/null
+++ b/x11-apps/xauth/xauth-1.0.9-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xauth/xauth-1.0.9-r2.ebuild,v 1.1 2015/02/17 13:51:46 chithanh Exp $
+
+EAPI=4
+
+inherit autotools-utils xorg-2
+
+DESCRIPTION="X authority file utility"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXext
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+# Tests dependend on dev-util/cmdtest awaiting keywording, bug #511202.
+# test? ( dev-util/cmdtest )
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ )
+ xorg-2_src_configure
+}
+
+src_test() {
+ # Address sandbox failure, bug #527574
+ addwrite /proc/self/comm
+ autotools-utils_src_test
+}