summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-05-23 12:21:51 +0000
committerRoy Marples <uberlord@gentoo.org>2007-05-23 12:21:51 +0000
commit7326a6417cc8540082935ed889bd54a39c57d37b (patch)
treeb70138c8cc5cbac5a42a70f0b5edfb3f5af53c9b /x11-apps
parent Remove unnecessary patch. (diff)
downloadgentoo-2-7326a6417cc8540082935ed889bd54a39c57d37b.tar.gz
gentoo-2-7326a6417cc8540082935ed889bd54a39c57d37b.tar.bz2
gentoo-2-7326a6417cc8540082935ed889bd54a39c57d37b.zip
New init script does away with STATICVT option.
A static VT is always preferred, and we check to see if VT7 is available. (Portage version: 2.1.2.7)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xinit/ChangeLog10
-rw-r--r--x11-apps/xinit/files/digest-xinit-1.0.3-r43
-rw-r--r--x11-apps/xinit/files/xdm.confd-110
-rwxr-xr-xx11-apps/xinit/files/xdm.initd-1199
-rw-r--r--x11-apps/xinit/xinit-1.0.3-r4.ebuild49
5 files changed, 270 insertions, 1 deletions
diff --git a/x11-apps/xinit/ChangeLog b/x11-apps/xinit/ChangeLog
index 292b34a754cc..7bdc83a2c336 100644
--- a/x11-apps/xinit/ChangeLog
+++ b/x11-apps/xinit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-apps/xinit
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.87 2007/05/20 22:24:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/ChangeLog,v 1.88 2007/05/23 12:21:51 uberlord Exp $
+
+*xinit-1.0.3-r4 (23 May 2007)
+
+ 23 May 2007; Roy Marples <uberlord@gentoo.org> +files/xdm.confd-1,
+ +files/xdm.initd-1, +xinit-1.0.3-r4.ebuild:
+ New init script does away with STATICVT option.
+ A static VT is always preferred, and we check to see if VT7 is
+ available.
20 May 2007; Jeroen Roovers <jer@gentoo.org> xinit-1.0.3-r3.ebuild:
Stable for HPPA (bug #175465).
diff --git a/x11-apps/xinit/files/digest-xinit-1.0.3-r4 b/x11-apps/xinit/files/digest-xinit-1.0.3-r4
new file mode 100644
index 000000000000..c80598bf332d
--- /dev/null
+++ b/x11-apps/xinit/files/digest-xinit-1.0.3-r4
@@ -0,0 +1,3 @@
+MD5 f04a903cc0e18b3c338f58eb90f6caf8 xinit-1.0.3.tar.bz2 97629
+RMD160 e0299e1cb07d12400b9513752dccde1dc0d9cb78 xinit-1.0.3.tar.bz2 97629
+SHA256 c77a58cba815eb1dde2242a819e80d7d84d753678837ac24d385e3ec65d33186 xinit-1.0.3.tar.bz2 97629
diff --git a/x11-apps/xinit/files/xdm.confd-1 b/x11-apps/xinit/files/xdm.confd-1
new file mode 100644
index 000000000000..6f1fd8ce1702
--- /dev/null
+++ b/x11-apps/xinit/files/xdm.confd-1
@@ -0,0 +1,10 @@
+# We always try and start X on a static VT. The various DMs normally default
+# to using VT7. If you wish to use the xdm init script, then you should ensure
+# that the VT checked is the same VT your DM wants to use. We do this check to
+# ensure that you have't accidently configured something to run on the VT
+# in your /etc/inittab file so that you don't get a dead keyboard.
+CHECKVT=7
+
+# What display manager do you use ? [ xdm | gdm | kdm | entrance ]
+# NOTE: If this is set in /etc/rc.conf, that setting will override this one.
+DISPLAYMANAGER="xdm"
diff --git a/x11-apps/xinit/files/xdm.initd-1 b/x11-apps/xinit/files/xdm.initd-1
new file mode 100755
index 000000000000..a6f5c3f0a3a7
--- /dev/null
+++ b/x11-apps/xinit/files/xdm.initd-1
@@ -0,0 +1,199 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/files/xdm.initd-1,v 1.1 2007/05/23 12:21:51 uberlord Exp $
+
+# This is here to serve as a note to myself, and future developers.
+#
+# Any Display manager (gdm,kdm,xdm) has the following problem: if
+# it is started before any getty, and no vt is specified, it will
+# usually run on vt2. When the getty on vt2 then starts, and the
+# DM is already started, the getty will take control of the keyboard,
+# leaving us with a "dead" keyboard.
+#
+# Resolution: add the following line to /etc/inittab
+#
+# x:a:once:/etc/X11/startDM.sh
+#
+# and have /etc/X11/startDM.sh start the DM in daemon mode if
+# a lock is present (with the info of what DM should be started),
+# else just fall through.
+#
+# How this basically works, is the "a" runlevel is a additional
+# runlevel that you can use to fork processes with init, but the
+# runlevel never gets changed to this runlevel. Along with the "a"
+# runlevel, the "once" key word means that startDM.sh will only be
+# run when we specify it to run, thus eliminating respawning
+# startDM.sh when "xdm" is not added to the default runlevel, as was
+# done previously.
+#
+# This script then just calls "telinit a", and init will run
+# /etc/X11/startDM.sh after the current runlevel completes (this
+# script should only be added to the actual runlevel the user is
+# using).
+#
+# Martin Schlemmer
+# aka Azarah
+# 04 March 2002
+
+
+# Start X Font Server before X
+depend() {
+ need localmount
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ # (#139824) Start after ypbind and autofs for network authentication
+ # (#145219) Could use lirc mouse as input device
+ # (#70689 comment #92) Start after consolefont to avoid display corruption
+ after bootmisc readahead-list ypbind autofs openvpn gpm netmount lircd consolefont
+ before alsasound
+
+ # Start before X
+ use acpid consolekit hald xfs
+}
+
+setup_dm() {
+ local MY_XDM="$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')"
+
+ # Load our root path from profile.env
+ # Needed for kdm
+ PATH="${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")"
+
+ case "${MY_XDM}" in
+ kdm|kde|kde2|kde3)
+ EXE="$(which kdm)"
+ # kdm takes too long to create a pidfile for baselayout-2
+ #PIDFILE=/var/run/kdm.pid
+ PIDFILE=
+ ;;
+ entrance*)
+ EXE=/usr/sbin/entranced
+ PIDFILE=/var/lib/entranced.pid
+ ;;
+ gdm|gnome)
+ EXE=/usr/bin/gdm
+ [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
+ PIDFILE=/var/run/gdm.pid
+ ;;
+ wdm)
+ EXE=/usr/bin/wdm
+ PIDFILE=
+ ;;
+ *)
+ EXE=
+ # Fix #65586, where MY_XDM is empty so EXE=somedir
+ [ -x "/usr/bin/${MY_XDM}" ] && [ -f "/usr/bin/${MY_XDM}" ] \
+ && EXE="/usr/bin/${MY_XDM}"
+ if [ -z "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ fi
+ ;;
+ esac
+
+ if ! [ -x "${EXE}" ] ; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ fi
+}
+
+cmdline_opt() {
+ if [ $# -ne 1 ] || ! [ -r /proc/cmdline ]; then
+ return 1
+ fi
+
+ for opt in $(cat /proc/cmdline) ; do
+ [ "${opt}" = "${1}" ] && return 0
+ done
+
+ return 1
+}
+
+# Check to see if something is defined on our VT
+vtstatic() {
+ if [ -e /etc/inittab ] ; then
+ grep -Eq "^[^#]+.*\<tty7\>" /etc/inittab
+ elif [ -e /etc/ttys ] ; then
+ grep -q "^ttyv$(($1 - 1))" /etc/ttys
+ else
+ return 1
+ fi
+}
+
+start() {
+ local EXE= NAME= PIDFILE=
+ setup_dm
+
+ if cmdline_opt nox ; then
+ einfo "Skipping ${EXE}, received 'nox'"
+ return 0
+ fi
+
+ ebegin "Setting up ${EXE##*/}"
+ #save the prefered DM
+ save_options "service" "${EXE}"
+ save_options "name" "${NAME}"
+ save_options "pidfile" "${PIDFILE}"
+
+ if [ -n "${CHECKVT-y}" ] ; then
+ if vtstatic "${CHECKVT:-7}" ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ] ; then
+ ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
+ telinit a >/dev/null 2>/dev/null
+ return 0
+ else
+ eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
+ return 1
+ fi
+ fi
+ fi
+
+ /etc/X11/startDM.sh
+ eend 0
+}
+
+stop() {
+ local retval=0
+ local curvt=
+ if [ -t 0 ] ; then
+ if type fgconsole >/dev/null 2>/dev/null ; then
+ curvt="$(fgconsole 2>/dev/null)"
+ else
+ curvt="$(tty)"
+ case "${curvt}" in
+ /dev/ttyv[0-9]*) curvt="${curvt#/dev/ttyv*}" ;;
+ *) curvt= ;;
+ esac
+ fi
+ fi
+ local myexe="$(get_options "service")"
+ local myname="$(get_options "name")"
+ local mypidfile="$(get_options "pidfile")"
+ local myservice=${myexe##*/}
+
+ [ -z "${myexe}" ] && return 0
+
+ ebegin "Stopping ${myservice}"
+
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}" ; then
+ start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
+ ${mypidfile:+--pidfile} ${mypidfile} \
+ ${myname:+--name} ${myname}
+ retval=$?
+ fi
+
+ # switch back to original vt
+ if [ -n "${curvt}" ] ; then
+ if type chvt >/dev/null 2>/dev/null ; then
+ chvt "${curvt}"
+ else
+ vidcontrol -s "$((${curvt} + 1))"
+ fi
+ fi
+ eend ${retval} "Error stopping ${myservice}"
+
+ return ${retval}
+}
+
+# vim: set ts=4 :
diff --git a/x11-apps/xinit/xinit-1.0.3-r4.ebuild b/x11-apps/xinit/xinit-1.0.3-r4.ebuild
new file mode 100644
index 000000000000..4a5057ff88cd
--- /dev/null
+++ b/x11-apps/xinit/xinit-1.0.3-r4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xinit/xinit-1.0.3-r4.ebuild,v 1.1 2007/05/23 12:21:51 uberlord Exp $
+
+# Must be before x-modular eclass is inherited
+# This is enabled due to modified Makefile.am from the patches
+SNAPSHOT="yes"
+
+inherit x-modular pam
+
+DESCRIPTION="X Window System initializer"
+
+LICENSE="${LICENSE} GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="minimal"
+
+RDEPEND="x11-apps/xauth
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+PDEPEND="!minimal? ( x11-wm/twm
+ x11-apps/xclock
+ x11-apps/xrdb
+ x11-apps/xsm
+ x11-terms/xterm )"
+
+PATCHES="${FILESDIR}/nolisten-tcp-and-black-background.patch
+ ${FILESDIR}/gentoo-startx-customization-0.99.4.patch"
+
+src_unpack() {
+ x-modular_unpack_source
+ x-modular_patch_source
+
+ sed -i -e "s:^XINITDIR.*:XINITDIR = \$(sysconfdir)/X11/xinit:g" ${S}/Makefile.am
+
+ x-modular_reconf_source
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /etc/X11
+ doexe ${FILESDIR}/chooser.sh ${FILESDIR}/startDM.sh
+ exeinto /etc/X11/Sessions
+ doexe ${FILESDIR}/Xsession
+ exeinto /etc/X11/xinit
+ doexe ${FILESDIR}/xinitrc
+ newinitd ${FILESDIR}/xdm.initd-1 xdm
+ newconfd ${FILESDIR}/xdm.confd-1 xdm
+ newpamd ${FILESDIR}/xserver.pamd xserver
+}