summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-08-08 06:28:13 +0000
commit57fb94ba97fd17987ae03bea4bd04417b795d84b (patch)
tree9bfd00b09ca8ce22f5f0c789638e86d6e99bbc25 /x11-apps/xphelloworld
parentversion bump (diff)
downloadgentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.gz
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.tar.bz2
gentoo-2-57fb94ba97fd17987ae03bea4bd04417b795d84b.zip
Initial commit for modular X.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-apps/xphelloworld')
-rw-r--r--x11-apps/xphelloworld/ChangeLog10
-rw-r--r--x11-apps/xphelloworld/Manifest2
-rw-r--r--x11-apps/xphelloworld/files/digest-xphelloworld-0.99.01
-rw-r--r--x11-apps/xphelloworld/xphelloworld-0.99.0.ebuild22
4 files changed, 35 insertions, 0 deletions
diff --git a/x11-apps/xphelloworld/ChangeLog b/x11-apps/xphelloworld/ChangeLog
new file mode 100644
index 000000000000..7858990d147b
--- /dev/null
+++ b/x11-apps/xphelloworld/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-apps/xphelloworld
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xphelloworld/ChangeLog,v 1.1 2005/08/08 06:28:12 spyderous Exp $
+
+*xphelloworld-0.99.0 (08 Aug 2005)
+
+ 08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +xphelloworld-0.99.0.ebuild:
+ Initial commit for modular X.
+
diff --git a/x11-apps/xphelloworld/Manifest b/x11-apps/xphelloworld/Manifest
new file mode 100644
index 000000000000..1cb1a98d0d5d
--- /dev/null
+++ b/x11-apps/xphelloworld/Manifest
@@ -0,0 +1,2 @@
+MD5 121dc3ecd5193afc9c0d9aefc9ed9247 xphelloworld-0.99.0.ebuild 496
+MD5 2ef38d162364461c0fac144c4552c1fa files/digest-xphelloworld-0.99.0 71
diff --git a/x11-apps/xphelloworld/files/digest-xphelloworld-0.99.0 b/x11-apps/xphelloworld/files/digest-xphelloworld-0.99.0
new file mode 100644
index 000000000000..5f80e162a202
--- /dev/null
+++ b/x11-apps/xphelloworld/files/digest-xphelloworld-0.99.0
@@ -0,0 +1 @@
+MD5 aeaf1b305d49eb084dc8bf6becc3cfad xphelloworld-0.99.0.tar.bz2 68511
diff --git a/x11-apps/xphelloworld/xphelloworld-0.99.0.ebuild b/x11-apps/xphelloworld/xphelloworld-0.99.0.ebuild
new file mode 100644
index 000000000000..f42fadb86a76
--- /dev/null
+++ b/x11-apps/xphelloworld/xphelloworld-0.99.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xphelloworld/xphelloworld-0.99.0.ebuild,v 1.1 2005/08/08 06:28:12 spyderous Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org xphelloworld application"
+KEYWORDS="~x86"
+RDEPEND="x11-libs/libXaw
+ x11-libs/libXprintUtil
+ x11-libs/libXprintAppUtil
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}