summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-06-24 03:15:54 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-06-24 03:15:54 +0000
commitf8673ca2a41c3109eb013f2a01fd944bacd0db6a (patch)
treec46a54d55ded5f6819194498881d31ddc66bd5d7 /x11-apps/xdm
parentAdd latest release of unieject and remove previous. (diff)
downloadgentoo-2-f8673ca2a41c3109eb013f2a01fd944bacd0db6a.tar.gz
gentoo-2-f8673ca2a41c3109eb013f2a01fd944bacd0db6a.tar.bz2
gentoo-2-f8673ca2a41c3109eb013f2a01fd944bacd0db6a.zip
Version bump. This merely contains the setuid patch against the previous
version. (Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'x11-apps/xdm')
-rw-r--r--x11-apps/xdm/ChangeLog8
-rw-r--r--x11-apps/xdm/files/digest-xdm-1.0.53
-rw-r--r--x11-apps/xdm/xdm-1.0.5.ebuild62
3 files changed, 72 insertions, 1 deletions
diff --git a/x11-apps/xdm/ChangeLog b/x11-apps/xdm/ChangeLog
index 32991997990f..5f6d62a14718 100644
--- a/x11-apps/xdm/ChangeLog
+++ b/x11-apps/xdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xdm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.46 2006/06/20 16:15:20 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/ChangeLog,v 1.47 2006/06/24 03:15:54 joshuabaergen Exp $
+
+*xdm-1.0.5 (24 Jun 2006)
+
+ 24 Jun 2006; Joshua Baergen <joshuabaergen@gentoo.org> +xdm-1.0.5.ebuild:
+ Version bump. This merely contains the setuid patch against the previous
+ version.
*xdm-1.0.4-r1 (20 Jun 2006)
diff --git a/x11-apps/xdm/files/digest-xdm-1.0.5 b/x11-apps/xdm/files/digest-xdm-1.0.5
new file mode 100644
index 000000000000..f2e6203a0042
--- /dev/null
+++ b/x11-apps/xdm/files/digest-xdm-1.0.5
@@ -0,0 +1,3 @@
+MD5 205cbf9cd4161dffd63d3516e681dbed xdm-1.0.5.tar.bz2 363931
+RMD160 bdd25a22146ffb495416c580d83c4dbaf6fdc3c9 xdm-1.0.5.tar.bz2 363931
+SHA256 4550c517bd6dcd842c1e4ba6545a4850a7fd708ec2ab831b573f49a40c6defae xdm-1.0.5.tar.bz2 363931
diff --git a/x11-apps/xdm/xdm-1.0.5.ebuild b/x11-apps/xdm/xdm-1.0.5.ebuild
new file mode 100644
index 000000000000..b3c715411493
--- /dev/null
+++ b/x11-apps/xdm/xdm-1.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xdm/xdm-1.0.5.ebuild,v 1.1 2006/06/24 03:15:54 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit multilib x-modular pam
+
+DEFAULTVT="vt7"
+
+DESCRIPTION="X.Org xdm application"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="xprint ipv6 pam"
+RDEPEND="x11-apps/xrdb
+ x11-libs/libXdmcp
+ x11-libs/libXaw
+ >=x11-apps/xinit-1.0.2-r3
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES="${FILESDIR}/wtmp.patch
+ ${FILESDIR}/xwilling-hang.patch"
+
+CONFIGURE_OPTIONS="$(use_enable xprint)
+ $(use_enable ipv6)
+ $(use_with pam)
+ --with-default-vt=${DEFAULTVT}
+ --with-xdmconfigdir=/etc/X11/xdm"
+
+pkg_setup() {
+ if use xprint && ! built_with_use x11-libs/libXaw xprint; then
+ die "Build x11-libs/libXaw with USE=xprint."
+ fi
+}
+
+src_install() {
+ x-modular_src_install
+ exeinto /usr/$(get_libdir)/X11/xdm
+ doexe ${FILESDIR}/Xsession
+ newpamd ${FILESDIR}/xdm.pamd xdm
+}
+
+pkg_preinst() {
+ x-modular_pkg_preinst
+
+ # Check for leftover /usr/lib/X11/xdm symlink
+ if [[ -L "/usr/lib/X11/xdm" ]]; then
+ ewarn "/usr/lib/X11/xdm is a symlink; deleting."
+ rm /usr/lib/X11/xdm
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "Install x11-apps/sessreg, or you won't be able to log in."
+ ewarn "It cannot be added as a dependency yet, because it isn't"
+ ewarn "tested on all architectures."
+}