summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-10-18 22:27:52 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-10-18 22:27:52 +0000
commit9b4a020df3585447304065397ff0bec3e9975acd (patch)
tree32c9644274c4caafb6d1067bbae7f47414e1737c /www-servers
parentFix crash when parsing pdf, bug 387049 (diff)
downloadgentoo-2-9b4a020df3585447304065397ff0bec3e9975acd.tar.gz
gentoo-2-9b4a020df3585447304065397ff0bec3e9975acd.tar.bz2
gentoo-2-9b4a020df3585447304065397ff0bec3e9975acd.zip
www-servers/tomcat: warning fixes in initd script
(Portage version: 2.1.10.29/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog9
-rw-r--r--www-servers/tomcat/files/7/tomcat.init8
-rw-r--r--www-servers/tomcat/tomcat-7.0.21-r1.ebuild (renamed from www-servers/tomcat/tomcat-7.0.21.ebuild)2
3 files changed, 13 insertions, 6 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 466c1c315f76..df94f81da1ba 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.261 2011/09/07 17:16:21 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.262 2011/10/18 22:27:52 fordfrog Exp $
+
+*tomcat-7.0.21-r1 (18 Oct 2011)
+
+ 18 Oct 2011; Miroslav Šulc <fordfrog@gentoo.org> files/7/tomcat.init,
+ -tomcat-7.0.21.ebuild, +tomcat-7.0.21-r1.ebuild:
+ Changed opts to extra_commands in initd script (bug #386753). Also replaced
+ deprecated --chuid with --user.
07 Sep 2011; Miroslav Šulc <fordfrog@gentoo.org>
-files/7/7.0.20-build-xml.patch, -tomcat-7.0.20.ebuild:
diff --git a/www-servers/tomcat/files/7/tomcat.init b/www-servers/tomcat/files/7/tomcat.init
index 9a8f4bba0e00..9e623a9dfc1b 100644
--- a/www-servers/tomcat/files/7/tomcat.init
+++ b/www-servers/tomcat/files/7/tomcat.init
@@ -1,9 +1,9 @@
#!/sbin/runscript
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/7/tomcat.init,v 1.1 2010/12/21 09:13:39 ali_bush Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/files/7/tomcat.init,v 1.2 2011/10/18 22:27:52 fordfrog Exp $
-opts="${opts} forcestop"
+extra_commands="forcestop"
init_env_vars() {
# Populate JAVA_HOME
@@ -44,7 +44,7 @@ ssd() {
shift
start-stop-daemon --start --quiet --background \
--chdir "${CATALINA_TMPDIR}" \
- --chuid ${CATALINA_USER}:${CATALINA_GROUP} \
+ --user ${CATALINA_USER}:${CATALINA_GROUP} \
--make-pidfile --pidfile /var/run/tomcat-7.pid \
--exec ${exec} -- ${OPTS_CP} "$@" ${CATALINA_ARGS} ${TOMCAT_START}
return $?
diff --git a/www-servers/tomcat/tomcat-7.0.21.ebuild b/www-servers/tomcat/tomcat-7.0.21-r1.ebuild
index 16144e3cdc86..19227d51969c 100644
--- a/www-servers/tomcat/tomcat-7.0.21.ebuild
+++ b/www-servers/tomcat/tomcat-7.0.21-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.21.ebuild,v 1.1 2011/09/02 10:50:01 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.21-r1.ebuild,v 1.1 2011/10/18 22:27:52 fordfrog Exp $
EAPI=2
JAVA_PKG_IUSE="doc examples source test"