summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-06-02 17:54:24 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-06-02 17:54:24 +0000
commit7bf8de493b966600a0838e83026f7fafdd54ea6c (patch)
tree2acff245085cbd5511eef470214ff81a2ba06a2c /www-servers
parentAdd virtual/emacs-22 as another alternative. (diff)
downloadgentoo-2-7bf8de493b966600a0838e83026f7fafdd54ea6c.tar.gz
gentoo-2-7bf8de493b966600a0838e83026f7fafdd54ea6c.tar.bz2
gentoo-2-7bf8de493b966600a0838e83026f7fafdd54ea6c.zip
axis compiles fine against the latest slot of dev-java/castor so use that
(Portage version: 2.1.2.7)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/axis/ChangeLog8
-rw-r--r--www-servers/axis/axis-1.2_rc2-r2.ebuild85
-rw-r--r--www-servers/axis/files/digest-axis-1.2_rc2-r23
-rw-r--r--www-servers/axis/metadata.xml2
4 files changed, 96 insertions, 2 deletions
diff --git a/www-servers/axis/ChangeLog b/www-servers/axis/ChangeLog
index 46b16aade3ea..ad315eef5ba4 100644
--- a/www-servers/axis/ChangeLog
+++ b/www-servers/axis/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for www-servers/axis
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/axis/ChangeLog,v 1.13 2007/05/19 21:01:32 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/axis/ChangeLog,v 1.14 2007/06/02 17:54:24 betelgeuse Exp $
+
+*axis-1.2_rc2-r2 (02 Jun 2007)
+
+ 02 Jun 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +axis-1.2_rc2-r2.ebuild:
+ axis compiles fine against the latest slot of dev-java/castor so use that
19 May 2007; Petteri Räty <betelgeuse@gentoo.org> -axis-1.2_rc2.ebuild:
Remove generation 1 ebuild from the tree so that sun-javamail-bin can be
diff --git a/www-servers/axis/axis-1.2_rc2-r2.ebuild b/www-servers/axis/axis-1.2_rc2-r2.ebuild
new file mode 100644
index 000000000000..c4bb25cfc8fd
--- /dev/null
+++ b/www-servers/axis/axis-1.2_rc2-r2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/axis/axis-1.2_rc2-r2.ebuild,v 1.1 2007/06/02 17:54:24 betelgeuse Exp $
+
+WANT_ANT_TASKS="ant-nodeps"
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_PV="${PV//./_}"
+MY_PV="${MY_PV/_rc2/RC2}"
+MY_P="${PN}-${MY_PV}"
+SRCFILE="${MY_P}-src.tar.gz"
+DESCRIPTION="Apache Axis SOAP implementation"
+HOMEPAGE="http://ws.apache.org/axis/"
+SRC_URI="mirror://apache/ws/${PN}/${MY_PV}/${SRCFILE}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+COMMON_DEPEND="
+ =dev-java/servletapi-2.4*
+ dev-java/commons-logging
+ dev-java/commons-discovery
+ dev-java/log4j
+ dev-java/wsdl4j
+ >=dev-java/xerces-2.7
+ =dev-java/rhino-1.5*
+ >=dev-java/castor-1.0
+ >=dev-java/sun-jimi-1.0
+ =dev-java/commons-httpclient-2*
+ >=dev-java/bsf-2.3
+ dev-java/sun-jaf
+ dev-java/sun-javamail"
+RDEPEND="
+ >=virtual/jre-1.4
+ ${COMMON_DEPEND}"
+DEPEND="=virtual/jdk-1.4*
+ ${COMMON_DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/axis-1.2-gentoo.patch"
+
+ find . -name "*.jar" -exec rm -v {} \;
+
+ cd "${S}/lib"
+ java-pkg_jar-from commons-discovery
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from log4j
+ java-pkg_jar-from wsdl4j
+ java-pkg_jar-from sun-jaf
+ java-pkg_jar-from servletapi-2.4
+ java-pkg_jar-from sun-javamail
+ java-pkg_jar-from xerces-2
+ java-pkg_jar-from sun-jimi
+ java-pkg_jar-from castor-1.0
+ java-pkg_jar-from commons-httpclient
+ java-pkg_jar-from bsf-2.3
+}
+
+src_compile() {
+ local antflags="compile -Ddeprecation=false -Dbase.path=/opt"
+ use debug && antflags="${antflags} -Ddebug=on"
+ use !debug && antflags="${antflags} -Ddebug=off"
+ # has prebuild javadocs
+ eant ${antflags}
+}
+
+src_install() {
+ java-pkg_dojar build/lib/axis*.jar
+ java-pkg_dojar build/lib/jaxrpc.jar
+ java-pkg_dojar build/lib/saaj.jar
+
+ dohtml release-notes.html changelog.html || die
+ if use doc; then
+ java-pkg_dohtml -r docs/*
+ dosym /usr/share/doc/${PF}/html/{apiDocs,api} || die
+ fi
+}
diff --git a/www-servers/axis/files/digest-axis-1.2_rc2-r2 b/www-servers/axis/files/digest-axis-1.2_rc2-r2
new file mode 100644
index 000000000000..798d83ec9502
--- /dev/null
+++ b/www-servers/axis/files/digest-axis-1.2_rc2-r2
@@ -0,0 +1,3 @@
+MD5 a5424fcb51e2f3e9ad53db2186185ad6 axis-1_2RC2-src.tar.gz 9888710
+RMD160 3543f87a148b524ccb2c1f5e71f7a22f6cf5d338 axis-1_2RC2-src.tar.gz 9888710
+SHA256 58d34b947c524eeb898a76f0d62020377216ee1173d9c62b70d7b5bb87393ce8 axis-1_2RC2-src.tar.gz 9888710
diff --git a/www-servers/axis/metadata.xml b/www-servers/axis/metadata.xml
index 44b5c227d518..d75e8a6c1c56 100644
--- a/www-servers/axis/metadata.xml
+++ b/www-servers/axis/metadata.xml
@@ -8,6 +8,6 @@ Apache Axis is an implementation of the SOAP ("Simple Object Access Protocol") s
From the draft W3C specification:
- SOAP is a lightweight protocol for exchange of information in a decentralized, distributed environment. It is an XML based protocol that consists of three parts: an envelope that defines a framework for describing what is in a message and how to process it, a set of encoding rules for expressing instances of application-defined datatypes, and a convention for representing remote procedure calls and responses.
+SOAP is a lightweight protocol for exchange of information in a decentralized, distributed environment. It is an XML based protocol that consists of three parts: an envelope that defines a framework for describing what is in a message and how to process it, a set of encoding rules for expressing instances of application-defined datatypes, and a convention for representing remote procedure calls and responses.
</longdescription>
</pkgmetadata>