summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-05-24 11:04:36 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-05-24 11:04:36 +0000
commit668347a16981c342d7aa844494fa2c7009206de8 (patch)
tree260021252615f7c86ae78cf181ad51f19f10792d /www-servers
parentFix typo "Finializing" > "Finalizing" (diff)
downloadgentoo-2-668347a16981c342d7aa844494fa2c7009206de8.tar.gz
gentoo-2-668347a16981c342d7aa844494fa2c7009206de8.tar.bz2
gentoo-2-668347a16981c342d7aa844494fa2c7009206de8.zip
* bump
(Portage version: 2.1_rc2-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/files/digest-nginx-0.3.473
-rw-r--r--www-servers/nginx/nginx-0.3.47.ebuild72
3 files changed, 81 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 376db105c0b1..db8cfa049c60 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.93 2006/05/11 16:54:30 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.94 2006/05/24 11:04:36 voxus Exp $
+
+*nginx-0.3.47 (24 May 2006)
+
+ 24 May 2006; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.3.47.ebuild:
+ Bump.
*nginx-0.3.46 (11 May 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.3.47 b/www-servers/nginx/files/digest-nginx-0.3.47
new file mode 100644
index 000000000000..bc44d8b11477
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.3.47
@@ -0,0 +1,3 @@
+MD5 e186b97e0410302dd7205a42036f7d12 nginx-0.3.47.tar.gz 397601
+RMD160 f5b31b319ef0a5aed70761817e7d86121924313b nginx-0.3.47.tar.gz 397601
+SHA256 6bd35c63b657c86f3d4a5cd4984f0c99ad24acc7b85ac542e8af049c083e5e8f nginx-0.3.47.tar.gz 397601
diff --git a/www-servers/nginx/nginx-0.3.47.ebuild b/www-servers/nginx/nginx-0.3.47.ebuild
new file mode 100644
index 000000000000..63384f3ce300
--- /dev/null
+++ b/www-servers/nginx/nginx-0.3.47.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.47.ebuild,v 1.1 2006/05/24 11:04:36 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}