summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-01-07 10:36:40 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-01-07 10:36:40 +0000
commit46c2b0392c0f989232eb0c26d9698ae5e4ad16fc (patch)
tree752617b5f83139759427002c33dc0e4808c5bbfe /www-servers
parentlighttpd block prior to more testing. (diff)
downloadgentoo-2-46c2b0392c0f989232eb0c26d9698ae5e4ad16fc.tar.gz
gentoo-2-46c2b0392c0f989232eb0c26d9698ae5e4ad16fc.tar.bz2
gentoo-2-46c2b0392c0f989232eb0c26d9698ae5e4ad16fc.zip
New 1.4.13 version, pmasked for testing.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/lighttpd/ChangeLog10
-rw-r--r--www-servers/lighttpd/files/1.4.13/01_lighttpd-1.4.13-99cpu-fix.diff11
-rw-r--r--www-servers/lighttpd/files/1.4.13/02_lighttpd-1.4.13-fcgi-auth-type.diff41
-rw-r--r--www-servers/lighttpd/files/digest-lighttpd-1.4.133
-rw-r--r--www-servers/lighttpd/lighttpd-1.4.13.ebuild204
5 files changed, 268 insertions, 1 deletions
diff --git a/www-servers/lighttpd/ChangeLog b/www-servers/lighttpd/ChangeLog
index 42a7c0898a0f..a3732aa82e5c 100644
--- a/www-servers/lighttpd/ChangeLog
+++ b/www-servers/lighttpd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for www-servers/lighttpd
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.91 2007/01/05 01:28:26 beu Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/ChangeLog,v 1.92 2007/01/07 10:36:39 robbat2 Exp $
+
+*lighttpd-1.4.13 (07 Jan 2007)
+
+ 07 Jan 2007; Robin H. Johnson <robbat2@gentoo.org>
+ +files/1.4.13/01_lighttpd-1.4.13-99cpu-fix.diff,
+ +files/1.4.13/02_lighttpd-1.4.13-fcgi-auth-type.diff,
+ +lighttpd-1.4.13.ebuild:
+ New 1.4.13 version, pmasked for testing.
05 Jan 2007; Elfyn McBratney <beu@gentoo.org> lighttpd-1.4.11.ebuild:
Set WANT_AUTO{CONF,MAKE} variables; fixes bug #160133.
diff --git a/www-servers/lighttpd/files/1.4.13/01_lighttpd-1.4.13-99cpu-fix.diff b/www-servers/lighttpd/files/1.4.13/01_lighttpd-1.4.13-99cpu-fix.diff
new file mode 100644
index 000000000000..56f4243218e0
--- /dev/null
+++ b/www-servers/lighttpd/files/1.4.13/01_lighttpd-1.4.13-99cpu-fix.diff
@@ -0,0 +1,11 @@
+--- src/connections.c.orig 2007-01-05 10:56:08.000000000 -0800
++++ src/connections.c 2007-01-05 10:56:23.000000000 -0800
+@@ -970,7 +970,7 @@
+ }
+ } else {
+ /* a splited \r \n */
+- return -1;
++ break;
+ }
+ }
+ }
diff --git a/www-servers/lighttpd/files/1.4.13/02_lighttpd-1.4.13-fcgi-auth-type.diff b/www-servers/lighttpd/files/1.4.13/02_lighttpd-1.4.13-fcgi-auth-type.diff
new file mode 100644
index 000000000000..aa051c7e1b36
--- /dev/null
+++ b/www-servers/lighttpd/files/1.4.13/02_lighttpd-1.4.13-fcgi-auth-type.diff
@@ -0,0 +1,41 @@
+--- lighttpd-1.4.13/src/mod_fastcgi.c 2006-10-05 03:22:32.000000000 -0700
++++ lighttpd-1.4.13.patch/src/mod_fastcgi.c 2006-10-18 00:57:19.000000000 -0700
+@@ -1875,8 +1875,36 @@
+ fcgi_env_add(p->fcgi_env, CONST_STR_LEN("REMOTE_ADDR"), s, strlen(s));
+
+ if (!buffer_is_empty(con->authed_user)) {
+- fcgi_env_add(p->fcgi_env, CONST_STR_LEN("REMOTE_USER"),
+- CONST_BUF_LEN(con->authed_user));
++ fcgi_env_add(p->fcgi_env, CONST_STR_LEN("REMOTE_USER"), CONST_BUF_LEN(con->authed_user));
++
++ /* AUTH_TYPE fix by Troy Kruthoff (tkruthoff@gmail.com)
++ * section 4.1.1 of RFC 3875 (cgi spec) requires the server to set a AUTH_TYPE env
++ * declaring the type of authentication used. (see http://tools.ietf.org/html/rfc3875#page-11)
++ *
++ * I copied this code from mod_auth.c where it extracts auth info from the "Authorization"
++ * header to authenticate the user before allowing the request to proceed. I'm guessing it makes
++ * sense to re-parse the header here, as mod_auth is unaware if the request is headed for cgi/fcgi.
++ * Someone more familiar with the lighty internals should be able to quickly determine if we are
++ * better storing AUTH_TYPE on the initial parse in mod_auth.
++ */
++ char *http_authorization = NULL;
++ data_string *ds;
++
++ if (NULL != (ds = (data_string *)array_get_element(con->request.headers, "Authorization"))) {
++ http_authorization = ds->value->ptr;
++ }
++
++ if (ds && ds->value && ds->value->used) {
++ char *auth_realm;
++ if (NULL != (auth_realm = strchr(http_authorization, ' '))) {
++ int auth_type_len = auth_realm - http_authorization;
++ if ((auth_type_len == 5) && (0 == strncmp(http_authorization, "Basic", auth_type_len))) {
++ fcgi_env_add(p->fcgi_env, CONST_STR_LEN("AUTH_TYPE"), CONST_STR_LEN("Basic"));
++ } else if ((auth_type_len == 6) && (0 == strncmp(http_authorization, "Digest", auth_type_len))) {
++ fcgi_env_add(p->fcgi_env, CONST_STR_LEN("AUTH_TYPE"), CONST_STR_LEN("Digest"));
++ }
++ }
++ }
+ }
+
+ if (con->request.content_length > 0 && host->mode != FCGI_AUTHORIZER) {
diff --git a/www-servers/lighttpd/files/digest-lighttpd-1.4.13 b/www-servers/lighttpd/files/digest-lighttpd-1.4.13
new file mode 100644
index 000000000000..7a885e91935a
--- /dev/null
+++ b/www-servers/lighttpd/files/digest-lighttpd-1.4.13
@@ -0,0 +1,3 @@
+MD5 d775d6478391b95d841a1018c8db0b95 lighttpd-1.4.13.tar.gz 797813
+RMD160 4e67e42dc3692d50c044561cc903de7b906f260c lighttpd-1.4.13.tar.gz 797813
+SHA256 62d5997fdb41afa9400adcdb040d04a1f5fa950045df96e3e3f593e8f0de5739 lighttpd-1.4.13.tar.gz 797813
diff --git a/www-servers/lighttpd/lighttpd-1.4.13.ebuild b/www-servers/lighttpd/lighttpd-1.4.13.ebuild
new file mode 100644
index 000000000000..8f8abbc12f4b
--- /dev/null
+++ b/www-servers/lighttpd/lighttpd-1.4.13.ebuild
@@ -0,0 +1,204 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/lighttpd/lighttpd-1.4.13.ebuild,v 1.1 2007/01/07 10:36:39 robbat2 Exp $
+
+WANT_AUTOCONF=latest
+WANT_AUTOMAKE=latest
+inherit eutils autotools depend.php
+
+DESCRIPTION="Lightweight high-performance web server"
+HOMEPAGE="http://www.lighttpd.net/"
+SRC_URI="http://www.lighttpd.net/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="bzip2 doc fam fastcgi gdbm ipv6 ldap lua minimal memcache mysql pcre php rrdtool ssl test webdav xattr"
+
+RDEPEND=">=sys-libs/zlib-1.1
+ bzip2? ( app-arch/bzip2 )
+ fam? ( virtual/fam )
+ gdbm? ( sys-libs/gdbm )
+ ldap? ( >=net-nds/openldap-2.1.26 )
+ lua? ( dev-lang/lua )
+ memcache? ( dev-libs/libmemcache )
+ mysql? ( >=virtual/mysql-4.0 )
+ pcre? ( >=dev-libs/libpcre-3.1 )
+ php? (
+ virtual/httpd-php
+ !net-www/spawn-fcgi
+ )
+ rrdtool? ( net-analyzer/rrdtool )
+ ssl? ( >=dev-libs/openssl-0.9.7 )
+ webdav? (
+ dev-libs/libxml2
+ >=dev-db/sqlite-3
+ )
+ xattr? ( kernel_linux? ( sys-apps/attr ) )"
+
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )
+ test? (
+ virtual/perl-Test-Harness
+ dev-libs/fcgi
+ )"
+
+# update certain parts of lighttpd.conf based on conditionals
+update_config() {
+ local config="/etc/lighttpd/lighttpd.conf"
+
+ # enable php/mod_fastcgi settings
+ use php && \
+ dosed 's|#.*\(include.*fastcgi.*$\)|\1|' ${config}
+
+ # enable stat() caching
+ use fam && \
+ dosed 's|#\(.*stat-cache.*$\)|\1|' ${config}
+}
+
+# remove non-essential stuff (for USE=minimal)
+remove_non_essential() {
+ local libdir="${D}/usr/$(get_libdir)/${PN}"
+
+ # text docs
+ use doc || rm -fr ${D}/usr/share/doc/${PF}/txt
+
+ # non-essential modules
+ rm -f \
+ ${libdir}/mod_{compress,evhost,expire,proxy,scgi,secdownload,simple_vhost,status,setenv,trigger*,usertrack}.*
+
+ # allow users to keep some based on USE flags
+ use pcre || rm -f ${libdir}/mod_{ssi,re{direct,write}}.*
+ use webdav || rm -f ${libdir}/mod_webdav.*
+ use mysql || rm -f ${libdir}/mod_mysql_vhost.*
+ use lua || rm -f ${libdir}/mod_cml.*
+ use rrdtool || rm -f ${libdir}/mod_rrdtool.*
+
+ if ! use fastcgi ; then
+ rm -f ${libdir}/mod_fastcgi.* ${D}/usr/bin/spawn-fcgi \
+ ${D}/usr/share/man/man1/spawn-fcgi.*
+ fi
+}
+
+pkg_setup() {
+ if ! use pcre ; then
+ ewarn "It is highly recommended that you build ${PN}"
+ ewarn "with perl regular expressions support via USE=pcre."
+ ewarn "Otherwise you lose support for some core options such"
+ ewarn "as conditionals and modules such as mod_re{write,direct}"
+ ewarn "and mod_ssi."
+ ebeep 5
+ fi
+
+ use php && require_php_with_use cgi
+
+ enewgroup lighttpd
+ enewuser lighttpd -1 -1 /var/www/localhost/htdocs lighttpd
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ EPATCH_SUFFIX="diff" epatch ${FILESDIR}/${PV} || die "Patching failed!"
+
+ eautoreconf || die
+
+ # dev-python/docutils installs rst2html.py not rst2html
+ sed -i -e 's|\(rst2html\)|\1.py|g' doc/Makefile.in || \
+ die "sed doc/Makefile.in failed"
+
+ # fix typo
+ sed -i -e 's|\(output_content\)_\(type\)|\1\2|' doc/cml.txt || \
+ die "sed doc/cml.txt failed"
+}
+
+src_compile() {
+ econf --libdir=/usr/$(get_libdir)/${PN} \
+ --enable-lfs \
+ $(use_enable ipv6) \
+ $(use_with bzip2) \
+ $(use_with fam) \
+ $(use_with gdbm) \
+ $(use_with lua) \
+ $(use_with ldap) \
+ $(use_with memcache) \
+ $(use_with mysql) \
+ $(use_with pcre) \
+ $(use_with ssl openssl) \
+ $(use_with webdav webdav-props) \
+ $(use_with xattr attr) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+
+ if use doc ; then
+ einfo "Building HTML documentation"
+ cd doc
+ emake html || die "failed to build HTML documentation"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # init script stuff
+ newinitd ${FILESDIR}/lighttpd.initd lighttpd || die
+ newconfd ${FILESDIR}/lighttpd.confd lighttpd || die
+ use fam && has_version app-admin/fam && \
+ sed -i 's/after famd/need famd/g' "${D}"/etc/init.d/lighttpd
+
+ if use php || use fastcgi ; then
+ newinitd ${FILESDIR}/spawn-fcgi.initd spawn-fcgi || die
+ newconfd ${FILESDIR}/spawn-fcgi.confd spawn-fcgi || die
+ fi
+
+ # configs
+ insinto /etc/lighttpd
+ doins ${FILESDIR}/conf/*.conf
+
+ # update lighttpd.conf directives based on conditionals
+ update_config
+
+ # docs
+ dodoc AUTHORS README NEWS ChangeLog doc/*.sh
+ newdoc doc/lighttpd.conf lighttpd.conf.distrib
+
+ use doc && dohtml -r doc/*
+
+ docinto txt
+ dodoc doc/*.txt
+
+ # logrotate
+ insinto /etc/logrotate.d
+ newins ${FILESDIR}/lighttpd.logrotate lighttpd || die
+
+ keepdir /var/l{ib,og}/lighttpd /var/www/localhost/htdocs
+ fowners lighttpd:lighttpd /var/l{ib,og}/lighttpd
+ fperms 0750 /var/l{ib,og}/lighttpd
+
+ use minimal && remove_non_essential
+}
+
+pkg_postinst () {
+ echo
+ if [[ -f ${ROOT}etc/conf.d/spawn-fcgi.conf ]] ; then
+ einfo "spawn-fcgi is now included with lighttpd"
+ einfo "spawn-fcgi's init script configuration is now located"
+ einfo "at /etc/conf.d/spawn-fcgi."
+ echo
+ fi
+
+ if [[ -f ${ROOT}etc/lighttpd.conf ]] ; then
+ ewarn "As of lighttpd-1.4.1, Gentoo has a customized configuration,"
+ ewarn "which is now located in /etc/lighttpd. Please migrate your"
+ ewarn "existing configuration."
+ ebeep 5
+ fi
+
+ if use fam ; then
+ einfo "Remember to re-emerge lighttpd should you switch from"
+ einfo "app-admin/famd to app-admin/gamin or vice versa."
+ fi
+ echo
+}