summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-12-15 21:31:15 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-12-15 21:31:15 +0000
commit40bad6087b187fced158703e65b04f555a5e96f6 (patch)
treeb1eafa023b0bfb9fec2da03ada70a0f5e7e5ab79 /www-servers
parentFix for Prefix, add amd64 FreeBSD support (~x64-freebsd Prefix arch), transfe... (diff)
downloadgentoo-2-40bad6087b187fced158703e65b04f555a5e96f6.tar.gz
gentoo-2-40bad6087b187fced158703e65b04f555a5e96f6.tar.bz2
gentoo-2-40bad6087b187fced158703e65b04f555a5e96f6.zip
www-servers/tomcat: fixed bug with storing session information
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/tomcat/ChangeLog9
-rw-r--r--www-servers/tomcat/tomcat-7.0.23-r1.ebuild (renamed from www-servers/tomcat/tomcat-7.0.23.ebuild)16
2 files changed, 22 insertions, 3 deletions
diff --git a/www-servers/tomcat/ChangeLog b/www-servers/tomcat/ChangeLog
index 3764ecc76c01..e796ab0a1305 100644
--- a/www-servers/tomcat/ChangeLog
+++ b/www-servers/tomcat/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/tomcat
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.270 2011/12/14 18:56:50 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/ChangeLog,v 1.271 2011/12/15 21:31:15 fordfrog Exp $
+
+*tomcat-7.0.23-r1 (15 Dec 2011)
+
+ 15 Dec 2011; Miroslav Šulc <fordfrog@gentoo.org> -tomcat-7.0.23.ebuild,
+ +tomcat-7.0.23-r1.ebuild:
+ Fixed bug with storing SESSIONS.ser in work directory. It cannot be symlink
+ because tomcat by default does not allow working with symlink paths.
14 Dec 2011; Agostino Sarubbo <ago@gentoo.org> tomcat-7.0.22-r1.ebuild:
Stable for AMD64, wrt bug #392393
diff --git a/www-servers/tomcat/tomcat-7.0.23.ebuild b/www-servers/tomcat/tomcat-7.0.23-r1.ebuild
index c69936e89119..d953141ff0c6 100644
--- a/www-servers/tomcat/tomcat-7.0.23.ebuild
+++ b/www-servers/tomcat/tomcat-7.0.23-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.23.ebuild,v 1.1 2011/11/29 13:00:21 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/tomcat/tomcat-7.0.23-r1.ebuild,v 1.1 2011/12/15 21:31:15 fordfrog Exp $
EAPI=2
JAVA_PKG_IUSE="doc examples source test"
@@ -165,7 +165,9 @@ src_install() {
dosym /etc/${TOMCAT_NAME} ${CATALINA_BASE}/conf
dosym /var/log/${TOMCAT_NAME} ${CATALINA_BASE}/logs
dosym /var/tmp/${TOMCAT_NAME} ${CATALINA_BASE}/temp
- dosym /var/run/${TOMCAT_NAME} ${CATALINA_BASE}/work
+ # we cannot symlink work directory because that breaks saving session data
+ # because session file cannot be saved to symlinked location by default
+ #dosym /var/run/${TOMCAT_NAME} ${CATALINA_BASE}/work
dodoc "${S}"/{RELEASE-NOTES,RUNNING.txt}
fperms 640 /etc/${TOMCAT_NAME}/tomcat-users.xml
@@ -183,6 +185,7 @@ pkg_postinst() {
# bug #180519
if [[ -e "${ROOT}var/lib/${TOMCAT_NAME}/webapps/manager" ]] ; then
+ elog
elog "The latest webapp has NOT been installed into"
elog "${ROOT}var/lib/${TOMCAT_NAME}/webapps/ because directory already exists"
elog "and we do not want to overwrite any files you have put there."
@@ -201,6 +204,15 @@ pkg_postinst() {
dosym ${TOMCAT_HOME}/webapps/manager/META-INF/context.xml /etc/${TOMCAT_NAME}/Catalina/localhost/manager.xml
fi
+ # bug with storing SESSIONS.ser file to path with symlink
+ if [[ -L "${ROOT}var/lib/${TOMCAT_NAME}/work" ]] ; then
+ elog
+ ewarn "${ROOT}var/lib/${TOMCAT_NAME}/work is symbolic link which breaks"
+ ewarn "storing of SESSIONS.ser files in work directory when allowLinking"
+ ewarn "is disabled (the default). Remove the symbolic link (while Tomcat is"
+ ewarn "not running) to fix the issue."
+ fi
+
elog
elog " This ebuild implements a FHS compliant layout for tomcat"
elog " Please read http://www.gentoo.org/proj/en/java/tomcat6-guide.xml"