summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-11-16 07:18:38 +0000
committerTim Harder <radhermit@gentoo.org>2011-11-16 07:18:38 +0000
commit2d1ed6f18f99d0bbe2199391b0c8039f1c50530e (patch)
treef1a02680df1d8517efd155d77eebb9a1586b1ac7 /www-servers
parentVersion bump and remove old. (diff)
downloadgentoo-2-2d1ed6f18f99d0bbe2199391b0c8039f1c50530e.tar.gz
gentoo-2-2d1ed6f18f99d0bbe2199391b0c8039f1c50530e.tar.bz2
gentoo-2-2d1ed6f18f99d0bbe2199391b0c8039f1c50530e.zip
Version bump (fixes bug #339100).
(Portage version: 2.2.0_alpha73/cvs/Linux x86_64)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/monkeyd/ChangeLog9
-rw-r--r--www-servers/monkeyd/monkeyd-0.21.0.ebuild68
2 files changed, 75 insertions, 2 deletions
diff --git a/www-servers/monkeyd/ChangeLog b/www-servers/monkeyd/ChangeLog
index 7f897eb0acc3..b0b18a9ee93a 100644
--- a/www-servers/monkeyd/ChangeLog
+++ b/www-servers/monkeyd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/monkeyd
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.21 2009/04/20 08:09:58 bangert Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/ChangeLog,v 1.22 2011/11/16 07:18:38 radhermit Exp $
+
+*monkeyd-0.21.0 (16 Nov 2011)
+
+ 16 Nov 2011; Tim Harder <radhermit@gentoo.org> +monkeyd-0.21.0.ebuild:
+ Version bump (fixes bug #339100).
20 Apr 2009; Thilo Bangert <bangert@gentoo.org> monkeyd-0.9.2-r1:
remove use-based dep on virtual again
diff --git a/www-servers/monkeyd/monkeyd-0.21.0.ebuild b/www-servers/monkeyd/monkeyd-0.21.0.ebuild
new file mode 100644
index 000000000000..6deeb579f246
--- /dev/null
+++ b/www-servers/monkeyd/monkeyd-0.21.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/monkeyd/monkeyd-0.21.0.ebuild,v 1.1 2011/11/16 07:18:38 radhermit Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs depend.php multilib
+
+WEBROOT=/var/www/localhost
+
+MY_P="${PN/d}-${PV}"
+DESCRIPTION="A small, fast, and scalable web server"
+HOMEPAGE="http://www.monkey-project.com/"
+SRC_URI="http://monkey-project.com/releases/${PV:0:4}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~sparc ~x86"
+IUSE="php"
+
+RDEPEND="php? ( virtual/httpd-php )"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use php && require_php_cgi
+}
+
+src_prepare() {
+ # Don't install the banana script, it is broken as is anyway and the
+ # functionality is provided by the ${FILESDIR}/monkeyd.init.d script.
+ sed -i '/install -m 755 bin\/banana/d' configure || die "sed banana"
+
+ # Don't explicitly strip files
+ sed -i -e '/$STRIP /d' -e 's/install -s -m 644/install -m 755/' configure || die
+}
+
+src_configure() {
+ # Non-autotools configure
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=${WEBROOT}/htdocs \
+ --logdir=/var/log/${PN} \
+ --mandir=/usr/share/man \
+ --plugdir=/usr/$(get_libdir)/monkeyd/plugins \
+ --sysconfdir=/etc/${PN} \
+ || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ if use php ; then
+ sed -i -e '/^#AddScript application\/x-httpd-php/s:^#::' "${D}"/etc/monkeyd/monkey.conf || die
+ sed -i -e 's:/home/my_home/php/bin/php:/usr/bin/php-cgi:' "${D}"/etc/monkeyd/monkey.conf || die
+ fi
+
+ mv "${D}"${WEBROOT}/htdocs/{index,index-monkey}.html
+
+ sed -i -e "s:/var/log/monkeyd/monkey.pid:/var/run/monkey.pid:" "${D}"/etc/monkeyd/monkey.conf || die
+ newinitd "${FILESDIR}"/monkeyd.init.d monkeyd
+ newconfd "${FILESDIR}"/monkeyd.conf.d monkeyd
+}