summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2005-09-08 22:13:22 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2005-09-08 22:13:22 +0000
commit2757699ef0bbd0e501051e96db6c986ab60b2a60 (patch)
treeed8d416d3c4437fd3e89b4fb0a2fec1a63edfbd3 /www-servers
parentMark 1.00 stable on alpha (diff)
downloadgentoo-2-2757699ef0bbd0e501051e96db6c986ab60b2a60.tar.gz
gentoo-2-2757699ef0bbd0e501051e96db6c986ab60b2a60.tar.bz2
gentoo-2-2757699ef0bbd0e501051e96db6c986ab60b2a60.zip
* bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/nginx/ChangeLog7
-rw-r--r--www-servers/nginx/Manifest2
-rw-r--r--www-servers/nginx/files/digest-nginx-0.1.451
-rw-r--r--www-servers/nginx/nginx-0.1.45.ebuild70
4 files changed, 79 insertions, 1 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 8615dea3fa9b..4fd571f57e58 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.41 2005/09/06 16:14:27 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.42 2005/09/08 22:13:22 voxus Exp $
+
+*nginx-0.1.45 (09 Sep 2005)
+
+ 09 Sep 2005; Konstantin Arkhipov <voxus@gentoo.org> +nginx-0.1.45.ebuild:
+ Version bump.
*nginx-0.1.44 (06 Sep 2005)
diff --git a/www-servers/nginx/Manifest b/www-servers/nginx/Manifest
index b5b64659a53e..bde264ec0405 100644
--- a/www-servers/nginx/Manifest
+++ b/www-servers/nginx/Manifest
@@ -2,7 +2,9 @@ MD5 33a1556cbc2f963118c3ca1782fe9d46 nginx-0.1.44.ebuild 1937
MD5 da8089ca918d40c0a8cdab5e39858a12 nginx-0.1.41.ebuild 1898
MD5 c97cfa1d6141e311cc194bccdc56dc61 ChangeLog 7324
MD5 822f3c821527e6a34f23a6a92a884766 metadata.xml 220
+MD5 33a1556cbc2f963118c3ca1782fe9d46 nginx-0.1.45.ebuild 1937
MD5 d726deb4444f111650634a938adba396 files/digest-nginx-0.1.41 64
MD5 b790af574de0a326ca384473a470f2b8 files/digest-nginx-0.1.44 64
+MD5 e8474104898712edc8575c940152bbd3 files/digest-nginx-0.1.45 64
MD5 d8f7e621e098b58848a6b5fb045c49c3 files/nginx 994
MD5 fecedd05099122b1f8169152e5bc9462 files/nginx.conf 1400
diff --git a/www-servers/nginx/files/digest-nginx-0.1.45 b/www-servers/nginx/files/digest-nginx-0.1.45
new file mode 100644
index 000000000000..a9705255af74
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.1.45
@@ -0,0 +1 @@
+MD5 e26aabfa4252bcf2cb19a70779b49b14 nginx-0.1.45.tar.gz 322706
diff --git a/www-servers/nginx/nginx-0.1.45.ebuild b/www-servers/nginx/nginx-0.1.45.ebuild
new file mode 100644
index 000000000000..616dac814816
--- /dev/null
+++ b/www-servers/nginx/nginx-0.1.45.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.1.45.ebuild,v 1.1 2005/09/08 22:13:22 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dodir /etc/${PN}
+
+ dosbin objs/nginx
+ doinitd ${FILESDIR}/nginx
+
+ insinto /etc/${PN}
+ rm conf/nginx.conf
+ doins -r conf/*
+ doins ${FILESDIR}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+}