summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2008-03-10 22:10:20 +0000
committerThilo Bangert <bangert@gentoo.org>2008-03-10 22:10:20 +0000
commit6ebd9741afd32a7d20eff8d6859a840b23d64b4d (patch)
tree453c14748d550da107d114f2b2ce67ef2fe4101b /www-servers/varnish
parentRemove old (diff)
downloadgentoo-2-6ebd9741afd32a7d20eff8d6859a840b23d64b4d.tar.gz
gentoo-2-6ebd9741afd32a7d20eff8d6859a840b23d64b4d.tar.bz2
gentoo-2-6ebd9741afd32a7d20eff8d6859a840b23d64b4d.zip
allow varnish to lock the logfile to memory - add RDEPEND on gcc
(Portage version: 2.1.4.4)
Diffstat (limited to 'www-servers/varnish')
-rw-r--r--www-servers/varnish/ChangeLog8
-rwxr-xr-xwww-servers/varnish/files/varnishd.initd4
-rw-r--r--www-servers/varnish/varnish-1.1.2.ebuild5
3 files changed, 12 insertions, 5 deletions
diff --git a/www-servers/varnish/ChangeLog b/www-servers/varnish/ChangeLog
index 93992f48016b..2819fe7875bc 100644
--- a/www-servers/varnish/ChangeLog
+++ b/www-servers/varnish/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/varnish
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.13 2007/12/21 22:39:22 bangert Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/ChangeLog,v 1.14 2008/03/10 22:10:20 bangert Exp $
+
+ 10 Mar 2008; Thilo Bangert <bangert@gentoo.org> files/varnishd.initd:
+ allow varnish to lock the logfile to memory - the next version of varnish
+ will require this. Add RDEPEND on gcc - varnish compiles vcl into c code.
21 Dec 2007; Thilo Bangert <bangert@gentoo.org>
-files/varnish-1.1-build-DESTDIR.patch, varnish-1.0.4.ebuild,
diff --git a/www-servers/varnish/files/varnishd.initd b/www-servers/varnish/files/varnishd.initd
index 61b450ba6782..4a7890f5dc8a 100755
--- a/www-servers/varnish/files/varnishd.initd
+++ b/www-servers/varnish/files/varnishd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/files/varnishd.initd,v 1.4 2007/06/11 22:59:25 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/files/varnishd.initd,v 1.5 2008/03/10 22:10:20 bangert Exp $
depend() {
need net
@@ -9,6 +9,8 @@ depend() {
start() {
ebegin "Starting varnish"
+ #allow varnishd to lock logfile to memory
+ ulimit -l 82000
start-stop-daemon --quiet --start --pidfile /var/run/varnishd.pid --exec /usr/sbin/varnishd -- -P /var/run/varnishd.pid ${VARNISHD_OPTS} &> /dev/null
eend $?
}
diff --git a/www-servers/varnish/varnish-1.1.2.ebuild b/www-servers/varnish/varnish-1.1.2.ebuild
index d89ef7260bbf..78dcf4e404e2 100644
--- a/www-servers/varnish/varnish-1.1.2.ebuild
+++ b/www-servers/varnish/varnish-1.1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-1.1.2.ebuild,v 1.1 2007/12/21 22:26:22 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/varnish/varnish-1.1.2.ebuild,v 1.2 2008/03/10 22:10:20 bangert Exp $
inherit eutils
DESCRIPTION="Varnish is an HTTP accelerator"
@@ -11,6 +11,7 @@ LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RDEPEND="sys-devel/gcc"
src_compile() {
econf || die "econf failed"