summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-08-03 16:52:47 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-08-03 16:52:47 +0000
commitd65d2d71aa3e885c7bbf5c698a78c2c887459989 (patch)
tree95778c8ea558a75abb4aab9f88504a0382a94f70 /www-servers/publicfile
parentRemoved old, keyword amd64-linux, x86-linux (diff)
downloadgentoo-2-d65d2d71aa3e885c7bbf5c698a78c2c887459989.tar.gz
gentoo-2-d65d2d71aa3e885c7bbf5c698a78c2c887459989.tar.bz2
gentoo-2-d65d2d71aa3e885c7bbf5c698a78c2c887459989.zip
Fix launch script wrt bug #429528. Tidy ebuild.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'www-servers/publicfile')
-rw-r--r--www-servers/publicfile/ChangeLog6
-rw-r--r--www-servers/publicfile/publicfile-0.52-r3.ebuild23
2 files changed, 17 insertions, 12 deletions
diff --git a/www-servers/publicfile/ChangeLog b/www-servers/publicfile/ChangeLog
index 622dd60d0ad2..bf6275a2b5f2 100644
--- a/www-servers/publicfile/ChangeLog
+++ b/www-servers/publicfile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/publicfile
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/publicfile/ChangeLog,v 1.16 2012/03/24 10:39:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/publicfile/ChangeLog,v 1.17 2012/08/03 16:52:47 kensington Exp $
+
+ 03 Aug 2012; Michael Palimaka <kensington@gentoo.org>
+ publicfile-0.52-r3.ebuild:
+ Fix launch script wrt bug #429528. Tidy ebuild.
*publicfile-0.52-r3 (24 Mar 2012)
diff --git a/www-servers/publicfile/publicfile-0.52-r3.ebuild b/www-servers/publicfile/publicfile-0.52-r3.ebuild
index ba2d2a0d90e8..e7716a0332f3 100644
--- a/www-servers/publicfile/publicfile-0.52-r3.ebuild
+++ b/www-servers/publicfile/publicfile-0.52-r3.ebuild
@@ -1,26 +1,29 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/publicfile/publicfile-0.52-r3.ebuild,v 1.1 2012/03/24 10:39:13 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/publicfile/publicfile-0.52-r3.ebuild,v 1.2 2012/08/03 16:52:47 kensington Exp $
EAPI=4
inherit eutils toolchain-funcs
-IUSE="selinux vanilla"
DESCRIPTION="publish files through FTP and HTTP"
HOMEPAGE="http://cr.yp.to/publicfile.html"
SRC_URI="http://cr.yp.to/publicfile/${P}.tar.gz
http://www.ohse.de/uwe/patches/${P}-filetype-diff
http://www.publicfile.org/ftp-ls-patch"
-SLOT="0"
+
LICENSE="as-is"
+SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="selinux vanilla"
RDEPEND="virtual/daemontools
>=sys-apps/ucspi-tcp-0.83
selinux? ( sec-policy/selinux-publicfile )
!net-ftp/netkit-ftpd"
+RESTRICT="test"
+
src_prepare() {
# filetypes in env using daemontools
use vanilla || epatch "${DISTDIR}"/${P}-filetype-diff
@@ -30,6 +33,12 @@ src_prepare() {
# fix for glibc-2.3.2 errno issue
sed -i -e 's|extern int errno;|#include <errno.h>|' error.h
+
+ # fix file collision
+ sed -i configure.c \
+ -e 's|/bin/httpd|/bin/publicfile-httpd|' \
+ -e 's|/bin/ftpd|/bin/publicfile-ftpd|' \
+ || die "sed file collision failed"
}
src_configure() {
@@ -38,14 +47,6 @@ src_configure() {
echo "/usr" > conf-home
}
-src_compile() {
- emake || die "emake failed"
-}
-
-src_test() {
- :
-}
-
src_install() {
exeinto /usr/bin
newexe ftpd publicfile-ftpd