summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-31 18:22:37 +0000
committerKonstantin V. Arkhipov <voxus@gentoo.org>2006-10-31 18:22:37 +0000
commitee8f51d7c564dd00d53217b7edfc6f4db38c19f5 (patch)
tree488009d0a8463e3a40a4b5373e977414a4e66ebe /www-servers/nginx
parentBump to 4.16 (from 4.15) (diff)
downloadgentoo-2-ee8f51d7c564dd00d53217b7edfc6f4db38c19f5.tar.gz
gentoo-2-ee8f51d7c564dd00d53217b7edfc6f4db38c19f5.tar.bz2
gentoo-2-ee8f51d7c564dd00d53217b7edfc6f4db38c19f5.zip
* bump, 0.3.61 goes stable.
(Portage version: 2.1.2_rc1-r1)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog9
-rw-r--r--www-servers/nginx/files/digest-nginx-0.4.123
-rw-r--r--www-servers/nginx/nginx-0.3.61.ebuild4
-rw-r--r--www-servers/nginx/nginx-0.4.12.ebuild79
4 files changed, 92 insertions, 3 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 7ef67226b4a3..b449bd5cb703 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.117 2006/10/25 17:25:55 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.118 2006/10/31 18:22:37 voxus Exp $
+
+*nginx-0.4.12 (31 Oct 2006)
+
+ 31 Oct 2006; Konstantin V. Arkhipov <voxus@gentoo.org>
+ -nginx-0.3.54.ebuild, -nginx-0.3.57.ebuild, nginx-0.3.61.ebuild,
+ -nginx-0.4.11.ebuild, +nginx-0.4.12.ebuild:
+ Version bump, 0.3.61 goes stable on amd64/x86.
*nginx-0.4.11 (25 Oct 2006)
diff --git a/www-servers/nginx/files/digest-nginx-0.4.12 b/www-servers/nginx/files/digest-nginx-0.4.12
new file mode 100644
index 000000000000..c5af21fb4c97
--- /dev/null
+++ b/www-servers/nginx/files/digest-nginx-0.4.12
@@ -0,0 +1,3 @@
+MD5 b2b9ca9d4fcb5e912dc082b535fd08b9 nginx-0.4.12.tar.gz 435588
+RMD160 43f5155e28a6a9f01ed6ccfc13358f0af5b551a6 nginx-0.4.12.tar.gz 435588
+SHA256 8d6615861a5da15f52f81a8fb51361ee0220c4e9e19f7f6faa4d54f7c32e82fa nginx-0.4.12.tar.gz 435588
diff --git a/www-servers/nginx/nginx-0.3.61.ebuild b/www-servers/nginx/nginx-0.3.61.ebuild
index 1d3d46757225..bf87e1f49519 100644
--- a/www-servers/nginx/nginx-0.3.61.ebuild
+++ b/www-servers/nginx/nginx-0.3.61.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.61.ebuild,v 1.1 2006/09/09 17:27:36 voxus Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.3.61.ebuild,v 1.2 2006/10/31 18:22:37 voxus Exp $
inherit eutils
@@ -10,7 +10,7 @@ HOMEPAGE="http://sysoev.ru/nginx/"
SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
+KEYWORDS="amd64 ~ppc x86"
IUSE="debug fastcgi imap pcre perl threads ssl zlib"
DEPEND="dev-lang/perl
diff --git a/www-servers/nginx/nginx-0.4.12.ebuild b/www-servers/nginx/nginx-0.4.12.ebuild
new file mode 100644
index 000000000000..7b4c67558187
--- /dev/null
+++ b/www-servers/nginx/nginx-0.4.12.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-0.4.12.ebuild,v 1.1 2006/10/31 18:22:37 voxus Exp $
+
+inherit eutils
+
+DESCRIPTION="Robust, small and high performance http and reverse proxy server"
+
+HOMEPAGE="http://sysoev.ru/nginx/"
+SRC_URI="http://sysoev.ru/nginx/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug fastcgi imap pcre perl threads ssl zlib"
+
+DEPEND="dev-lang/perl
+ pcre? ( >=dev-libs/libpcre-4.2 )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )
+ perl? ( >=dev-lang/perl-5.8 )"
+
+src_compile() {
+ local myconf
+
+ if use threads; then
+ einfo
+ ewarn "threads support is experimental at the moment"
+ ewarn "do not use it on production systems - you've been warned"
+ einfo
+ myconf="${myconf} --with-threads"
+ fi
+
+ use fastcgi || myconf="${myconf} --without-http_fastcgi_module"
+ use fastcgi && myconf="${myconf} --with-http_realip_module"
+ use zlib || myconf="${myconf} --without-http_gzip_module"
+ use pcre || {
+ myconf="${myconf} --without-pcre --without-http_rewrite_module"
+ }
+ use debug && myconf="${myconf} --with-debug"
+ use ssl && myconf="${myconf} --with-http_ssl_module"
+ use imap && myconf="${myconf} --with-imap" # pop3/imap4 proxy support
+ use perl && myconf="${myconf} --with-http_perl_module"
+
+ ./configure \
+ --prefix=/usr \
+ --conf-path=/etc/${PN}/${PN}.conf \
+ --http-log-path=/var/log/${PN}/access_log \
+ --error-log-path=/var/log/${PN}/error_log \
+ --pid-path=/var/run/${PN}.pid \
+ --http-client-body-temp-path=/var/tmp/${PN}/client \
+ --http-proxy-temp-path=/var/tmp/${PN}/proxy \
+ --http-fastcgi-temp-path=/var/tmp/${PN}/fastcgi \
+ --with-md5-asm --with-md5=/usr/include \
+ ${myconf} || die "configure failed"
+
+ emake || die "failed to compile"
+}
+
+src_install() {
+ keepdir /var/log/${PN} /var/tmp/${PN}/{client,proxy,fastcgi}
+
+ dosbin objs/nginx
+ cp ${FILESDIR}/nginx-r1 ${T}/nginx
+ doinitd ${T}/nginx
+
+ rm conf/nginx.conf
+ cp ${FILESDIR}/nginx.conf-r2 ${T}/nginx.conf
+
+ dodir /etc/${PN}
+ insinto /etc/${PN}
+ doins conf/* ${T}/nginx.conf
+
+ dodoc CHANGES{,.ru} LICENSE README
+
+ use perl && {
+ cd ${S}/objs/src/http/modules/perl/
+ make DESTDIR=${D} install || die "failed to install perl stuff"
+ }
+}