summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-03-10 12:45:41 +0000
committerJustin Lecher <jlec@gentoo.org>2015-03-10 12:45:41 +0000
commit7cfe00ef09f64a4131d446c85133f4acbd8f2ebc (patch)
tree16d2ae5207f7f504c216c4453961d984b028e41c /www-servers/nginx
parentUpdate version to new fork (diff)
downloadgentoo-2-7cfe00ef09f64a4131d446c85133f4acbd8f2ebc.tar.gz
gentoo-2-7cfe00ef09f64a4131d446c85133f4acbd8f2ebc.tar.bz2
gentoo-2-7cfe00ef09f64a4131d446c85133f4acbd8f2ebc.zip
Import changes from proxy maintainer Johan Bergstroem, https://github.com/gentoo/proxy-maintainers/pull/22
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'www-servers/nginx')
-rw-r--r--www-servers/nginx/ChangeLog6
-rw-r--r--www-servers/nginx/nginx-1.7.10.ebuild24
2 files changed, 17 insertions, 13 deletions
diff --git a/www-servers/nginx/ChangeLog b/www-servers/nginx/ChangeLog
index 2a2afcd8b87d..6a3055573849 100644
--- a/www-servers/nginx/ChangeLog
+++ b/www-servers/nginx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for www-servers/nginx
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.402 2015/03/10 09:34:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/ChangeLog,v 1.403 2015/03/10 12:45:41 jlec Exp $
+
+ 10 Mar 2015; Justin Lecher <jlec@gentoo.org> nginx-1.7.10.ebuild:
+ Import changes from proxy maintainer Johan Bergstroem,
+ https://github.com/gentoo/proxy-maintainers/pull/22
*nginx-1.7.10 (10 Mar 2015)
diff --git a/www-servers/nginx/nginx-1.7.10.ebuild b/www-servers/nginx/nginx-1.7.10.ebuild
index 1e82a99facb4..4b4ff73d6b1e 100644
--- a/www-servers/nginx/nginx-1.7.10.ebuild
+++ b/www-servers/nginx/nginx-1.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.7.10.ebuild,v 1.1 2015/03/10 09:34:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/www-servers/nginx/nginx-1.7.10.ebuild,v 1.2 2015/03/10 12:45:41 jlec Exp $
EAPI="5"
@@ -498,11 +498,11 @@ src_configure() {
--with-cc-opt="-I${EROOT}usr/include" \
--with-ld-opt="-L${EROOT}usr/$(get_libdir)" \
--http-log-path="${EPREFIX}"/var/log/${PN}/access_log \
- --http-client-body-temp-path="${EPREFIX}/${NGINX_HOME_TMP}"/client \
- --http-proxy-temp-path="${EPREFIX}/${NGINX_HOME_TMP}"/proxy \
- --http-fastcgi-temp-path="${EPREFIX}/${NGINX_HOME_TMP}"/fastcgi \
- --http-scgi-temp-path="${EPREFIX}/${NGINX_HOME_TMP}"/scgi \
- --http-uwsgi-temp-path="${EPREFIX}/${NGINX_HOME_TMP}"/uwsgi \
+ --http-client-body-temp-path="${EPREFIX}${NGINX_HOME_TMP}"/client \
+ --http-proxy-temp-path="${EPREFIX}${NGINX_HOME_TMP}"/proxy \
+ --http-fastcgi-temp-path="${EPREFIX}${NGINX_HOME_TMP}"/fastcgi \
+ --http-scgi-temp-path="${EPREFIX}${NGINX_HOME_TMP}"/scgi \
+ --http-uwsgi-temp-path="${EPREFIX}${NGINX_HOME_TMP}"/uwsgi \
${myconf} || die "configure failed"
# A purely cosmetic change that makes nginx -V more readable. This can be
@@ -520,9 +520,9 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D%/}" install
- cp "${FILESDIR}"/nginx.conf "${ED}"/etc/nginx/nginx.conf || die
+ cp "${FILESDIR}"/nginx.conf "${ED}"etc/nginx/nginx.conf || die
newinitd "${FILESDIR}"/nginx.initd-r2 nginx
@@ -533,7 +533,7 @@ src_install() {
# just keepdir. do not copy the default htdocs files (bug #449136)
keepdir /var/www/localhost
- rm -rf "${D}"/usr/html || die
+ rm -rf "${D}"usr/html || die
# set up a list of directories to keep
local keepdir_list="${NGINX_HOME_TMP}"/client
@@ -641,9 +641,9 @@ src_install() {
pkg_postinst() {
if use ssl; then
- if [ ! -f "${EROOT}"/etc/ssl/${PN}/${PN}.key ]; then
+ if [ ! -f "${EROOT}"etc/ssl/${PN}/${PN}.key ]; then
install_cert /etc/ssl/${PN}/${PN}
- use prefix || chown ${PN}:${PN} "${EROOT}"/etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
+ use prefix || chown ${PN}:${PN} "${EROOT}"etc/ssl/${PN}/${PN}.{crt,csr,key,pem}
fi
fi
@@ -669,7 +669,7 @@ pkg_postinst() {
ewarn "Check if this is correct for your setup before restarting nginx!"
ewarn "This is a one-time change and will not happen on subsequent updates."
ewarn "Furthermore nginx' temp directories got moved to ${NGINX_HOME_TMP}"
- chmod -f o-rwx "${EPREFIX}"/var/log/nginx "${EPREFIX}/${NGINX_HOME_TMP}"/{,client,proxy,fastcgi,scgi,uwsgi}
+ chmod -f o-rwx "${EPREFIX}"/var/log/nginx "${EPREFIX}${NGINX_HOME_TMP}"/{,client,proxy,fastcgi,scgi,uwsgi}
fi
# If the nginx user can't change into or read the dir, display a warning.